Forum

Results 1 to 3 of 3
  1. #1
    Join Date
    November 2015
    Posts
    1

    teamspeak lagging/crash since update 3.0.18.2

    Hi guys, I have been having this issue for a little over a week now. I have an Astro a40 headset and have been using TS for awhile now, but recently TS crashes, but does not say "Not Responding". When I close it, it gets super laggy (any audio related software as well). I tried re-installing Teamspeak after FULLY uninstalling it, no help. I updated all my audio drivers and firmware, still didnt help. I even did a completely new install of windows and the problem still occurs. It happens randomly, the blue bubbles light up as though someone is talking, but they arnt. They stay lit up and I can't talk. It is like teamspeak froze, without actually freezing. I can re enter the servers, and no more problem, until it wants to randomly happen again.
    I am using windows 10

  2. #2
    Join Date
    November 2015
    Posts
    1
    i'm also experiencing this issue. i've tried every "fix" i could find on the forums to no avail

  3. #3
    Join Date
    June 2012
    Posts
    2

    Angry Sugestion

    Downgrade to 3.0.18.1 until the problem is solved.

    I have the same issue, maybe it's something related with chat logs but i'm not sure yet.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Lagging in teamspeak, but everything is fine in Skype?
    By eXon2 in forum General Questions
    Replies: 0
    Last Post: July 23rd, 2013, 06:34 PM
  2. Teamspeak : my voice is lagging.
    By s1LENT in forum Client Support
    Replies: 0
    Last Post: August 30th, 2011, 07:04 PM
  3. Lagging only in Teamspeak 3
    By Callo in forum Windows
    Replies: 1
    Last Post: April 29th, 2011, 02:02 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •