Forum

Results 1 to 2 of 2
  1. #1
    Join Date
    November 2015
    Posts
    1

    loading VirtualServer(1) failed to start, error: invalid group ID

    Hi, help to understand this problem please.

    Code:
    2015-11-23 22:56:36.640684|INFO    |ServerLibPriv |   | TeamSpeak 3 Server 3.0.11.4 (2015-08-18 13:30:34)
    2015-11-23 22:56:36.641019|INFO    |ServerLibPriv |   | SystemInformation: Linux 3.2.0-4-amd64 #1 SMP Debian 3.2.51-1 x86_64 Binary: 64bit
    2015-11-23 22:56:36.643740|INFO    |DatabaseQuery |   | dbPlugin name:    MySQL plugin, (c)TeamSpeak Systems GmbH
    2015-11-23 22:56:36.643916|INFO    |DatabaseQuery |   | dbPlugin version: 1
    2015-11-23 22:56:37.004769|INFO    |Accounting    |   | Licensing Information
    2015-11-23 22:56:37.005130|INFO    |Accounting    |   | type              : Non-profit
    2015-11-23 22:56:37.005308|INFO    |Accounting    |   | starting date     : Wed Aug 19 00:00:00 2015
    2015-11-23 22:56:37.005425|INFO    |Accounting    |   | ending date       : Mon Feb 22 00:00:00 2016
    2015-11-23 22:56:37.005622|INFO    |Accounting    |   | max virtualservers: 10
    2015-11-23 22:56:37.005779|INFO    |Accounting    |   | max slots         : 512
    2015-11-23 22:56:38.925444|INFO    |              |   | Puzzle precompute time: 1909
    2015-11-23 22:56:38.926118|INFO    |FileManager   |   | listening on 0.0.0.0:30033
    2015-11-23 22:56:38.953894|ERROR   |VirtualServer |  1| VIRTUALSERVER_DEFAULT_SERVER_GROUP points to 0
    2015-11-23 22:56:38.954183|ERROR   |VirtualSvrMgr |   | loading VirtualServer(1) failed to start, error: invalid group ID
    2015-11-23 22:56:38.954471|INFO    |VirtualServerBase|  1| stopped
    2015-11-23 22:56:38.954667|INFO    |CIDRManager   |   | updated query_ip_whitelist ips: 127.0.0.1,
    2015-11-23 22:56:38.954959|INFO    |Query         |   | listening on 0.0.0.0:10011

  2. #2
    Join Date
    June 2008
    Posts
    18,275
    You do not have any default server group (which should be Guest by default).
    In other words, your databse is broken.


    You could try to fix this via ServerQuery

    1. Login into server and start the server in virtual mode
    Code:
    login serveradmin xxxx
    use 1 -virtual
    2. Find the Guest server group
    Code:
    servergrouplist --->>> Now search in the output for name=Guest type=1 and remember the value of ssgid=X
    (2.1 re-create the Guest Group if it was deleted or can not be found)
    Code:
    servergroupcopy ssgid=5 tsgid=0 name=Guest type=1
    ---> Write dowen the ssgid=X
    3. Set the Group as the default group
    Code:
    serveredit virtualserver_default_server_group=X
    4. Start the server
    Code:
    use 0
    serverstart sid=1

    If Step 1 or all fails:
    Use a backup.
    Or start from scratch.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: January 20th, 2017, 07:59 AM
  2. Replies: 3
    Last Post: March 26th, 2013, 08:01 AM
  3. New Server (second virtualserver) - Failed to connect!
    By bo1337 in forum Server Support
    Replies: 1
    Last Post: July 21st, 2011, 08:50 AM
  4. Replies: 0
    Last Post: May 15th, 2010, 05:45 PM
  5. Replies: 0
    Last Post: January 7th, 2010, 12:49 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •