Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 7 of 7
  1. #1
    Join Date
    November 2015
    Posts
    4

    TS3 volume linked to system volume

    I have Windows 7, 64-bit and TS3 client. I use a simple USB headset for a PS4. It has one headphone I use for TS and I use my desktop speakers for music or games. Previously (prior to a reformat), the volume in TS was static, and my system/speaker volume was changed independently. I use a Logitec illuminated keyboard to raise and lower my system volume. Again, it worked fine like that for quite some time.

    After the reformat, my TS volume in my headset is now linked to my system volume. When I raise the sound of my music, my TS volume goes up. This may sound handy, but for me it's not.

    I've done the common fixes...in TS: Setting => Options => Playback... Playback Mode I've set to both Windows Audio Session and Direct Sound. Playback device is set to "Speakers (USB Chat Headset)". I've also made sure under Settings => Plugins... that the TeamSpeak 3 control plugin is enabled. In Windows, Control Panel => Hardware and Sound => Sound => Communications... I have it set to "do nothing".

    I can manually move the volume sliders for Firefox or something and have them different from TS, but as soon as I use the keyboard it evens everything out. One friend suggested I try another keyboard to see if that was the issue. I don't have another keyboard to try, and the current keyboard was installed and used initially without this issue.

  2. #2
    Join Date
    October 2012
    Location
    Germany
    Posts
    553
    You probably have your setup messed up.

    The keyboard's volume buttons are linked to the windows default audio device, unless there's a custom keyboard driver providing configuration for the target (highly unlikely).

    Previously (yay):
    Your Speakers were the windows default device.
    In TeamSpeak playback Options you selected the USB headphone.

    Hence, hitting the keyboard buttons resulted in changing the volume of all that is on the windows default audio device, but not TS (which is not).

    Now (nay):
    Your Headphones are the default audio device.
    In TeamSpeak playback options you selected the Headphones or had default (ergo headphones).

    Hence, hitting the keyboard button results in changing the volume of all that is on the windows default audio device, including TS (which is).

  3. #3
    Join Date
    November 2015
    Posts
    4
    Thank you for the prompt reply. Your explanation was very well worded and easy to understand =) I used it to verify my setting as you described them. It didn't seem to correct the problem, however =( Let me post a few SS's to show my setup:

    Click image for larger version. 

Name:	TS1_zpsztnioo0z.jpg 
Views:	152 
Size:	87.4 KB 
ID:	13227

    Click image for larger version. 

Name:	TS2_zpse4eqcrgm.jpg 
Views:	185 
Size:	133.0 KB 
ID:	13228

  4. #4
    Join Date
    October 2012
    Location
    Germany
    Posts
    553
    Try what happens if you set the "default communications device" to the Realtek Speakers, too.

    It might be that the media buttons on the keyboard control both the system default device as well as the default communications device.

  5. #5
    Join Date
    November 2015
    Posts
    4
    Followed your instructions, but no change in the problem. It took the "default communication device" off the headset and the speakers still say "default device" with no option to change them (if need be).

  6. #6
    Join Date
    October 2012
    Location
    Germany
    Posts
    553
    That should be the intended scenario, actually.

    Note that the TS Client itself, like most communication devices, gives a waffle about the windows communication device implementation.
    If it's set to a specific output, that's the target, if it's set to default, it'll take the windows system default audio device.
    So, excluding the fact that I'd generally prefer Windows Audio Session mode in TS over the outdated DirectSound unless I was on a very old windows version, the strict selection of the Headset should be fine.

    Let's leave the keyboard out of it for now.
    Having set both the default communications device as well as the system default one to speakers, open e.g. Firefox with youtube or whatever, and TS.
    Open the windows volume mixer.
    Note, that much to our surprise there is (should be) no TS listed.
    That's because when you look at the master fader, you note it's for your default device.
    Change the volume for demonstration purposes.
    If you click on that, you can select the device for the application mixer to show (strange sentence, hu).
    If you switch over to Headphones, there's a sole TS fader.
    Note that the Master fader is not at the same position as before - because it's the master fader for another device.

    Hence, if you change the master fader on the default device, any volume will change - except TS as it is on another device.

    That's when we enter the domain of your keyboard keys.
    Afaik those buttons are hard-wired to the volume fader of the default device - it should behave exactly like when moving the fader of your Realtek default audio device - and leave the fader of the Headphone device unaffected.

    If it changes both, that's either windows (having changed that behaviour of those buttons between versions) or something you potentionally can configure in drivers/utility for your keyboard / a generic third party utility might exist.
    There would be settings like "Map keyboard keys", and there *could* be different options for the audio volume media keys, like increase default audio volume or increase volume of x.

  7. #7
    Join Date
    November 2015
    Posts
    4
    When I click on the mixer, it shows the attached image. The left icon is "Headset (USB Chat Headset)" and the right is "Speakers (Realtek High Definition Audio)". If I raise the right slider (speakers), my speaker volume increases and TS does not. HOWEVER, when I raise or lower the volume on the keyboard one click, the slider then shoots down to match the volume of the Headset.

    The same things happens if I move the slider on the left (Headset). TS volume raises and speakers stay low until I raise/lower via the keyboard, then the slider comes down to match the one of the right (Speakers).

    My keyboard set-up utility only has variable binds for the F1-F12 keys.

    Click image for larger version. 

Name:	TS3_zpsiilvrr1i.jpg 
Views:	67 
Size:	16.0 KB 
ID:	13229

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] TS3 volume lowered by system sounds
    By Bodhbh in forum Windows
    Replies: 3
    Last Post: April 10th, 2015, 10:06 AM
  2. Replies: 0
    Last Post: February 17th, 2015, 02:24 AM
  3. Making system volume ignore TS
    By Stroopwafel in forum Windows
    Replies: 2
    Last Post: July 1st, 2012, 09:40 AM
  4. Replies: 3
    Last Post: July 16th, 2011, 03:13 PM
  5. Replies: 0
    Last Post: May 25th, 2011, 08:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •