Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 5 of 5
  1. #1
    Join Date
    January 2016

    Can't open TeamSpeak

    hey guys, i just reseted my pc and installed TS3. But it simply won't open. It's not on the bottom bar or anything, it's just not there. I've tried to reinstall it several times with restarting the PC, but it didn't work either.
    When I tried to shut down the process in the taskmaneger, it says that it cant be closed and closes itself afterwards. maybe someone can link me a fully delete tool for teamspeak or so so i can try to reinstall it. running Win7 home premium and used TS3 for several years without troubles, now after a reinstallation of Win7 on my 256gb Samsung EVO SSD it just doesnt work anymore.

    Thanks for your help


  2. #2
    Join Date
    January 2016

    Newest TeamSpeak 3 won't open

    Hello guys!
    I've been using TS for about 5 years now. I've had some issues before, nothing mentionable, but this is something I can't overcome.
    I formatted my PC yesterday, because reasons, and after that I downloaded TeamSpeak 3 from your official site. Installed it and it just won't open. No error, no nothing, it just won't open. It appears in the Task Manager for a second, but then it disappears. I've tried reinstalling, compatibility mode, Run as Admin, and still nothing. I don't know what to do anymore and this problem affects my gaming experience alot. I also tried downloading older version and it worked like a charm. Of course I couldn't connect to any servers, but at least the program started.

  3. #3
    Join Date
    February 2016

    Teamspeak3 will not open on new PC

    So after building my new PC, everything seems to be working fine but I am unable to open Teamspeak3, even as administrator nothing seems to work. I have reinstalled 4 times with the same problem persisting. I do not get any type of error message, all I get is a little loading wheel for about 3 seconds then that goes away. It is not open in my task window or anything. when I try to see if it processed on task manager. It will only show up for about 5 seconds then disappear. Followed by : werfault.exe. I am running windows 7 home premium (dont laugh at me) lol.

    Im at a lost for words and can not think what is the problem..

  4. #4
    Join Date
    June 2008
    We have no clue about the problem on your computer.
    Read that and follow the steps (if possible).
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  5. #5
    Join Date
    October 2012
    Missing Win7 SP1?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. TeamSpeak does not open
    By fragi in forum Windows
    Replies: 2
    Last Post: December 12th, 2011, 03:16 PM
  2. Open mic only when using Teamspeak
    By SnoFox in forum Windows
    Replies: 0
    Last Post: November 15th, 2011, 04:38 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts