Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 5 of 5
  1. #1
    Join Date
    January 2016

    [Help] Trying to compile and run example plugin, shows Failed to open plugin.

    I'm trying to make my own plugin, and first I want to make sure everything works fine, I have all the headers and source files copied from the pluginsdk to my C++ Project (Visual Studio 2015) and included.. I have it set to build the project to a .dll, the build process runs fine but when I try to load it into TeamSpeak, it fails, only telling me "Plugin failed to load: Failed to open plugin."

    Any help would be appreciated, thanks.

  2. #2
    Join Date
    March 2016
    Hi Ducky,

    I dont use visual studio but it works for me as follow:
    I copied the plugin.c and plugin.h files and compiled it with the gcc compiler like in this link:
    You can try to install the gcc compiler for windows and try to compile with it.

    Please loock in you plugin source code amd make shure, that the init- and shutdown- function are available in your plugin.

    Sorry i am a beginner too and dont have more ideas. I hope that helps.
    Bye Mehonidas
    Last edited by Mehonidas; April 1st, 2016 at 05:41 PM. Reason: he she it s muss mit ;-)

  3. #3
    Join Date
    October 2012
    Note that there's the file ending convention for _win32 & _win64. A 64bit ts client trying to load a 32 bit dll, which would happen with a 32 bit build not following that, would be one cause for that problem.

  4. #4
    Join Date
    September 2012
    It might also be that because you're using 2015 and the TeamSpeak client is using 2013 that there are some incompatibilities between those which may cause your plugin to not be recognized correctly.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  5. #5
    Join Date
    October 2015
    Go to the configuration manager and create a new build group called x64 (instead of Any CPU), this worked for me and I use Visual Studio 2015

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Auto away plugin compile
    By Sandbird in forum Client Plugins / Lua Scripts
    Replies: 0
    Last Post: September 5th, 2013, 01:37 PM
  2. I can't seem to compile the TS3 sample plugin
    By waterfoul in forum Windows
    Replies: 4
    Last Post: February 19th, 2013, 10:48 PM
  3. [Solved] How to compile a plugin?
    By blophy in forum Client Plugins / Lua Scripts
    Replies: 5
    Last Post: December 13th, 2010, 05:52 PM
  4. ts3 overlay plugin (Failed to open plugin)
    By netmario in forum Windows
    Replies: 0
    Last Post: September 22nd, 2010, 08:29 AM
  5. Can't I compile plugin.c with C++ compiler?
    By Pommes in forum Client Plugins / Lua Scripts
    Replies: 3
    Last Post: January 12th, 2010, 02:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts