Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 5 of 5
  1. #1
    Join Date
    August 2015

    TeamSpeak not loading on Win 10

    When i launch TS, i keep seeing my desktop, although it shows me the ts ui when hold alt and press tab to cycle through the processes. I had this error before and solved it by uninstalling TS, removing every nvidia driver i had and completely reinstalling them, then reinstalling TS. Today i tried to fix it that way again, but it didn't work. Can anyone help me?
    Last edited by dante696; March 31st, 2016 at 10:41 AM.

  2. #2
    Join Date
    August 2015

    Fixed it.. kind of

    I now fixed it by doing it the same way as i already described, but this time i also deleted the config file and tada: it works again -.- now i just need to find my favs again

  3. #3
    Join Date
    December 2015

    Unable to launch Teamspeak after download

    All I get is "ts3client_win64" as a process in Task Manager for about 10 seconds. Nothing in the Applications tab for Teamspeak. Nothing appears in the Taskbar. I have tried all variation of options in the setup wizard. This will happen after setup when it is supposed to automatically start and when I try to use the desktop shortcut that was created by the setup wizard. I have uninstalled and reinstalled TS over a dozen times trying different setup options and nothing has changed. This is a new PC build. Very few other applications are installed yet. All drivers are up-to-date. Specs are below.

    CPU: i7-4790k 4.0 GHz
    GPU: PowerColor PCS+ R9 390 8GB
    Mobo: ASUS Z97/USB3.1
    RAM: 1x8GB DDR3 1600 (Second stick was causing computer to Blue Screen so I removed it)
    PSU: Corsair RMx RM850X 850W
    SSD: Crucial M500 CT240M500SSD1 2.5" 240GB SATA III

    Please help. I have been trying to figure this out for hours and have found nothing online that has at all helped.

  4. #4
    Join Date
    February 2016

    Client wont lauch


    so every time i try open the client i get the windows loading little spinning circle but nothing happens. ive tried reinstalling multiple times and running as admin but no joy.

    thanks in advance

  5. #5
    Join Date
    March 2016
    I also have a similar problem. Teamspeak 3 starts and instantly shuts down. I can see the icon in the toolbar tray but it disapears when I try to click it. Please help, having this problem for a while now...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts