Forum

Results 1 to 6 of 6

Thread: Locale question

  1. #1
    Join Date
    December 2009
    Location
    St.Petersburg, Russia
    Posts
    137

    Locale question

    $ cat /etc/default/locale
    LANG="en_US.UTF-8"
    LC_ALL="ru_RU.UTF-8"

    $ locale
    LANG=en_US.UTF-8
    LANGUAGE=
    LC_CTYPE="ru_RU.UTF-8"
    LC_NUMERIC="ru_RU.UTF-8"
    LC_TIME="ru_RU.UTF-8"
    LC_COLLATE="ru_RU.UTF-8"
    LC_MONETARY="ru_RU.UTF-8"
    LC_MESSAGES="ru_RU.UTF-8"
    LC_PAPER="ru_RU.UTF-8"
    LC_NAME="ru_RU.UTF-8"
    LC_ADDRESS="ru_RU.UTF-8"
    LC_TELEPHONE="ru_RU.UTF-8"
    LC_MEASUREMENT="ru_RU.UTF-8"
    LC_IDENTIFICATION="ru_RU.UTF-8"
    LC_ALL=ru_RU.UTF-8

    2016-02-10 18:33:01.690519|WARNING |ServerLibPriv | |The system locale is set to "C" this can cause unexpected behavior. We advice you to repair your locale!

    WAT?

  2. #2
    Join Date
    December 2004
    Location
    RF
    Posts
    3,006
    Are you sure the script that starts your server read the locale settings?

  3. #3
    Join Date
    December 2009
    Location
    St.Petersburg, Russia
    Posts
    137
    I'm using supplied ts3server_startscript.sh to start server. It is started from local user's cron. Maybe locale settings are read only on login shells, but then I don't know how to make it happen when script is started from cron. I believe this code should be included in ts3server_startscript.sh because system-wide everything is configured properly.

  4. #4
    Join Date
    December 2004
    Location
    RF
    Posts
    3,006
    I think that cron is what clearing the environemnt. You could check the user's crontab and include necessary definitions to tweak the environment.
    If you are using Debian based distro, the http://forum.teamspeak.com/threads/1...n-based-distro may be of help.
    Or head over to ubuntu.ru and we can discuss it in a more friendly environment.

  5. #5
    Join Date
    February 2016
    Posts
    2
    create or edit file /etc/sysconfig/i18n

    add or edit the value

    LANG="en_US.UTF-8"

  6. #6
    Join Date
    August 2018
    Posts
    1

    The system locale is set to "C" this can cause unexpected behavior. We advice you to

    Guten Tag, bei mir kommt Folgender Fehler beim Starten des Teamspeaks:

    |WARNING |ServerLibPriv | |The system locale is set to "C" this can cause unexpected behavior. We advice you to repair your locale!

    Was kann ich tun?
    Last edited by dante696; August 2nd, 2018 at 11:16 AM. Reason: merged

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Locale Problem
    By rmz93 in forum Linux / FreeBSD
    Replies: 3
    Last Post: May 25th, 2016, 09:22 AM
  2. Replies: 2
    Last Post: July 3rd, 2015, 09:14 AM
  3. Replies: 2
    Last Post: June 7th, 2015, 02:27 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •