Forum

Results 1 to 8 of 8
  1. #1
    Join Date
    February 2012
    Location
    Nuremberg, Bavaria
    Posts
    258

    server release 3.0.12.1 dies unexpected after 13 minutes

    Hi,

    I've just updated a Test server successful, but the server always dies after ~13 minutes.

    Quote Originally Posted by TS3 Client server log
    <20:18:36> Connected to server: "TeamSpeak ]I[ Server"
    <20:31:03> Connection lost
    The instance log file does not show anything regarding this unexpected shutdown:
    Code:
    2016-02-12 19:19:19.801950|INFO    |ServerLibPriv |   |TeamSpeak 3 Server 3.0.12.1 (2016-02-08 15:34:38)
    2016-02-12 19:19:19.802002|INFO    |ServerLibPriv |   |SystemInformation: Linux 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt9-3~deb8u1 (2015-04-24) x86_64 Binary: 64bit
    2016-02-12 19:19:19.802032|INFO    |ServerLibPriv |   |Using hardware aes
    2016-02-12 19:19:19.812427|INFO    |DatabaseQuery |   |dbPlugin name:    MariaDB plugin, (c)TeamSpeak Systems GmbH
    2016-02-12 19:19:19.812478|INFO    |DatabaseQuery |   |dbPlugin version: 1
    2016-02-12 19:19:19.820042|INFO    |SQL           |   |database updated successfully to revision: 24
    2016-02-12 19:19:19.820882|WARNING |Accounting    |   |Unable to find valid license key, falling back to limited functionality
    2016-02-12 19:19:20.910168|INFO    |              |   |Puzzle precompute time: 1087
    2016-02-12 19:19:20.910271|INFO    |FileManager   |   |listening on 0.0.0.0:30033
    2016-02-12 19:19:20.953238|INFO    |CIDRManager   |   |updated query_ip_whitelist ips: 127.0.0.1,
    2016-02-12 19:19:20.953341|INFO    |Query         |   |listening on 0.0.0.0:10011
    The virtual server log does only show this:
    Code:
    2016-02-12 19:19:20.953145|INFO    |VirtualServer |1  |listening on 0.0.0.0:9987
    Code:
    $ ./ts3server_startscript.sh start
    ts3server.pid found, but no server running. Possibly your previously started server crashed
    Please view the logfile for details.
    Starting the TeamSpeak 3 server
    TeamSpeak 3 server started, for details please view the log file
    The ts3server.pid file does still exists, but the process has been killed/stopped.

    I'm using Debian 8.0 with kernel 3.16.0-4-amd64.

    Is there a bug in the Hotfix version 3.0.12.1?

    I've just started, stopped and started the instance once again to verify, if it's gone or not, but the server always dies after ~13 minutes.

    Code:
    <20:43:01> Connected to server: "TeamSpeak ]I[ Server"
    <20:55:28> Connection lost
    Instance log file:
    Code:
    2016-02-12 19:43:44.830470|INFO    |ServerLibPriv |   |TeamSpeak 3 Server 3.0.12.1 (2016-02-08 15:34:38)
    2016-02-12 19:43:44.830573|INFO    |ServerLibPriv |   |SystemInformation: Linux 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt9-3~deb8u1 (2015-04-24) x86_64 Binary: 64bit
    2016-02-12 19:43:44.830599|INFO    |ServerLibPriv |   |Using hardware aes
    2016-02-12 19:43:44.832356|INFO    |DatabaseQuery |   |dbPlugin name:    MariaDB plugin, (c)TeamSpeak Systems GmbH
    2016-02-12 19:43:44.832375|INFO    |DatabaseQuery |   |dbPlugin version: 1
    2016-02-12 19:43:44.837013|WARNING |Accounting    |   |Unable to find valid license key, falling back to limited functionality
    2016-02-12 19:43:46.245130|INFO    |              |   |Puzzle precompute time: 904
    2016-02-12 19:43:46.245260|INFO    |FileManager   |   |listening on 0.0.0.0:30033
    2016-02-12 19:43:46.298817|INFO    |CIDRManager   |   |updated query_ip_whitelist ips: 127.0.0.1,
    2016-02-12 19:43:46.299118|INFO    |Query         |   |listening on 0.0.0.0:10011
    Virtual server log file:
    Code:
    2016-02-12 19:43:46.298703|INFO    |VirtualServer |1  |listening on 0.0.0.0:9987
    Now I could see something on my SSH console. This was spammed on my SSH session while waiting for the unexpected shutdown:
    Code:
    unknown: debugger aborting because missing DBUG_RETURN or DBUG_VOID_RETURN macro in function "?func"
    Seems to be a bug in the Hotfix, or?
    Last edited by dante696; February 18th, 2016 at 01:34 PM. Reason: merged

  2. #2
    Join Date
    March 2014
    Posts
    2
    Quote Originally Posted by Sebi94 View Post
    I've just started, stopped and started the instance once again to verify, if it's gone or not, but the server always dies after ~13 minutes.

    [...]

    Seems to be a bug in the Hotfix, or?
    I came here looking for confirmation that the update does not cause any issues, and I found this thread. Before we update all our machines to 3.0.12.1, we need to know if this is an actual problem that others are experiencing as well? Please advise if it is in fact safe to update to 3.0.12.1, without causing our clients with severe issues.

  3. #3
    Join Date
    February 2012
    Location
    Nuremberg, Bavaria
    Posts
    258
    There is an exploit since version 3.0.12, which causes a crash of the entire instance.

    This may has been fixed in version 3.0.12.2.

    I need to verify it, because TeamSpeak does not write, which "exploits" were fixed. Instead they are just telling us, that they have fixed something.

  4. #4
    Join Date
    June 2008
    Posts
    18,412
    Your crash has nothing to do with the 3.0.12 exploits.
    The message on your SSH isn't something new (i saw a report for 3.0.11 already) in relationship with MariaDB.

    I think it's a communication problem to the MariaDB / MySQL server.
    But we don't know what causes this -> i asked a dev but can't promise anything.

    I will only reply if i have something new and will not if dev also doesn't know anything.


    //Edit
    It looks like the server does use the wrong mariaDB plugin.
    unknown: debugger aborting because missing DBUG_RETURN or DBUG_VOID_RETURN macro in function "?func"
    Is part of the maria db plugin. but our version has no debug features added.


    Please copy the libmariadb.so.2 from the redist folder into the server main folder and then start your server.
    Last edited by dante696; February 18th, 2016 at 03:43 PM.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  5. #5
    Join Date
    February 2012
    Location
    Nuremberg, Bavaria
    Posts
    258
    Quote Originally Posted by Sebi94 View Post
    There is an exploit since version 3.0.12, which causes a crash of the entire instance.

    This may has been fixed in version 3.0.12.2.

    I need to verify it, because TeamSpeak does not write, which "exploits" were fixed. Instead they are just telling us, that they have fixed something.
    Has been fixed!

    Quote Originally Posted by dante696 View Post
    It looks like the server does use the wrong mariaDB plugin.
    unknown: debugger aborting because missing DBUG_RETURN or DBUG_VOID_RETURN macro in function "?func"
    Is part of the maria db plugin. but our version has no debug features added.


    Please copy the libmariadb.so.2 from the redist folder into the server main folder and then start your server.
    Thanks for this information! Yes, this fixed the problem.

  6. #6
    Join Date
    February 2012
    Location
    Nuremberg, Bavaria
    Posts
    258
    @dante696: Can you please create an internal ticket at TeamSpeak to verify the libary?

    I've just grab the latest version of TS3 server (Linux, x64) last thursday, installed it and had the same problem again. After I've copied the libmariadb.so.2 manually from redist/ directory, the server was working fine.

    I believe, that the archive is still using the old libary. Can you validate this please? Thanks!

  7. #7
    Join Date
    June 2008
    Posts
    18,412
    The server package for Linux x64 does have the latest libmariadb.so incluced in the redist folder. There is no ticket needed for this.

    What you describe is normal, when you update your server without replacing the libmariadb.so in server root folder with the newer libmariadb.so from redist folder.
    You need to replace the libmariadb.so everytime when you update your server when you use mySQL, MaraiDB etc.

    //edit post above and under my post have nothing to do with original thread
    Last edited by dante696; June 13th, 2016 at 07:27 PM. Reason: this thread is now mixed with 2 topics........
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  8. #8
    Join Date
    February 2012
    Location
    Nuremberg, Bavaria
    Posts
    258
    dante696, please read carefully!

    I did not update my server. I've just installed a fresh one by downloading the archive, unzipping it, setting up ts3server.ini and db.ini. After that I've started the server the first time with the ts3server.ini and I got this error immediately.

    At a fresh installation, this file should be in the root directory of the archive, where the ts3server_startscript.sh file is also located, but it isn't. Instead I had to copy it from redist/ directory to the root directory of the installation.

    Quote Originally Posted by server_quickstart.txt
    Also you need the libmariadb(.dll/.so/.dylib) library in the same directory, or in your systems search path. TeamSpeak
    has provided one for you in the redist directory. You can choose to copy that one, or you can use
    one that is installed on your system (Linux/FreeBSD), or you can download an official one from
    MariaDB themselves
    here: https://downloads.mariadb.org/client-native/ .
    That is an acceptable answer. Thanks!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: March 5th, 2015, 01:49 PM
  2. Unexpected talk events (server side)
    By Mitragrad in forum General Questions
    Replies: 0
    Last Post: May 30th, 2014, 08:07 AM
  3. Replies: 1
    Last Post: June 26th, 2013, 03:27 PM
  4. server syntax error at line 6: `D1=$' unexpected
    By Felidor in forum Linux / FreeBSD
    Replies: 6
    Last Post: April 30th, 2012, 03:05 PM
  5. Replies: 7
    Last Post: September 13th, 2010, 04:46 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •