Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 5 of 5
  1. #1
    alQamar Guest

    How to correctly udpate to 3.0.12.x from

    Hello everyone,

    I recently tried to upgrade my TS3 to 3.0.12 running into the issue that the TS server crashed after a period of time.
    Also, the version string in the root (visible in the client)

    like Version: auf Windows did not update to 3.0.12 as usual.

    To avoid further crashes I restored the backup of the server.
    Usually, to update the server I shut down the Process, extract all files from the server zip file to the TS 3 directory.

    The fact that this time I ran in to this issue and also the version number did not update on the client, I was curious if the copying of files is really everything I need to do.
    In the TS3\SQL directory there are several SQL Update scripts and I wonder if I had to apply them manually to ensure that not only the binaries but also the database is being updated.

    We use ts3server.sqlitedb

    Please keep in mind I never did that before so fear that my DB scheme does not match the current one 3.0.12.x might need.

    Thanks for your help in advance!

  2. #2
    Join Date
    September 2012
    The server automatically updates the database if need be for a very long time already. So just replacing the files is sufficient.
    You may have started the wrong server binary though as some names changed with recent versions.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  3. #3
    alQamar Guest

    still reporting old version

    Hello Chris,

    I am still facing the same issue.
    Meanwhile I have checked the database with SQLLiteMan and I found some of the updates that I saw in the SQL Update files, so I assume the database is up to date.

    However when I connect to my TS server with a client it still states
    Version on Windows, while it should be which binaries I've copied in the TS Server folder as usual.

    I have no explaination for this strange behaviour.
    Also connecting with YaTQA to the server will print the release.
    Any ideas?

  4. #4
    Join Date
    June 2008
    Quote Originally Posted by Chris View Post
    You may have started the wrong server binary though as some names changed with recent versions.
    Please read the changelog!
    Last edited by Chris; February 16th, 2016 at 02:39 PM.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  5. #5
    alQamar Guest

    Exclamation I can read... but

    Quote Originally Posted by dante696 View Post
    Please read the changelog!
    I have read the changelog and now I understand what Chris pointed out with wrong binary... jesus I am not a dev nor linux freak. If he would have said "you started wrong exe file" I could imagine something.

    Now I noticed they renamed the exe file. I have deleted the old ts3_*x64.exe now and startes tsserver.exe. Issue solved.
    Thanks for your help!
    Last edited by alQamar; February 19th, 2016 at 09:59 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. TS3 nit working correctly
    By SomeYank in forum Bug Reports [EN/DE]
    Replies: 0
    Last Post: December 20th, 2011, 06:00 PM
  2. Ts 3 won´t work correctly
    By Kleinlarsen in forum Windows
    Replies: 4
    Last Post: October 27th, 2010, 01:50 PM
  3. TS G15 Overlay - not working correctly
    By TheOmen in forum Suggestions and Feedback
    Replies: 1
    Last Post: May 28th, 2010, 08:53 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts