Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 2 of 2
  1. #1
    Join Date
    October 2010
    67 retrieves only "TS" if run from cronjob

    Hey guys,

    i used the file from here several times, including via a timed cronjob.

    Since some weeks now the cronjob which calls the file, retrieves only one line with the content: (ts3_snapshot_X.txt)
    The process itself returns:
    Invalid number of lines from snapshot retrieval, aborting
    View X/ts3_snapshot_X.txt for details
    If i run the ./ file manually, the process to retrieve the snapshot takes some time but it works as expected.
    For me it seems like the cronjob is retrieving the snapshot, but abortes due to some time it takes - could this be possible?

    Nothing changed since the script worked via a cronjob, expect the size of the TeamSpeak 3 Database.

    Greetings, FireEmerald

    ps.: The cronjob doesn't call the file directly, it calls a script which calls the file:
    Attached Files Attached Files

  2. #2
    Join Date
    October 2010


    Update: Tested some changes but nothing worked.
    Yesterday i reverted all changes in the script itself and just edited the time when the script is executed from 3:00 to 4:00. Now the pullsnapshot script executed as expected - no idea why. Seems like something else must go on at 3:00 with the server/ts3server itself.

    Greetings, FireEmerald

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. TS3 Cronjob
    By michi119 in forum Linux / FreeBSD
    Replies: 6
    Last Post: January 19th, 2010, 09:45 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts