Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 3 of 3
  1. #1
    Join Date
    March 2016
    United States

    Unable to set and save push to talk

    I used to be able to use push to talk just fine but since two days ago it started doing this.

    Even though I select it and press apply it just goes back to voice detection.

    I am running on TS3 Version
    The headset I use is an Astro A50 headset.
    Running Windows 10

    I tried running TS in administrator to see if that would change anything but it still won't allow me to use it. I have also tried reinstalling TeamSpeak but it still hasn't solved the problem and I tried changing my hotkey for push to talk. I have no idea what is causing the problem. Any feed back would be helpful. c:

  2. #2
    Join Date
    June 2008
    The client reloads the settings from the settings.db after you did apply anything to it.
    And for some reason the client could not save the settings into the settings.db.

    Could be that the settings.db is write protected or the user does not have permissions to write into the file.
    I can reporduce it in these ways.
    Do you get any error on client start?

    Could also be that the file is broken.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    March 2016
    United States
    I used to get client start-up crashes but now it stopping doing that. I can run TeamSpeak just fine now I just have to use Voice Activation Detection. Would Deleting the settings.db and allowing the client to make a new one be a fix?

    Edit- Just realized that when you delete the settings.db you lose all your saved bookmarks and contacts. Luckily, I have a backup but it is the one with the PTT issue.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: August 10th, 2014, 05:12 PM
  2. Unable To Select Push To Talk Key
    By Hassan in forum Bug Reports [EN/DE]
    Replies: 8
    Last Post: June 16th, 2011, 10:30 AM
  3. Replies: 3
    Last Post: May 29th, 2011, 02:56 AM
  4. Unable to force push to talk
    By Ebay01 in forum Off Topic
    Replies: 1
    Last Post: May 23rd, 2011, 07:30 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts