Forum

Results 1 to 4 of 4
  1. #1
    Join Date
    March 2016
    Posts
    1

    Start server error using MariaDB

    I turned on my server using MariaDB and it worked. But after a few minutes I was off launch me the error:

    CRITICAL|DatabaseQuery | |setSQLfromFile( file:sql/client_get_by_uid.sql) failed
    And now when I try to start the server gives me the error:

    CRITICAL|DatabaseQuery | |setSQLfromFile( file:sql/properties_list_by_string_id.sql) failed
    ----------------------------------------------------------------------------------------------------------------------------------------------------------------

    I have the two .so files

    *libts3db_mariadb.so
    *libmariadb.so.2

    ----------------------------------------------------------------------------------------------------------------------------------------------------------------

    My configs and more

    machine_id=
    default_voice_port=9987
    voice_ip=0.0.0.0
    licensepath=
    filetransfer_port=30033
    filetransfer_ip=0.0.0.0
    query_port=10011
    query_ip=0.0.0.0
    query_ip_whitelist=query_ip_whitelist.txt
    query_ip_blacklist=query_ip_blacklist.txt
    dbplugin=ts3db_mariadb
    dbpluginparameter=ts3db_mariadb.ini
    dbsqlpath=sql/
    dbsqlcreatepath=create_mariadb/
    dbconnections=10
    logpath=logs
    logquerycommands=0
    dbclientkeepdays=30
    logappend=0
    query_skipbruteforcecheck=0

    #I try to delete the ' but dont work#

    [config]
    host='127.0.0.1'
    port='3306'
    username='ts3'
    password='y6XVWE783UqZ24YC'
    database='mythalium_voice_ts3'
    socket=
    COMMANDLINE_PARAMETERS="inifile=ts3server.ini"${2} ""

  2. #2
    Join Date
    June 2008
    Posts
    17,724
    The server could not write into your database. And it looks like the server does have problems reading the sql files.
    Are you sure your user does have permissions to read in sql folder? Or maybe the files in sql folder are broken or missing.

    Try to download the latest server again and then extract the content over your current installation.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    May 2014
    Posts
    12
    Will try that and let you know

  4. #4
    Join Date
    December 2010
    Location
    United Kingdom
    Posts
    324
    Quote Originally Posted by alienienigenagamer View Post
    I turned on my server using MariaDB and it worked. But after a few minutes I was off launch me the error:



    And now when I try to start the server gives me the error:



    ----------------------------------------------------------------------------------------------------------------------------------------------------------------

    I have the two .so files

    *libts3db_mariadb.so
    *libmariadb.so.2

    ----------------------------------------------------------------------------------------------------------------------------------------------------------------

    My configs and more
    COMMANDLINE_PARAMETERS="dbplugin=ts3db_mariadb dbpluginparameter=ts3db_mariadb.ini dbsqlcreatepath=create_mariadb/ default_voice_port=9987 voice_ip=0.0.0.0 filetransfer_ip=0.0.0.0 filetransfer_port=30033 query_ip=0.0.0.0 query_port=10011 dbconnections=15 logappend=1 query_buffer_mb=20"

    Please fix your command line parameter and start as user shell not root.
    Last edited by hunterpl; November 4th, 2017 at 01:34 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: September 22nd, 2015, 03:28 PM
  2. TS3-Server stops after about 24 minutes using MariaDB
    By whfor in forum Linux / FreeBSD
    Replies: 2
    Last Post: April 15th, 2015, 03:53 PM
  3. Teamspeak server shutdown randomly (3.0.11.1 MariaDB)
    By xxFankxx in forum Server Support
    Replies: 4
    Last Post: December 12th, 2014, 01:00 AM
  4. TS3 server Debian MariaDB not working (Permissions bug?)
    By triggerim in forum Linux / FreeBSD
    Replies: 4
    Last Post: July 12th, 2014, 01:22 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •