Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 9 of 11 FirstFirst ... 7891011 LastLast
Results 121 to 135 of 160
  1. #121
    Join Date
    June 2008
    Posts
    18,513
    At the moment it looks like a permission issue on your machine.
    The message below is related here
    2018-04-12 04:17:37.677492|ERROR |Accounting | |failed to register local accounting service
    Matching forum thread Instance-check-error-no-Key-on-start-(on-Windows)
    But you get the Token. Could be trough the changes in new accounting system.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  2. #122
    Join Date
    April 2018
    Posts
    3
    Quote Originally Posted by dante696 View Post
    At the moment it looks like a permission issue on your machine.
    The message below is related here

    Matching forum thread Instance-check-error-no-Key-on-start-(on-Windows)
    But you get the Token. Could be trough the changes in new accounting system.
    Interesting. With the older version of ts3server it was staying open but no one could join, the log looked the exact same with no errors. What is weird is that we can all connect if I delete the sqldb and start again and leave that server key window open. I'm happy to allow remote access through something like ultraviewer.net if this will help at all, otherwise I'm just doing this workaround until then.


    EDIT:
    I found a log from 04/07, which is when this first started (before I updated my ts3server.exe), it was getting that exact error you mentioned in the thread:

    2018-04-07 17:57:50.546829|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.0.13.8 (2017-07-19 08:26:51)
    2018-04-07 17:57:50.547328|INFO |ServerLibPriv | |SystemInformation: Windows 10 (17133) x64 (AMD or Intel) Binary: 64bit
    2018-04-07 17:57:50.547328|INFO |ServerLibPriv | |Using hardware aes
    2018-04-07 17:57:50.547827|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, (c)TeamSpeak Systems GmbH
    2018-04-07 17:57:50.547827|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
    2018-04-07 17:57:50.548326|INFO |DatabaseQuery | |checking database integrity (may take a while)
    2018-04-07 17:57:50.562803|WARNING |Accounting | |Unable to find valid license key, falling back to limited functionality
    2018-04-07 17:57:50.563801|ERROR |Accounting | |failed to register local accounting service
    2018-04-07 17:57:50.563801|ERROR |ServerLibPriv | |Server() error while starting servermanager, error: instance check error
    Last edited by Pseudami; April 14th, 2018 at 04:56 AM.

  3. #123
    Join Date
    April 2018
    Posts
    2

    Server stops on Win 2012 R2 Server (failed to update local accounting service)

    Hi,

    I manage a website and teamspeak server for a small gaming clan. I installed TeamSpeak on a dedicated Windows 2012 R2 server. Everything seems to work fine, clan members can connect to the TeamSpeak Server and use it. However, it seems that TS randomly just stops or shuts down. I then have to log into my server and manually start the TS Server again.

    Below are the last three sets of log files:

    ================================================== ========>>


    ts3server_2018-04-26__18_15_05.400251_0.log

    2018-04-26 18:15:05.400251|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.1.2 (2018-04-24 06:11:19)
    2018-04-26 18:15:05.400251|INFO |ServerLibPriv | |SystemInformation: Windows Server 2012 R2 (9600) x64 (AMD or Intel) Binary: 64bit
    2018-04-26 18:15:05.400251|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, (c)TeamSpeak Systems GmbH
    2018-04-26 18:15:05.400251|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
    2018-04-26 18:15:05.400251|INFO |DatabaseQuery | |checking database integrity (may take a while)
    2018-04-26 18:15:05.431502|WARNING |Accounting | |Unable to open licensekey.dat, falling back to limited functionality
    2018-04-26 18:15:05.462754|INFO |Accounting | |Licensing Information
    2018-04-26 18:15:05.462754|INFO |Accounting | |licensed to : Anonymous
    2018-04-26 18:15:05.462754|INFO |Accounting | |type : No License
    2018-04-26 18:15:05.462754|INFO |Accounting | |starting date : Wed May 31 22:00:00 2017
    2018-04-26 18:15:05.462754|INFO |Accounting | |ending date : Fri Aug 31 22:00:00 2018
    2018-04-26 18:15:05.462754|INFO |Accounting | |max virtualservers: 1
    2018-04-26 18:15:05.462754|INFO |Accounting | |max slots : 32
    2018-04-26 18:15:07.556601|INFO | | |Puzzle precompute time: 2031
    2018-04-26 18:15:07.556601|INFO |FileManager | |listening on 0.0.0.0:30033, [::]:30033
    2018-04-26 18:15:07.572226|INFO |CIDRManager | |updated query_ip_whitelist ips: 127.0.0.1/32, ::1/128,
    2018-04-26 18:15:07.572226|INFO |Query | |listening on 0.0.0.0:10011, [::]:10011
    2018-04-26 19:30:40.561998|ERROR |Accounting | |failed to update local accounting service


    ts3server_2018-04-26__18_15_05.400251_1.log

    2018-04-26 18:15:07.572226|INFO |VirtualServer |1 |listening on 0.0.0.0:9987, [::]:9987
    2018-04-26 19:30:40.687011|INFO |VirtualServerBase|1 |stopped

    ---------------------------------------------------------------->

    ts3server_2018-04-26__19_30_57.958764_0.log

    2018-04-26 19:30:57.958764|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.1.2 (2018-04-24 06:11:19)
    2018-04-26 19:30:57.958764|INFO |ServerLibPriv | |SystemInformation: Windows Server 2012 R2 (9600) x64 (AMD or Intel) Binary: 64bit
    2018-04-26 19:30:57.958764|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, (c)TeamSpeak Systems GmbH
    2018-04-26 19:30:57.958764|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
    2018-04-26 19:30:57.958764|INFO |DatabaseQuery | |checking database integrity (may take a while)
    2018-04-26 19:30:57.990016|WARNING |Accounting | |Unable to open licensekey.dat, falling back to limited functionality
    2018-04-26 19:30:58.021268|INFO |Accounting | |Licensing Information
    2018-04-26 19:30:58.021268|INFO |Accounting | |licensed to : Anonymous
    2018-04-26 19:30:58.021268|INFO |Accounting | |type : No License
    2018-04-26 19:30:58.021268|INFO |Accounting | |starting date : Wed May 31 22:00:00 2017
    2018-04-26 19:30:58.021268|INFO |Accounting | |ending date : Fri Aug 31 22:00:00 2018
    2018-04-26 19:30:58.021268|INFO |Accounting | |max virtualservers: 1
    2018-04-26 19:30:58.021268|INFO |Accounting | |max slots : 32
    2018-04-26 19:31:00.896401|INFO | | |Puzzle precompute time: 2813
    2018-04-26 19:31:00.896401|INFO |FileManager | |listening on 0.0.0.0:30033, [::]:30033
    2018-04-26 19:31:00.927651|INFO |CIDRManager | |updated query_ip_whitelist ips: 127.0.0.1/32, ::1/128,
    2018-04-26 19:31:00.927651|INFO |Query | |listening on 0.0.0.0:10011, [::]:10011
    2018-04-26 19:32:39.292763|ERROR |Accounting | |failed to update local accounting service


    ts3server_2018-04-26__19_30_57.958764_1.log

    2018-04-26 19:31:00.927651|INFO |VirtualServer |1 |listening on 0.0.0.0:9987, [::]:9987
    2018-04-26 19:32:39.419060|INFO |VirtualServerBase|1 |stopped


    ================================================== ========>>

    The last set of log files are the current log files. And the TS server is currently working fine.

    The dedicated server I use is my own server (I develop websites), and is on permanently.

    I've added a screenshot of my TeamSpeak Client that shows the messages when the TS Server stops.

    Any suggestions?

    Thank you.
    Attached Images Attached Images  

  4. #124
    Join Date
    June 2008
    Posts
    18,513
    For some reasons your Windows user doesn't have the permission to create a permanent shared object (SE_CREATE_PERMANENT_NAME).
    https://msdn.microsoft.com/de-de/lib...(v=vs.85).aspx

    We wonder why it appears after server did start successfully.
    Normally this message should appear after server start "Server() error while starting servermanager, error: instance check error"
    Something on your system/permissions may change during the run time.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  5. #125
    Join Date
    April 2018
    Posts
    2
    Quote Originally Posted by dante696 View Post
    For some reasons your Windows user doesn't have the permission to create a permanent shared object (SE_CREATE_PERMANENT_NAME).
    https://msdn.microsoft.com/de-de/lib...(v=vs.85).aspx

    We wonder why it appears after server did start successfully.
    Normally this message should appear after server start "Server() error while starting servermanager, error: instance check error"
    Something on your system/permissions may change during the run time.

    Hi, thank you for the reply. I've added the "Administrators" group to the "Create permanent shared objects" object under "Local Security Policy >> Local Policy >> User Rights Assignment"

    Is that correct?

  6. #126
    Join Date
    June 2008
    Posts
    18,513
    Yep, but you should not use an Admin account to run the server.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  7. #127
    Join Date
    June 2018
    Posts
    1

    Dev Info for this problem

    I recently encountered a similar problem to this, which I have resolved. I am providing the sequence which I think my have caused it in hopes of it being resolved in future releases.

    I recently did a clean install of Windows 10 1803. I had a backup of my server, so I copied it to the new build. I use a separate drive for this, D:\, so that permissions will not be a problem. I have done this many times in the past without problems. I have a firewall I use, instead of Windows Firewall. I usually have WFW disabled. This time, after I installed my firewall, I forgot to disable WFW. I copied TS3 server and ran it to make sure it started. I got a notice from WFW asking to allow the TS3 Server traffic. Instead of allowing it, I clicked the X to close the window. I also got a firewall notification from Local Security authority subsystem service, trying to connect to the internet and verify the TS3 server application. I temporarily blocked this request. I disabled WFW, unblocked LSASS and tried the TS3 Server again. My firewall has a rule to always allow the TS3 server access to the internet. I NEVER received another notification that LSASS was trying to verify the application. I think this is the root of the problem.
    I created another user account, ran the TS3 server and immediately got another firewall request for LSASS to access the internet and verify the TS3 server. I allowed this request and voila, the server works. This user account uses the exact same firewall configuration as my other account, so It can be ruled out as the cause.

    The problem seems to be related to the fact that the LSASS never authorizes the TS3 server. I am not an expert on LSASS, but I know that it can prevent apps from working if they do not get verified. Maybe this is why the "ERROR |Accounting | |failed to register local accounting service" happens.

    Shinring.

  8. #128
    Join Date
    June 2018
    Posts
    2

    Server auto shutdown

    This issue only happened recently, before this it was all fine.
    When i open the server exe file, it opens for about 2 secs before it closes by itself. Anyone knows how to fix?
    Last edited by dante696; June 2nd, 2018 at 10:45 AM. Reason: merged

  9. #129
    Join Date
    June 2008
    Posts
    18,513
    Please read or show your server log.
    Nobody can fix anything without knowing what the problem is.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  10. #130
    Join Date
    June 2018
    Posts
    2
    Quote Originally Posted by dante696 View Post
    Please read or show your server log.
    Nobody can fix anything without knowing what the problem is.


    2018-06-02 09:25:52.333435|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.2.0 (2018-05-08 06:11:20)
    2018-06-02 09:25:52.334435|INFO |ServerLibPriv | |SystemInformation: Windows 10 (17134) x64 (AMD or Intel) Binary: 64bit
    2018-06-02 09:25:52.334435|INFO |ServerLibPriv | |Using hardware aes
    2018-06-02 09:25:52.334435|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, (c)TeamSpeak Systems GmbH
    2018-06-02 09:25:52.334435|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
    2018-06-02 09:25:52.335434|INFO |DatabaseQuery | |checking database integrity (may take a while)
    2018-06-02 09:25:52.345433|WARNING |Accounting | |Unable to open licensekey.dat, falling back to limited functionality
    2018-06-02 09:25:52.350431|ERROR |Accounting | |failed to register local accounting service
    2018-06-02 09:25:52.350431|INFO |Accounting | |Licensing Information
    2018-06-02 09:25:52.350431|INFO |Accounting | |licensed to : Anonymous
    2018-06-02 09:25:52.350431|INFO |Accounting | |type : No License
    2018-06-02 09:25:52.350431|INFO |Accounting | |starting date : Wed May 31 22:00:00 2017
    2018-06-02 09:25:52.350431|INFO |Accounting | |ending date : Fri Aug 31 22:00:00 2018
    2018-06-02 09:25:52.350431|INFO |Accounting | |max virtualservers: 1
    2018-06-02 09:25:52.350431|INFO |Accounting | |max slots : 32
    2018-06-02 09:25:53.413242|INFO | | |Puzzle precompute time: 1048
    2018-06-02 09:25:53.413242|INFO |FileManager | |listening on 0.0.0.0:30033, [::]:30033
    2018-06-02 09:25:53.425236|INFO |CIDRManager | |updated query_ip_whitelist ips: 127.0.0.1/32, ::1/128,
    2018-06-02 09:25:53.425236|INFO |Query | |listening on 0.0.0.0:10011, [::]:10011




    2018-06-02 09:25:53.424237|INFO |VirtualServer |1 |listening on 0.0.0.0:9987, [::]:9987
    2018-06-02 09:25:53.432233|INFO |VirtualServerBase|1 |stopped

  11. #131
    Join Date
    June 2018
    Posts
    1

    TS3 used to work but suddenly won't launch.

    Hi, this is my first time posting a new thread so I apologize if I do something wrong.

    My server which I have been running since early october last year from my own computer recently stopped working, whenever it is launched it just shuts down instantly.
    I tried a fresh install, but it didn't fix anything and yes, before anyone asks I have restarted my computer.

    Here are the logs
    TS3logs.zip

    If anyone can help me out, it'd be greatly appreciated.
    Last edited by dante696; June 4th, 2018 at 09:27 AM. Reason: merged

  12. #132
    Join Date
    March 2016
    Location
    Belgium
    Posts
    12
    Quote Originally Posted by loopymoomoo View Post
    Hi, this is my first time posting a new thread so I apologize if I do something wrong.

    My server which I have been running since early october last year from my own computer recently stopped working, whenever it is launched it just shuts down instantly.
    I tried a fresh install, but it didn't fix anything and yes, before anyone asks I have restarted my computer.

    Here are the logs
    TS3logs.zip

    If anyone can help me out, it'd be greatly appreciated.

    My reply might just be useless, but I'll try to do my best anyway.
    I compared your logs with the one from my server, and they look the same (Expect mine has more "icon not found errors.).
    And, the logs looks the same as when you just shut down the TeamSpeak Server.
    There is nothing which state a crash.
    Just a normal boot and a stop.


    It doesn't give any error with the accounting servers or server manager.
    (Which the most errors in this topic do)

    So, this is what I can think off. I really hopes it helps, otherwise let me know and I'll search further.
    - Could there be something on your system which kills the program? (I has this issue once with a clean up tool which killed the instance because of some "idle" stuff)
    - Have you made any recent changes to the hosting pc? Maybe one of these changes caused this.
    - ***Worst thing I'll ever say, be warned when doing this***; Could you try running it as an admin process?
    Some of my friends has this error, and running it as an admin gave it some sudden magic.


    I really hopes this helped, or will help.
    If it doesn't let me know so that I know it as well and I'll look further.



    EDIT:
    That's only what I can think off.
    I'll be useless if it doens't work

    EDIT 2:
    It's useless, ignore this post.

  13. #133
    Join Date
    July 2018
    Posts
    1

    Accounting error..

    Hey there, this is similar to the instance check error but without that portion of it.

    Rebuilt my Windows server, upgrading from 2012 to 2016, and now I can't run my small TS server.

    It boots the first time, until I use the priv key. After that if I shutdown and restart it, it fails to start. Log follows:

    Code:
    2018-07-14 01:55:14.686600|INFO    |ServerLibPriv |   |TeamSpeak 3 Server 3.2.0 (2018-05-08 06:11:20)
    2018-07-14 01:55:14.686600|INFO    |ServerLibPriv |   |SystemInformation: Windows Server 2016 (14393) x64 (AMD or Intel) Binary: 64bit
    2018-07-14 01:55:14.686600|INFO    |DatabaseQuery |   |dbPlugin name:    SQLite3 plugin, Version 3, (c)TeamSpeak Systems GmbH
    2018-07-14 01:55:14.686600|INFO    |DatabaseQuery |   |dbPlugin version: 3.11.1
    2018-07-14 01:55:14.686600|INFO    |DatabaseQuery |   |checking database integrity (may take a while)
    2018-07-14 01:55:14.717851|WARNING |Accounting    |   |Unable to open licensekey.dat, falling back to limited functionality
    2018-07-14 01:55:14.717851|ERROR   |Accounting    |   |failed to register local accounting service
    2018-07-14 01:55:14.717851|INFO    |Accounting    |   |Licensing Information
    2018-07-14 01:55:14.717851|INFO    |Accounting    |   |licensed to       : Anonymous
    2018-07-14 01:55:14.717851|INFO    |Accounting    |   |type              : No License
    2018-07-14 01:55:14.717851|INFO    |Accounting    |   |starting date     : Wed May 31 22:00:00 2017
    2018-07-14 01:55:14.717851|INFO    |Accounting    |   |ending date       : Fri Aug 31 22:00:00 2018
    2018-07-14 01:55:14.717851|INFO    |Accounting    |   |max virtualservers: 1
    2018-07-14 01:55:14.717851|INFO    |Accounting    |   |max slots         : 32
    2018-07-14 01:55:16.967847|INFO    |              |   |Puzzle precompute time: 2187
    2018-07-14 01:55:16.967847|INFO    |FileManager   |   |listening on 0.0.0.0:30033, [::]:30033
    2018-07-14 01:55:16.999093|INFO    |CIDRManager   |   |updated query_ip_whitelist ips: 127.0.0.1/32, ::1/128, 
    2018-07-14 01:55:16.999093|INFO    |Query         |   |listening on 0.0.0.0:10011, [::]:10011
    Code:
    2018-07-14 01:55:16.983471|INFO    |VirtualServer |1  |listening on 0.0.0.0:9987, [::]:9987
    2018-07-14 01:55:16.999093|INFO    |VirtualServerBase|1  |stopped
    After that the process dies, the temp files for sqllite go away and nothing else happens.
    Last edited by dante696; July 15th, 2018 at 12:20 AM. Reason: merged

  14. #134
    Join Date
    July 2018
    Posts
    2

    Server stops itself after few seconds

    Hello, I would like to host a free version of TS Server. I'm using the latest version 3.2.0.
    I've set up a MariaDB database correctly, tables are created during the first run (had hard time to choose the correct collate setting which turned out to be utf8mb4_unicode_ci) but then it always stops after few seconds.

    logs dont'say anything useful but I'm reporting them here

    _0 log
    Code:
    2018-07-14 10:02:20.906929|INFO    |ServerLibPriv |   |TeamSpeak 3 Server 3.2.0 (2018-05-08 06:11:20)
    2018-07-14 10:02:20.922553|INFO    |ServerLibPriv |   |SystemInformation: Windows Server 2008 R2 SP1 (7601) x64 (AMD or Intel) Binary: 64bit
    2018-07-14 10:02:20.922553|INFO    |ServerLibPriv |   |Using hardware aes
    2018-07-14 10:02:20.922553|INFO    |DatabaseQuery |   |dbPlugin name:    MariaDB plugin, version 3, (c)TeamSpeak Systems GmbH
    2018-07-14 10:02:20.922553|INFO    |DatabaseQuery |   |dbPlugin version: 2
    2018-07-14 10:02:20.969428|WARNING |Accounting    |   |Unable to open licensekey.dat, falling back to limited functionality
    2018-07-14 10:02:20.969428|ERROR   |Accounting    |   |failed to register local accounting service
    2018-07-14 10:02:20.969428|INFO    |Accounting    |   |Licensing Information
    2018-07-14 10:02:20.969428|INFO    |Accounting    |   |licensed to       : Anonymous
    2018-07-14 10:02:20.969428|INFO    |Accounting    |   |type              : No License
    2018-07-14 10:02:20.969428|INFO    |Accounting    |   |starting date     : Wed May 31 22:00:00 2017
    2018-07-14 10:02:20.969428|INFO    |Accounting    |   |ending date       : Fri Aug 31 22:00:00 2018
    2018-07-14 10:02:20.969428|INFO    |Accounting    |   |max virtualservers: 1
    2018-07-14 10:02:20.969428|INFO    |Accounting    |   |max slots         : 32
    2018-07-14 10:02:24.641256|INFO    |              |   |Puzzle precompute time: 3625
    2018-07-14 10:02:24.656881|INFO    |FileManager   |   |listening on 0.0.0.0:30033
    2018-07-14 10:02:24.719380|INFO    |CIDRManager   |   |updated query_ip_whitelist ips: 127.0.0.1/32, ::1/128, 
    2018-07-14 10:02:24.719380|INFO    |Query         |   |listening on 0.0.0.0:10011
    _1 log
    Code:
    2018-07-14 10:02:24.703755|INFO    |VirtualServer |1  |listening on 0.0.0.0:9987
    2018-07-14 10:02:24.735005|INFO    |VirtualServerBase|1  |stopped
    It just says VirtualServerBase|1 stopped

    Please help on how can I troubleshoot this
    Last edited by dante696; July 15th, 2018 at 12:13 AM. Reason: merged

  15. #135
    Join Date
    June 2008
    Posts
    18,513
    Log 0 says it.
    There is an error in there. This error does not allow you to run servers.

    Thread merged
    See Post 33
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] Instance check error / failed to register local accounting service on Linux
    By dani4u87 in forum Linux / FreeBSD
    Replies: 126
    Last Post: January 22nd, 2020, 05:22 PM
  2. Replies: 5
    Last Post: June 1st, 2016, 02:11 PM
  3. Replies: 2
    Last Post: August 20th, 2010, 02:31 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •