Forum

Results 1 to 2 of 2
  1. #1
    Join Date
    April 2016
    Posts
    1

    While teamspeak is running my complete audio stutters, but only on my headset

    As said in the title, while teamspeak is running my audio from other things like youtube or spotify or laggy, they just sound like shit. So the wohle pc sound is bugged, but only for my headset not for my display for example.

    Specs: Logitech G430, Windows 10, Teamspeak latest Version

    If you need more informations just tell me which

    Hope you are able to help me
    Firestorm

  2. #2
    Join Date
    June 2008
    Posts
    17,710
    Tell us which client version is this.
    Are you using the usb soundcard for this headset or the onboard soundcard?
    Is the latest driver installed for target device?
    Which audio playback do you use in the client settings?
    What is your CPU usage saying?
    Are latest updates installed?

    Note: There are known problems with Logitech G Headsets on Windows 10
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Audio Problems While Teamspeak is Running
    By AustinJamesG in forum General Questions
    Replies: 0
    Last Post: July 15th, 2013, 06:03 PM
  2. ts3 audio to headset game audio to speakers?
    By wayland in forum Client Support
    Replies: 1
    Last Post: January 29th, 2010, 08:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •