Forum

Page 2 of 6 FirstFirst 1234 ... LastLast
Results 16 to 30 of 80
  1. #16
    Join Date
    March 2003
    Location
    Birmingham & Wales
    Posts
    7
    I have the exact same problem.

    I am running Suse 7.0

    ldd server_Linux produces:
    /lib/libNoVersion.so.1 => /lib/libNoVersion.so.1 (0x40015000)
    libpthread.so.0 => /lib/libpthread.so.0 (0x4001b000)
    libdl.so.2 => /lib/libdl.so.2 (0x4002e000)
    libc.so.6 => /lib/libc.so.6 (0x40032000)
    /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

    dir structure is:

    -rwxr--r-- 1 games games 725 Mar 2 20:15 Readme.txt
    drwxr-xr-x 3 games games 1344 Mar 2 20:17 httpdocs
    -rwxr--r-- 1 games games 616692 Mar 2 20:18 server_linux
    -rwxr--r-- 1 games games 2594 Dec 7 15:20 slicense.txt
    -rwxr--r-- 1 games games 233084 Mar 2 20:18 sqlite.so
    drwxr-xr-x 2 games games 1296 Mar 2 20:18 sqlite_sql
    -r-xr--r-- 1 games games 751 Aug 26 2002 tss.SuSE_startscript
    -r-xr--r-- 1 games games 358 Aug 26 2002 tss.minimal_startscript

    and the errorlog shows

    ---------------------------------------------------------------
    -------------- log started at 03-03-03 20:06 -------------
    ---------------------------------------------------------------
    03-03-03 20:06:01,ALL,Info,server, Server init initialized
    03-03-03 20:06:01,ALL,Info,server, Server version: 2.0.19.16 Linux
    03-03-03 20:06:01,ERROR,All,SQL, Database initialization error: Library "sqlite.dll" not found.
    03-03-03 20:06:01,ERROR,All,SQL, Database initialization error: Library "sqlite.dll" not found.
    03-03-03 20:06:01,ERROR,All,SERVER, Start_TeamSpeak_Server: unable to open sqlite database
    ----------------------------------------------------------
    ---------------------------------------------------------------
    --------------- log ended at 03-03-03 20:06 --------------
    ---------------------------------------------------------------

    this is the first and only entry.

  2. #17
    Join Date
    June 2002
    Location
    Northern California
    Posts
    314
    Don't know if this helps, but Googling for "sql lite" turned up this:

    http://www.go-mono.com/sqlite.html

    Is the .so installed?

    (How will other DB's be supported? I'm anxious to integrate TS2 with my MySQL DB and want to be prepared when that capability is implemented.)

  3. #18
    Join Date
    March 2003
    Location
    NY
    Posts
    11
    i'm in your boat spleasure. i'm running slackware 8.1 and the only one i don't have is the libNoVersion.so.1 i'm DL'in an rpm package and i'll get back in here with a link if it worked.

    ok not only do you need glibc you need glibc-common first... grrr still working on it.

    ok i found the file we need libNoVersion.so.1 (no tar, not rpm, just the file) http://www.mit.edu/afs/athena/system...ller/root/lib/

    it still does nothing! i changed to the /lib dir and saw everyone of .so that is "missing." so i'm going to need more info.
    Last edited by veruca; March 4th, 2003 at 05:26 PM.

  4. #19
    Join Date
    March 2003
    Location
    UK
    Posts
    2
    Sorry to say, but I'm with Veruca.

    Have just downloaded and "installed" the latest RPM, verified that all the relevant files:-

    libNoVersion.so.1
    libpthread.so.0
    libdl.so.2
    libc.so.6
    ld-linux.so.2

    are where they should be. Reinstalled the TSS2_RC2 server, run it trying both ./server-linux from the installation directory and the tss_minimal_startscript.

    Still get the "error starting daemon. Aborted" message although clients can connect to the server.

    however ldd sqlite.so is now only reporting on libc.so.6 and ld-linux.so.2

    ldd on server_linux still reports on all five library files.

    Does any one have any ideas?

  5. #20
    Join Date
    August 2002
    Location
    Earth
    Posts
    20
    As far as I can see, the problem is with sqlite. When I run "ldd sqlite.so", I get this error message:

    ./sqlite.so: /lib/libc.so.6: version `GLIBC_2.2' not found (required by ./sqlite.so)

    Apparently it was compiled on a different distribution than the server binary ? If yes, it would be nice of the developers to update the release with a correctly compiled sqlite. I think I'll try to build my own in the meantime, though.

    I'm still running Red Hat 6.2 here, based on glibc 2.1 ! Don't ask me to upgrade just for Teamspeak (I won't).

    Update:

    RC2 finally works after building sqlite myself. The developers should really build sqlite on the same machine as the server and include it.

    Silz: if you get the "aborted" message but your clients can connect, then TS2 works. I got this error message even with RC1, no idea why.
    Last edited by wossName; March 5th, 2003 at 03:33 PM.

  6. #21
    Dashel Guest
    I too will be shutting down my TS server until this issue is resolved. I do not plan on upgrading to glibc 2.2 either.

  7. #22
    Join Date
    December 2002
    Location
    Vancouver, Canada
    Posts
    35
    I am running FreeBSD 4.7 with linux bindary compatability...
    I supposedly need
    libNoVersion.so.1
    libpthread.so.0
    libdl.so.2
    libc.so.6
    ld-linux.so.2

    however... IT RUNS! and ppl can connect.
    the only thing is... I can't get admin access to my server or superadmin access...
    using either the webadmin, or the admin login from the client.

    RC1 ran fine... but the user and channel management of RC2 are 100x better.

  8. #23
    stedlj Guest

    Question Runs but error?

    - System -
    Redhat 8.0 (Fully Updated)
    500mhz K6 384meg Ram

    TS2 RC1 ran fine

    From the command line the new version I have
    1) Wiped it out and made a clean install
    2) Changed CHMOD to 777 for it
    3) Checked ldd server_linux
    /lib/libNoVersion.so.1 => /lib/libNoVersion.so.1 (0x40013000)
    libpthread.so.0 => /lib/libpthread.so.0 (0x40020000)
    libdl.so.2 => /lib/libdl.so.2 (0x40050000)
    libc.so.6 => /lib/libc.so.6 (0x40053000)
    /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
    4) Checked ldd sqlite.so
    libc.so.6 => /lib/libc.so.6 (0x40046000)
    /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)
    5) When I Run ./tss.minimal_startscript start
    and I get
    Error starting daemon. Aborted
    Runtime error 231 at 08058CF1

    I have tried as 'root' just incase it was a permission problem but same results.

    Buy it is running and I can connect from my Windows box?

  9. #24
    Join Date
    March 2003
    Location
    Pompey, England
    Posts
    46
    I have the very same problem - and even using b22 the below is true.

    I can start RC2 and it gives the 'Error starting daemon. Aborted' fault, yet all is up and running.

    I have tried various hacks, but cannot pin down what is going on.

    As an aside, I am still running RC1 (with anti-nag patch applied) until Tuesday (2 days time from the date of this post), and then moving to RC2 for testing.

    But I need to ask - Why code in an expiry date??? That really seems screwy to me.

    Nick

  10. #25
    Join Date
    July 2002
    Location
    Netherlands
    Posts
    303
    Because we're bastards....
    and wanted everybody to upgrade So people would be forced to tell us about their problems. It's not like this anymore but it helped us a lot in the past Sorry for the inconvenience.

  11. #26
    Join Date
    April 2003
    Location
    Germany
    Posts
    19
    Got a Cobalt Raq3 (should be an i386 compatible cpu).

    all fine for server_linux :

    [[email protected] tss2_rc2]$ ldd server_linux
    /lib/libNoVersion.so.1 => /lib/libNoVersion.so.1 (0x40015000)
    libpthread.so.0 => /lib/libpthread.so.0 (0x4001a000)
    libdl.so.2 => /lib/libdl.so.2 (0x4002d000)
    libc.so.6 => /lib/libc.so.6 (0x40031000)
    /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)


    upgraded to glibc 2.2 (took me a few hours, because i first needed a new gcc then a new version of make and so on, and because i would have need some more for glibc 2.3.1 i upgraded only to 2.2) and now sqlite.so looks fine too :

    [[email protected] tss2_rc2]$ ldd sqlite.so
    libc.so.6 => /usr/local/lib/libc.so.6 (0x4003b000)
    /usr/local/lib/ld-linux.so.2 => /usr/local/lib/ld-linux.so.2 (0x80000000)


    but i still get this error :

    ---------------------------------------------------------------
    08-04-03 22:50:09,ALL,Info,server, Server init initialized
    08-04-03 22:50:09,ALL,Info,server, Server version: 2.0.19.16 Linux
    08-04-03 22:50:09,ERROR,All,SQL, Database initialization error: Library "
    sqlite.dll" not found.
    08-04-03 22:50:09,ERROR,All,SQL, Database initialization error: Library "
    sqlite.dll" not found.
    08-04-03 22:50:09,ERROR,All,SERVER, Start_TeamSpeak_Server: unable to open s
    qlite database
    ----------------------------------------------------------


    somebody above posted he recompiled or manually installed sqlite and then it worked, can anyone confirm this ?

    btw real mysql access would be cool since i already have a mysql db setup on my server, so it would be np for ts to connect to this...

  12. #27
    Join Date
    April 2003
    Location
    Germany
    Posts
    19
    one more thing, where do i get this b22 developer version ? somebody posted a link to the ftp voice.teamspeak.org/developer/server/

    but i need a password to connect, damn

  13. #28
    Join Date
    August 2002
    Location
    Earth
    Posts
    20
    That information is in the "Developer Releases" forum, links are in the first post.

  14. #29
    Join Date
    April 2003
    Location
    Germany
    Posts
    19
    same error with b22

    any news on sqlite manual installing ?

  15. #30
    Join Date
    August 2002
    Location
    Earth
    Posts
    20
    I simply grabbed the sources off the SQLite homepage, compiled and installed it (installing might not be necessary), and replaced the sqlite.so in the Teamspeak directory with the one I built myself. You should read the SQLite documentation, the build process is slightly non-standard.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 18
    Last Post: April 20th, 2011, 10:34 PM
  2. Issues moving TS3 server from 32-bit linux to 64-bit linux
    By DreamPhysix in forum Linux / FreeBSD
    Replies: 1
    Last Post: March 10th, 2011, 07:43 AM
  3. Linux server install for low-skill-in-linux-terminal guy
    By flakz0r in forum Linux / FreeBSD
    Replies: 5
    Last Post: December 30th, 2010, 08:03 AM
  4. Replies: 0
    Last Post: February 24th, 2010, 04:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •