Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 6 of 6
  1. #1
    Join Date
    April 2016

    Unhappy Teamspeak Server() error while starting servermanager, error: instance check error

    I get the following error when starting my server (although it worked yesterday)

    The two errors of importance are below, the full log is below them

    25/04/2016 19:07:45.118 [1]Server log message: failed to register local accounting service
    25/04/2016 19:07:45.120 [1]Server log message: Server() error while starting servermanager, error: instance check error

    25/04/2016 19:07:44.756 [4]Server log message: TeamSpeak 3 Server (2015-06-10 10:47:37) SDK
    25/04/2016 19:07:44.756 [4]Server log message: SystemInformation: Windows Vista SP2 (6002) x64 (AMD or Intel) Binary: 32bit
    25/04/2016 19:07:44.757 [4]Server log message: Using hardware aes
    25/04/2016 19:07:44.758 [2]Server log message: Unable to find valid license key, falling back to limited functionality
    25/04/2016 19:07:45.118 [1]Server log message: failed to register local accounting service
    25/04/2016 19:07:45.120 [1]Server log message: Server() error while starting servermanager, error: instance check error
    25/04/2016 19:07:45.121 Error initialzing serverlib: instance check error
    25/04/2016 19:07:45.122 Server lib version: [Build: 1433933257] SDK
    25/04/2016 19:07:45.130 Error creating virtual server: server library not initialized (1802)

    I don't really understand why yesterday this working and today its not. I'm only starting one server at a time. The client slots never exceed 16, so I'm not sure what issue I'm actually causing. I've restarted my pc a few times, there are no other TS servers on my network.

    As for sample code, I'm using the minimal TS server example basically, except the logic is wrapped in a class (which shouldn't matter).

    I did see stuff in about how this can happen in unix machines and the TS server process needs to run as root. Well the process I've integrated the TS server is always running as root fyi.

    Using windows 10 by the way

    Any help is appreciated


  2. #2
    Join Date
    April 2016
    I guess a better question might be, how is the license stuff determined on windows platforms?

  3. #3
    Join Date
    June 2008
    I guess your Windows user does miss permissions

    Quote Originally Posted by xxteknolustxx View Post
    I guess a better question might be, how is the license stuff determined on windows platforms?
    Putting the license into the root folder of the server (where you start he binary) should help.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  4. #4
    Join Date
    April 2016
    Sorry if I've been misinformed, but my assumption was that I did not need to provide a license to utilize the free mode for teamspeak sdk. I'm only starting one server at a time and not exceeding more than 10 clients (haven't even tried more than 4)

    Is that not correct?

    Also a reboot made the issue go away, so I'm still a little confused at this inconsistent behavior. I verified no other TS servers were running and nothing was listening on my ts port. I should mention I did delete the binaries (the ts library dlls and the soundbackends) as well, not sure if this helped.

    My windows user does have the correct permissions fyi, my only user on the machine is the admin user.

  5. #5
    Join Date
    October 2012
    Now that me be a little bit of a long shot, but here's a theory.
    As mentioned somewhere in the forum, shared memory is used for comm with local accounting service.
    This, I'm pretty sure should be implemented in the server either by native windows api, boost native windows - or boost portable shared mem.
    In the later case, boost utilizes temp files. Those are stored in ProgrammData\boost_interprocess.
    Now, I could imagine if the server shuts down improperly and thereby files that'd get deleted on a proper one are left over - that could cause trouble on proceeding launches.
    So, if there actually is such a folder, you might have a look if it makes a difference if you temporarily rename that folder when the trouble occurs / keep an eye on activity there.

    Admin/Root should afaik be irrelevant, even discouraged for a pub server, the only issue I'm aware of would be write access to a file (e.g. a license file) if the whole thing is in an UAC-protected area which I don't think is applicable here (and solely using an admin account wouldn't help against that), assuming your working directory is out of there.

  6. #6
    Join Date
    April 2016
    Thanks for the answers guys, but no one has really provided me what I would call a correct solution.

    The error I mentioned happens for tons of unix users (enough that the unix solution is packaged with the Teamspeak sdk docs), but for windows it seems like people just assume you aren't running as admin or you are running multiple TS servers (or giving answers that go no where).

    Both these articles have literally the same problem I mentioned and there are multiple people with unresolved problems here, with the same proposed solutions each time that DON'T even explain the problem in the first place.

    In this problem scenario, I am always running as admin (the only user on my machine is the admin), and always running one server at a time (otherwise I would actually require a license).

    The only solution that works is restarting my computer, but that shouldn't be required (the server is most def not running). One piece I did find to be interesting, if I was to force close my app (with the TS integrated into it), this issue would sometimes pop up. It's like when the process is exited forcibly, the teamspeak server does not clean up whatever it uses to start the TS server/validate license stuff (but I can't be sure about this, since I don't have access to the source). This ties to the last persons post which to me seems to be somewhat related to the problem in general.

    Is the source available for the teamspeak sdk?
    Can anyone provide any additional troubleshooting steps to help me?
    Can a developer look at this and actually tell me whats wrong?


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] Instance check error / failed to register local accounting service on Linux
    By dani4u87 in forum Linux / FreeBSD
    Replies: 126
    Last Post: January 22nd, 2020, 05:22 PM
  2. Replies: 159
    Last Post: November 13th, 2019, 09:04 AM
  3. Replies: 16
    Last Post: October 24th, 2012, 01:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts