Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 3 of 3
  1. #1
    Join Date
    April 2016
    Posts
    2

    Headset and spam protection errors.

    Teamspeak 3.0.19.1
    Windows 8.1 64 bit
    GeForce GTX 750 Ti driver 364.72

    I have two monitors and a headset. I get sound from one monitor as the 'default device' the head set is set up as the 'default communication device', and the second monitor is disabled for sound. When I connect to a TS3 server and press my push-to-talk button I get the following text in the text area: Action currently not possible due to spam protection. Please wait a few seconds and try again. I also hear a voice saying 'Error'. This continues to repeat until I disconnect from the server. While this is happening, if I open the Sound window (shows the sound devices) I can see my headset disabled and then re-enabled. If someone is talking on the channel I am connected to I can hear them on the primary monitor and then on the headset.

    I have uninstalled and reinstalled Teamspeak, rebooted my computer, switched sound from one monitor to the other and back again, and disabled and re-enabled the headset. I have also gone through the setup for Teamspeak to ensure that the headset is selected as the default device. I'm not sure what else to try to either fix the problem or get more information to identify the cause. I also have Mumble installed, and can connect and speak to friends on a server without problems - not sure if that eliminates anything as a possible problem.

    I followed a thread on the spam protection, it said to adjust the anti-flood points, but the levels they gave are the ones the server has set and I can't make changes to it anyways.

    Yesterday
    1 uninstalled and re-installed Teamspeak
    2 Reboot of computer
    3 Shifted sound from one monitor to other
    4 Verified setup with Teamspeak
    5 Verified latest driver for video/sound was installed.
    Today
    1 Attempted to connect with other Teamspeak server - same problem
    2 Disabled sound on second monitor - no affect
    3 Removed second monitor - no effect

    If I connect and TRY to talk
    1 In Windows Sound (where you can select default device and such) my headset begins to cycle disabled and enabled
    2 In Teamspeak it show my mic and speakers muted/disabled
    3 The text error for spam protection begins with the lovely voice saying 'Error'.

    If I connect and DO NOT try to talk
    1 For a few seconds everything is normal
    2 Items 1 through 3 from above begin to happen

    If you can suggest something to try or do to resolve or create more information to isolate/identify the cause - please post it.

    Headset is a USB connect headset - moved from a USB2 port to a USB3 port and everything works fine. Plugged it back to a different USB2 port and problem returned, and going to a different USB3 port made the problem go away. Something about a USB2 port is the root cause of the problem, work around is to swap to a USB3 port.
    Last edited by blackship; April 29th, 2016 at 08:46 PM. Reason: more information

  2. #2
    Join Date
    April 2016
    Posts
    2

    More information

    My Video card is GeForce GTX 750 Ti.

    I disabled the second monitor for sound. Now when I open Teamspeak, connect with a server, and try to talk
    1. In Teamspeak my mic and speaker is muted.
    2. The cycling between disabling and re-enabling of my headset in Windows begins
    3. The error text from my post above appears in Teamspeak

    If I open Teamspeak, connect with a server, and do not try to talk
    1. After a few seconds my mic is muted
    2. Shortly after that the cycling on my headset begins
    3. Which results in the error text for spam protection.

    I have verified that I have the current and up to date drivers for video and sound.

    I have tried to connect to other Teamspeak servers and had the same problem.
    I have disconnected one of the monitors and tried to connect with only one monitor and headset - no joy.

  3. #3
    Join Date
    October 2012
    Location
    Germany
    Posts
    553
    [Edith for reading]
    That USB part. Flood protection could be triggered if the audio device is lost and found in rapid iteration yes.
    Most likely the USB device isn't getting enough power. USB power is shared in pairs of slots, so the device "combination" could be key.
    USB 3 in this case simply works because it's on a seperate circuit, not because it's USB 3.
    Either that or there's indeed a problem between the USB Audio driver of the headset and the USB drivers. In any case that's sth. that can be seen through, but not corrected by fixing a bug (as it ain't a bug in TS).

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: December 8th, 2014, 10:33 AM
  2. [No Bug] Action currently not possible due to spam protection.
    By ara9al in forum Windows
    Replies: 1
    Last Post: October 8th, 2014, 08:17 AM
  3. disbable spam protection for me?
    By Jtadtr in forum Server Support
    Replies: 5
    Last Post: September 28th, 2014, 07:19 PM
  4. [Resolved] Action currently not possible due to spam protection..
    By fasterthanlight in forum Server Support
    Replies: 13
    Last Post: February 8th, 2014, 02:38 PM
  5. Action currently not possible due to spam protection.
    By newbyb0y in forum Client Support
    Replies: 5
    Last Post: June 21st, 2013, 03:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •