Hey fellas..

Im having trouble connecting too a certain teamspeak server, that my guild uses in a game.
I have tried to hide all the places it shows IP; dont know if its safe to post that shit online

What does it say? Error message:
<12:59:49> Trying to resolve hostname "HidingIPBecauseiDontKnowIfIShouldPostIt.killumina ti.eu"
<12:59:53> Trying to connect to server on "HidingIPBecauseiDontKnowIfIShouldPostIt.killumina ti.eu"
<12:59:59> Failed to connect to server

26-05-2016 10:59:18 Info TeamSpeak 3 Client 3.0.19 (2016-04-01 09:48:51)
26-05-2016 10:59:18 Info SystemInformation: Windows 10 (10586) x64 (AMD or Intel) Binary: 32bit
26-05-2016 10:59:18 Direct Sound Debug setting timer resolution to 1ms
26-05-2016 10:59:18 Info Loading plugin: appscanner_plugin
26-05-2016 10:59:18 Info Loading plugin: clientquery_plugin
26-05-2016 10:59:18 Info Loading plugin: lua_plugin
26-05-2016 10:59:18 Info Loading plugin: teamspeak_control_plugin
26-05-2016 10:59:18 Info Loading plugin: test_plugin
26-05-2016 10:59:18 Info Loading plugin: ts3g15
26-05-2016 10:59:18 Query Info listening on "Hiding.0.0.1:25639
26-05-2016 10:59:19 Windows Audio Session Devel DeviceDeleteList::waitForDeletes - enter
26-05-2016 10:59:19 Windows Audio Session Devel DeviceDeleteList::waitForDeletes - leave
26-05-2016 10:59:19 Info *** Time [BUILD_GUI]: 115
26-05-2016 10:59:19 Info *** Time [SERVERVIEW_ACTIONS]: 193
26-05-2016 10:59:19 Info *** Time [SERVERVIEW]: 333
26-05-2016 10:59:19 Info *** Time [SERVERVIEWMANAGER]: 458
26-05-2016 10:59:19 Input Info Default monitoring enabled
26-05-2016 10:59:19 Info *** Time [MAINWINDOW]: 1055
26-05-2016 10:59:19 Info *** Time [INIT]: 1056
26-05-2016 10:59:19 ClientUI Info Qt version: 5.5.1
26-05-2016 10:59:19 ClientUI Info Using configuration location: C:\Users\Mattias\AppData\Roaming\TS3Client\setting s.db
26-05-2016 10:59:20 ClientUI Info Last update check was: on maj 25 15:31:58 2016
26-05-2016 10:59:20 ClientUI Info Checking for update
26-05-2016 10:59:20 Update Info Checking for updates...
26-05-2016 10:59:21 Newsticker Info Newsticker next check: on maj 25 16:02:00 2016
26-05-2016 10:59:21 Update Info Check license version: 1
26-05-2016 10:59:21 Update Info Check client version: 3.0.19.1 1461588969
26-05-2016 10:59:21 Update Info Update check, my version: 1459504131, latest version: 1461588969
26-05-2016 10:59:21 Newsticker Info Newsticker not found for language da
26-05-2016 10:59:22 Newsticker Info Newsticker received for language da, expires on to maj 26 13:29:21 2016, next check in 1800 seconds
26-05-2016 10:59:30 Info Statistics report: User previously denied participation
26-05-2016 10:59:49 ClientUI Info Connect to server: "HidingIPBecauseiDontKnowIfIShouldPostIt.killumina ti.eu"
26-05-2016 10:59:49 ClientUI Info Trying to resolve "HidingIPBecauseiDontKnowIfIShouldPostIt.killumina ti.eu"
26-05-2016 10:59:49 TSDNS Info SRV DNS resolve unsuccessful for "_ts3._udp.HidingIPBecauseiDontKnowIfIShouldPostIt .killuminati.eu"
26-05-2016 10:59:49 TSDNS Info No SRV TSDNS found at "_tsdns._tcp.HidingHidingHiding.eu"
26-05-2016 10:59:49 TSDNS Info No SRV TSDNS found at "_tsdns._tcp.HidingIPBecauseiDontKnowIfIShouldPost It.killuminati.eu
26-05-2016 10:59:49 TSDNS Info DNS resolve successful, "HidingIPBecauseiDontKnowIfIShouldPostIt.killumina ti.eu"=104.18.37.184
26-05-2016 10:59:53 ClientUI Info Lookup finished: "blabla".18.37.184 9987 "HidingIPBecauseiDontKnowIfIShouldPostIt.killumina ti.eu" 0 0
26-05-2016 10:59:53 ClientUI Info Resolve successful: "Blabla".18.37.184:9987
26-05-2016 10:59:53 ClientUI Info Blacklist check ok
26-05-2016 10:59:53 ClientUI Info Initiating connection: "BlaBla".18.37.184:9987 "HidingIPBecauseiDontKnowIfIShouldPostIt.killumina ti.eu"
26-05-2016 10:59:53 Windows Audio Session Devel DeviceDeleteList::waitForDeletes - enter
26-05-2016 10:59:53 Windows Audio Session Devel DeviceDeleteList::waitForDeletes - leave
26-05-2016 10:59:53 Windows Audio Session Debug WAS:penDevice-enter
26-05-2016 10:59:53 Windows Audio Session Debug WAS Buffer size: 1056
26-05-2016 10:59:53 Windows Audio Session Debug WAS:penDevice-leave
26-05-2016 10:59:53 Windows Audio Session Debug WAS::startDevice-enter
26-05-2016 10:59:53 Windows Audio Session Debug WAS::startDevice-leave
26-05-2016 10:59:54 Windows Audio Session Devel DeviceDeleteList::waitForDeletes - enter
26-05-2016 10:59:54 Windows Audio Session Devel DeviceDeleteList::waitForDeletes - leave
26-05-2016 10:59:54 Windows Audio Session Debug WAS:penDevice-enter
26-05-2016 10:59:54 Windows Audio Session Debug WAS Buffer size: 1056
26-05-2016 10:59:54 Windows Audio Session Debug WAS:penDevice-leave
26-05-2016 10:59:54 PreProSpeex Info Speex version: speex-1.2beta3
26-05-2016 10:59:54 Windows Audio Session Debug WAS::startDevice-enter
26-05-2016 10:59:54 Windows Audio Session Debug WAS::startDevice-leave
26-05-2016 10:59:54 Windows Audio Session Debug WAS::associateAECDevice-enter
26-05-2016 10:59:54 Windows Audio Session Debug WAS Buffer size: 1056
26-05-2016 10:59:54 Windows Audio Session Debug WAS::associateAECDevice-leave
26-05-2016 10:59:54 ClientUI Info Connect status: Connecting
26-05-2016 10:59:59 ClientUI Info Connect status: Disconnected
26-05-2016 10:59:59 ClientUI Info Failed to connect to server, want autoreconnect = 0

What have i tried?????

- My friends can connect, the server is running.
- I have flushed my DNS thingy using ipconfig /flushdns
- I can connect too multiple other TS servers (tried 5 diffrent)
- I have tried too connect via. the xxx.xx.xx.x:xxxx IP thingy instead of the name thingy

What i think the problem is from my google searching
The server is blocking my public IP and i need too call my ISP and make them open a port of smth
(I found this info by searching this forum)

What my question realy is
Can i use a proxy or some other fancy solution?? (if yes how) Instead of calling my provider and all that???

Please help