Forum

Results 1 to 13 of 13
  1. #1
    Join Date
    March 2014
    Location
    Germany
    Posts
    54

    Server 3.0.12.4 does crash with encryption/rsa_puzzle.cpp:465;

    If you can't understand this translation, because of my bad english, i can provide a german translation. Maybe someone would translate this in a better english.

    Hello,

    our TeamSpeak 3 Server is now crashed again.
    In the first restart attempt he has also crashed with an error message.
    It happens more often lately, that the server is crashed, but we found no cause.
    Maybe you know more. And i hope you can help me.
    I will as soon as possible to adjust that core dumps are created and hand them in.
    If you need something that is not already in this post, please write it to me. I will add every information you need.

    Best regards,
    Markus

    System Information:
    TeamSpeak 3 Server Version: 3.0.12.4 (2016-04-25 15:16:45)
    Operating System: Linux 3.2.0-4-amd64 #1 SMP Debian 3.2.78-1 x86_64 Binary: 64bit

    Logs:
    All abnormal messages and error messages (Instance Log) (The clock goes back only about a minute.):
    Code:
    2016-05-14 17:50:44.744786|WARNING |PktHandler    |   |detected incorrectly running system clock (>)
    2016-05-18 14:32:54.085646|WARNING |              |   |Accounting connection stalled
    End of Instance Log before the server crashed (This Query Logins are completly normal! So there is no message about the crash.):
    Code:
    2016-05-24 11:02:52.928211|INFO    |Query         |   |query from 5724 *.*.*.*:***** issued: login with account "serveradmin"(serveradmin)
    2016-05-24 11:05:02.893263|INFO    |Query         |   |query from 5725 *.*.*.*:***** issued: login with account "serveradmin"(serveradmin)
    2016-05-24 11:05:07.934264|INFO    |Query         |   |query from 5726 *.*.*.*:***** issued: login with account "serveradmin"(serveradmin)
    2016-05-24 11:05:38.934598|INFO    |Query         |   |query from 5727 *.*.*.*:***** issued: login with account "serveradmin"(serveradmin)
    2016-05-24 11:06:29.563543|INFO    |Query         |   |query from 5728 *.*.*.*:***** issued: login with account "serveradmin"(serveradmin)
    End of Virtual Server Log before the server crashed (There is no Warning, Error, or any other abnormal message in the log):
    Code:
    2016-05-24 11:03:55.355833|INFO    |VirtualServerBase|1  |client connected '***'(id:12157) from *.*.*.*:*****
    2016-05-24 11:04:53.896336|INFO    |VirtualServerBase|1  |client connected '***(id:15222) from *.*.*.*:*****
    2016-05-24 11:04:59.696923|INFO    |VirtualServerBase|1  |client connected '***'(id:12655) from *.*.*.*:*****
    Message which was shown when I tried to start the Server with the normal runscript:
    Code:
    2016-05-24 11:11:41.467967|CRITICAL|              |   |Assertion "my_sz <= static_cast<unsigned int>(bytesNeeded)" failed at ../../../../s/deps/teamspeak_common_lib/src/encryption/rsa_puzzle.cpp:465;
    2016-05-24 11:11:41.467995|CRITICAL|              |   |Assertion "my_sz <= static_cast<unsigned int>(bytesNeeded)" failed at ../../../../s/deps/teamspeak_common_lib/src/encryption/rsa_puzzle.cpp:465;
    2016-05-24 11:11:41.468021|CRITICAL|              |   |Assertion "my_sz <= static_cast<unsigned int>(bytesNeeded)" failed at ../../../../s/deps/teamspeak_common_lib/src/encryption/rsa_puzzle.cpp:465;
    Last edited by dante696; June 2nd, 2016 at 02:56 PM. Reason: merged

  2. #2
    Join Date
    March 2014
    Location
    Germany
    Posts
    54
    This post is now 7 days old.
    And since I have created that post, I haven't got any reply.
    And it would be great if anyone can tell me what this error means.

  3. #3
    Join Date
    June 2008
    Posts
    17,812
    Please make sure you use the stable server and not the pre 3.0.12.4
    http://www.teamspeak.com/downloads

    About the message "detected incorrectly running system clock (>)"
    It's to much to explain here, please read this post in other thread.
    http://forum.teamspeak.com/threads/1...ot-log-message
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  4. #4
    Join Date
    March 2014
    Location
    Germany
    Posts
    54
    @dante696
    Yes, I'm using the final version.
    I'm never using the pre-releases for servers.

  5. #5
    Join Date
    June 2008
    Posts
    17,812
    We thought this was fixed, but it seems the problem still does exist.
    I've send you a private message.


    //I moved the posts of this thread to an own thread (again ).
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  6. #6
    Join Date
    October 2011
    Posts
    15

    TS3 Server Crash

    PHP Code:
    2016-06-17 15:00:22.424790|CRITICAL|              |   |Assertion "my_sz <= static_cast<unsigned int>(bytesNeeded)" failed at ../../../../s/deps/teamspeak_common_lib/src/encryption/rsa_puzzle.cpp:465
    Server crashed with that error this morning and last night I got this:

    PHP Code:
    2016-06-17 08:43:06.613907|CRITICAL|Accounting    |   |The accounting thread has stalledTerminating the server 
    It's probably not related though.
    Last edited by dante696; June 20th, 2016 at 07:44 AM. Reason: merged

  7. #7
    Join Date
    March 2014
    Location
    Germany
    Posts
    54
    A long time ago I got this error too.
    See: http://forum.teamspeak.com/threads/1...puzzle-cpp-465

    At the moment we are using the version with the debug outputs but the server has no crashes since the crash i have reported.
    For me it seems to be a random bug that comes randomly. But I don't know something special about it.
    (My english is wow, isn't it ?)

  8. #8
    Join Date
    June 2008
    Posts
    17,812
    We still don't know why the server does crash with that critical ;(

    hakkuo23 which operation system and which server version are you using?
    You missed some details in your report.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  9. #9
    Join Date
    October 2011
    Posts
    15
    Quote Originally Posted by dante696 View Post
    We still don't know why the server does crash with that critical ;(

    hakkuo23 which operation system and which server version are you using?
    You missed some details in your report.
    Gentoo x64 and 3.0.12.4.

  10. #10
    Join Date
    March 2014
    Location
    Germany
    Posts
    54
    Wie ich sehe, gibt man sich möglich viel Mühe um die Behebung von Problemen.
    Das die Private Nachricht bzgl. Crashes nach knapp 2 Wochen immer noch nicht gelesen wurde, unterstreicht dies.
    Ich werde mich bei Gelegenheit um ein Restart-Skript kümmern. Scheint wohl besser zu sein.

  11. #11
    Join Date
    June 2008
    Posts
    17,812
    Natürlich geben wir uns mühe und inzwischen haben wir sogar per Debug server und der Mühe vom Member Schlumpi mehr Details zum crash, aber halt noch keinen bugfix bereit.

    Zum random crash oder was auch immer da passiert:
    Bitte sicherstellen, dass diese Fehler vom Betriebssystem oder der Hardware behoben ist. Das kann (muss aber nicht) verursachen, dass der Prozess einfach aus geht.
    Quote Originally Posted by dante696 View Post
    About the message "detected incorrectly running system clock (>)"
    It's to much to explain here, please read this post in other thread.
    http://forum.teamspeak.com/threads/1...ot-log-message
    Zu den privaten Nachrichten: Es tut mir leid, dass es den Eindruck macht als kümmert man sich nicht drum. Dem ist nicht so.
    Natürlich wurden diese gelesen, aber warfen mehr fragen zum inhalt auf als ich beantworten könnte.
    Der Inhalt lieferte keine nützlichen Hinweise die nicht hier schon im Post #1 stehen oder hatte irgendwas mit dieser assertion zu tun.
    Diese wäre in der Log und tritt wie uns bekannt ist nur beim Server start aus.

    Mixing Languages is atm forbidden on this froum
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  12. #12
    Join Date
    February 2012
    Location
    Germany
    Posts
    565
    It's not really a big problem. According to my research, the crash does happen very seldomly, about 1 out of 100 starts as far as I remember. And it happens only on startup, not after the startup has been done successfully.

    So if you implement a start mechanism that restarts a service for a limited amount of tries on a startup failure, you will be fine.

    On Linux systems with systemd, for example CentOS 7 or Fedora 18+, if you use a systemd unit file to manage the service, this is handled by systemd automatically and you don't need to do anything special. It just works. Systemd monitors and restarts failed services automatically without any extra configuration.

    An example on how to implement the server on CentOS 7 with systemd, see this *.spec file:
    https://www.wombaz.de/uploads/2015/0...k3-server.spec

  13. #13
    Join Date
    June 2008
    Posts
    17,812
    Server 3.0.13 beta 2 will be relleased soon and should fix the rare assertion rsa_puzzle.cpp:465; on server start.

    Update news can be found here then: http://forum.teamspeak.com/threads/1...er-3-0-13-Beta
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] Pre Server 3.0.12.4 does crash (connection.cpp:681 and rsa_puzzle.cpp:465;)
    By hunterpl in forum Bug Reports [EN/DE]
    Replies: 5
    Last Post: May 22nd, 2016, 10:11 PM
  2. TS3 encryption
    By Thor Erik in forum General Questions
    Replies: 2
    Last Post: August 17th, 2014, 03:46 PM
  3. voice encryption not available (linux server)
    By realBigMac in forum Server Support
    Replies: 6
    Last Post: January 30th, 2013, 02:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •