Forum

Results 1 to 7 of 7
  1. #1
    Join Date
    January 2016
    Posts
    29

    No privilege key when creating server on linux?

    Hi guys.

    Just started the server on linux for the first time and it didnt give me a privilege key. Only the server querey admin log in and password.

    every tutorial ive followed showed a privilege key given along with the others. see here http://puu.sh/pvxkF/a37ff86054.png

    Please help as i have been at this for hours and my head hurts. the server must be running in a few hours!
    Last edited by DanBarnett; June 17th, 2016 at 04:25 AM. Reason: added link

  2. #2
    Join Date
    September 2012
    Posts
    6,080
    The server will report the privilege key if a server was created. Check your logs for errors, if there are no errors the privilege key should be in the _1.log (or _x.log where x is the id of the last created server).
    Else stop the server, delete the ts3server.sqlitedb file and run it again.
    Last edited by Chris; June 17th, 2016 at 03:19 PM.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  3. #3
    Join Date
    January 2016
    Posts
    29
    I am a terrible terrible noob when it comes to all this. i just reinstalled os. remade the server following these instructions:

    http://forum.teamspeak.com/threads/6...-Server-CentOS

    I replaced the old link with newest version.

    It still did not give me a privilege key. It DID show me server query log info.


    If the token is indeed in the log, could you explain how to access it from the very beginning step by step please including where i have to be when starting the commands. THANK YOU!!!

    Also, it says the server is running but when i try to connect using my client, it says: FAILED TO CONNECT TO SERVER.

    Surely i should be able to connect at this stage?

  4. #4
    Join Date
    June 2008
    Posts
    18,396
    Please do not open log_0 for the privilege key (token). It's not printed there.
    The key is always printed in target vserver log which is 1 on first generated server.
    Code:
    2016-06-16 12:34:34.199732|INFO    |VirtualServer |1  |listening on 0.0.0.0:9987
    2016-06-16 12:34:34.200232|WARNING |VirtualServer |1  |--------------------------------------------------------
    2016-06-16 12:34:34.200232|WARNING |VirtualServer |1  |ServerAdmin privilege key created, please use the line below
    2016-06-16 12:34:34.200727|WARNING |VirtualServer |1  |token=0lF6GLzBh5CJCCQaRvxRWTMafUSxJd5xMd7oGytC
    2016-06-16 12:34:34.200727|WARNING |VirtualServer |1  |--------------------------------------------------------
    Have port forwarded the needed ports?
    https://support.teamspeakusa.com/ind...k-3-server-use
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  5. #5
    Join Date
    January 2016
    Posts
    29
    Thanks for the quick reply. I have seen this around in other forums ( see link) http://puu.sh/pvQ6W/ecc9433e21.png

    I have no idea what to do to get that information or how to access any logs at all, commands would be useful if you know them?

    I didnt forward any ports at all but i recently made a server on the same vps and everything worked without doing that. everyone was able to connect, showed me token on creation.... I will forward the ports now using the link you gave me

  6. #6
    Join Date
    June 2008
    Posts
    18,396
    The link only shows my example. The link, is not usefull for me.

    You need to access your Server machine via ssh to get to the logfiles.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  7. #7
    Join Date
    January 2016
    Posts
    29
    solved thanks guys all working now

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: June 1st, 2016, 03:15 PM
  2. Where is "Privilege key" located? (i686 GNU/Linux)
    By GriGore in forum Server Support
    Replies: 5
    Last Post: December 19th, 2011, 06:23 PM
  3. got my server up and the privilege key did not work???
    By swordfish196 in forum Server Support
    Replies: 1
    Last Post: July 24th, 2011, 12:17 AM
  4. TS3 Server Linux *Privilege Key Location*
    By dwcjr in forum Linux / FreeBSD
    Replies: 2
    Last Post: December 20th, 2010, 01:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •