Forum

Page 1 of 2 12 LastLast
Results 1 to 15 of 19
  1. #1
    Join Date
    February 2015
    Posts
    5

    Android Crash Bug

    So I bought the android version of teamspeak 3 about 2 years ago and have never been able to keep it open for longer than a minute or so before it crashes. Today I looked at logcat when it crashed and found information that might come in useful for finding the source of the bug.

    Code:
    06-28 13:51:02.046 F/libc    (14889): Fatal signal 11 (SIGSEGV), code 1, fault addr 0x7fbb2c30b6 in tid 14904 (teamspeak)

  2. #2
    Join Date
    January 2013
    Location
    Thüringen
    Posts
    337
    What have you for an Android Version?

  3. #3
    Join Date
    February 2015
    Posts
    5
    Quote Originally Posted by Rikku View Post
    What have you for an Android Version?
    6.0.1 but it's been like this since 4.4.4.

  4. #4
    Join Date
    June 2008
    Posts
    18,151
    I will forward this to a developer but i need informations about your device.

    Which device do you use and are you uisng an original firmware?

    //Edit
    The log is not helpfull for our developer.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  5. #5
    Join Date
    February 2015
    Posts
    5
    Quote Originally Posted by dante696 View Post
    I will forward this to a developer but i need informations about your device.

    Which device do you use and are you uisng an original firmware?

    //Edit
    The log is not helpfull for our developer.
    I've been on several devices that have the issues:
    Motorola RAZR on stock firmware
    Samsung Galaxy S3 on stock firmware and cyanogenmod
    Samsung Galaxy S5 on stock firmware
    Nexus 6P on stock firmware and cyanogenmod

    All of the devices and firmwares above I've had this problem with. The device connects to teamspeak then it always crashes at a maximum of 2 minutes later.

  6. #6
    Join Date
    April 2015
    Location
    Germany
    Posts
    16

    App Crash for specific server

    When I try to connect to my own TS3 server using the Android app on my Samsung Galaxy S6 with an instance that has admin privileges, the app crashes all the time. When I try to connect as guest, the app crashes one time and connects for the next try.

    It all worked on my Nexus 5 and NVidia Shield Tablet.

    Complete TS IP on request, or check error log file.

    This is what (I think) the TeamSpeak crash outputs in
    Code:
    adb logcat *:E
    :
    http://pastebin.com/Xvzng7P0

    This is what
    Code:
    adb logcat com.teamspeak.ts3client:V
    prints:
    http://flybel.de/TS3error.txt
    Last edited by Flybel; July 4th, 2016 at 03:32 PM.

  7. #7
    Join Date
    June 2008
    Posts
    18,151
    Thread merged


    "has admin privileges" -> Are you reffering to a normal Server Group?

    Could be that subscription mode (Icon with Eye when you are connected) or Show ServerQuery clients does cause that crash.
    Disable both as Gues and then assign yourself back to Admin -> Now connect.

    Thank you for the advanced logs. I forwarded this to our developers.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  8. #8
    Join Date
    April 2015
    Location
    Germany
    Posts
    16
    Quote Originally Posted by dante696 View Post
    Thread merged


    "has admin privileges" -> Are you reffering to a normal Server Group?

    Could be that subscription mode (Icon with Eye when you are connected) or Show ServerQuery clients does cause that crash.
    Disable both as Gues and then assign yourself back to Admin -> Now connect.

    Thank you for the advanced logs. I forwarded this to our developers.
    What is definitely the case is that when I connect to any server on any device, the first time the Subscribe icon is colored, meaning the client is subscribed. However it is not, and I have to push that button twice (to disable and re-enable subscription) for it to work and to see clients in other channels.

    The admin privileges are the default Server Admin group, just renamed to "OP", I'm not entirely sure if I changed permissions in that group.

  9. #9
    Join Date
    April 2015
    Location
    Germany
    Posts
    16
    Any news?

    I got an OS update from Samsung but the issue still persists.

  10. #10
    Join Date
    June 2008
    Posts
    18,151
    Nope, we are still unable to reprodcue the crash or what you did report in post #8 what does not lookl ike a crash anymore.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  11. #11
    Join Date
    April 2015
    Location
    Germany
    Posts
    16
    Well, that was just something I noticed which I think I had on every device. I just thought that maybe it could have something to do with the crash on my Galaxy S6 so I posted it.

    If it isn't relevant for the crash then it doesn't matter, however it is something that could be fixed because if it is how I described it, it's just a little flaw and not so difficult to resolve.

  12. #12
    Join Date
    June 2008
    Posts
    18,151
    I forgot something:
    We have a Samsung S6 device and it does crash. But this happens on start and only in our alpha version.
    Maybe it is related and will be fixed too, when this crash will be fixed.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  13. #13
    Join Date
    April 2015
    Location
    Germany
    Posts
    16
    That sounds good. Hopefully that issue gets resolved.

  14. #14
    Join Date
    June 2008
    Posts
    18,151
    Can't promise it ;( as long we can't reproduce the original crash on
    S5 6.0.1 and another one with Cyagenmod 13
    Tab S2 6.0.1
    Sony Xperia L 4.2.2
    Asus Zen Fone 5 (don't know Android version atm)
    Moto G
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  15. #15
    Join Date
    April 2015
    Location
    Germany
    Posts
    16
    Hmm, well if there is anything else I can do to help you resolve the issue let me know ^^.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] teamspeak 3 application android crash crash crash
    By hycksou in forum Android
    Replies: 4
    Last Post: July 5th, 2017, 06:05 PM
  2. [TSDNS + Android] Crash
    By JoccE in forum Android
    Replies: 0
    Last Post: December 29th, 2015, 06:27 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •