Im unable to download the client

At first I tried to download the 64bit client because I have 64bit. It downloaded to ~12mb and then stopped (the file size is ~30mb). Then I tried a few more times but I got the same result. After that I tried to download the 32bit but it also didnt go through 12mb. I tried to download the mac version just to see (I run Windows 10 64 bit) and it downloaded completely fine.

Later I tried to download the client from different sites like cnet, softpedia etc. and I got the same exact result- stops at 12mb. Very weird. This never happened to me. After all that I disabled Windows defender (my only AV installed) and repeated the whole process. No improvement.
Almost ready to give up I tried one last thing- I downloaded an older version of ts3 and It downloaded completely. Success? not really. After installing and launching the client I was required to update. You guessed it.... It wasnt able to connect. F*ck!

I tried Rebooting my laptop, downloading the client from a different browser, connecting to wired internet. Nothing helped.
My speculations are that my computer somehow identifies the file and is blocking it at download.

Thanks in advance to anyone willing to help