Forum

Page 3 of 3 FirstFirst 123
Results 31 to 42 of 42
  1. #31
    Join Date
    August 2013
    Location
    Germany
    Posts
    542
    Teamspeak dropped XP support since 3.1.8

  2. #32
    Join Date
    September 2005
    Location
    Germany / Dortmund
    Posts
    1,369
    Which version do you use?

    If you use the "myTeamSpeak-version": I seriously don't know anymore, how I built this, so there might be some issues on my windows build machine.

    If you use the latest (always up to date) version from here (which would be my suggestion): there might be issues on the buildbox and I'd have to look into it. I'm too lazy to test this builds for every arch, so let me know, if you are using it.

  3. #33
    Join Date
    February 2017
    Posts
    2

    Coding Issue

    Hey thansk for the great plugin! I have recently been altering the answercontacts script, however I am fairly basic when it comes to python. I have been trying to implement a bot known as chatterbot, however it seems as though the plugin does not reply to messages when I do this. Here is a snippet of the code:

    def onTextMessageEvent(self, schid, targetMode, toID, fromID, fromName, fromUniqueIdentifier, message, ffIgnored):
    (err, myid) = ts3lib.getClientID(schid)

    #CHATTERBOT BIT, When the next 3 lines are uncommented no reply is sent to the sending user...
    #from chatterbot import ChatBot
    #chatbot = ChatBot('Ron Obvious', trainer='chatterbot.trainers.ChatterBotCorpusTrain er')
    #response = chatbot.get_response(message)


    #Below is something that messages the user with a joke, this works when the below 2 lines of code are uncommented.
    #if message[0] != "-":
    # response = message + "... Don't copy me! Type - at the start of each message, to cancel this reply."


    So if anyone has any ideas to fix this, or anyone can alter the code/suggest something that would work -Essentially want something that will autoreply to a user with an AI Response, then I would be extremely thankful! Regards, Jack

  4. #34
    Join Date
    September 2005
    Location
    Germany / Dortmund
    Posts
    1,369
    Is chatterbot installed in pyTSon's site-packages (Go to Plugins -> pyTSon -> Settings -> General -> Site packages -> Add)? Even if it's installed on your systems python installation, pyTSon won't notice that!

    Is there any output in the clientlog?


    P.S.: Please use code tags especially when posting python code!
    P.P.S: Sorry for the late answer, I just didn't notice your post.

  5. #35
    Join Date
    December 2015
    Posts
    7
    Running win64, latest update of ts and getting the error when installing the 64bit version of the plugin:
    This add-on is not available for your platform.

  6. #36
    Join Date
    September 2005
    Location
    Germany / Dortmund
    Posts
    1,369
    Sounds like a myteamspeak issue, I've always uploaded a build for each available desktop platform.
    The client log might be a bit more verbose about what's wrong.

    You can try to download it with your browser from myteamspeak.com (latest release is currently pending, so you'll get version 1.2.1).

    You can download the latest release from Github or the most recent updates from my download page.

  7. #37
    Join Date
    March 2019
    Posts
    1
    onClientMoveEvent only works on myself, is there something similar which also works for other people joining the channel which i am currently in?

    Is it possible to run a function when a user joined the channel which i am currently in? onClientMoveEvent only works on myself right? And is it possible to know who is talking?
    Last edited by dante696; April 1st, 2019 at 08:52 AM. Reason: merged 2 posts

  8. #38
    Join Date
    September 2005
    Location
    Germany / Dortmund
    Posts
    1,369
    Please decide first, if you wanna communicate here or on github.

    See https://github.com/pathmann/pyTSon/issues/115

  9. #39
    Join Date
    April 2019
    Posts
    1
    Name:  VDMk5fVIQ1WMA7zAaHZkRQ.png
Views: 44
Size:  2.2 KB
    What is that error?
    I think you should update the API version to 22

  10. #40
    Join Date
    September 2005
    Location
    Germany / Dortmund
    Posts
    1,369
    Nope, api version 21 is still supported.

    Check your log, there should be an error message.

    This might happen, when some needed resources are not found. So where did you download it (and how did you install it)?

  11. #41
    Join Date
    September 2005
    Location
    Germany / Dortmund
    Posts
    1,369
    What are you trying to do and how?

    Did you forget to add the log?

    edit by mod
    Post and user got removed from forum.
    Last edited by dante696; May 12th, 2019 at 12:37 AM.

  12. #42
    Join Date
    March 2019
    Location
    Maskavas iela 12 k-1, Rīga, LV-1050
    Posts
    1
    Thanks for awesome plugin!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [RELEASE]Now Playing Plugin
    By Screech in forum Client Plugins / Lua Scripts
    Replies: 236
    Last Post: February 3rd, 2018, 02:59 AM
  2. [Release] VLC Mute Plugin
    By SilentStorm in forum Client Plugins / Lua Scripts
    Replies: 18
    Last Post: April 30th, 2017, 09:20 PM
  3. [Release]LoLRandomizer Plugin
    By mJrA83 in forum Client Plugins / Lua Scripts
    Replies: 17
    Last Post: January 13th, 2015, 05:06 PM
  4. [Release] AutoAway plugin
    By plamen in forum Client Plugins / Lua Scripts
    Replies: 30
    Last Post: March 14th, 2014, 09:05 PM
  5. [RELEASE] Another TS3 Overlay Plugin
    By MarkR in forum Client Plugins / Lua Scripts
    Replies: 120
    Last Post: January 14th, 2011, 08:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •