Forum

Results 1 to 11 of 11
  1. #1
    Join Date
    June 2012
    Posts
    33

    Updated Server to 3.0.13 Now its not connecting???!!!

    So updated to the new server have not changed anything but updating the server and now i am unable to connect to it?

  2. #2
    Join Date
    June 2008
    Posts
    18,406
    Are there server logs or anything else we can work with to help you?
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    June 2012
    Posts
    33
    Quote Originally Posted by dante696 View Post
    Are there server logs or anything else we can work with to help you?
    Here is the last log:

    2016-08-08 14:42:30.777364|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.0.13 (2016-07-19 12:06:50)
    2016-08-08 14:42:30.777364|INFO |ServerLibPriv | |SystemInformation: Windows 7 SP1 (7601) x64 (AMD or Intel) Binary: 64bit
    2016-08-08 14:42:30.777364|INFO |ServerLibPriv | |Using hardware aes
    2016-08-08 14:42:30.831367|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, (c)TeamSpeak Systems GmbH
    2016-08-08 14:42:30.831367|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
    2016-08-08 14:42:31.023378|INFO |DatabaseQuery | |checking database integrity (may take a while)
    2016-08-08 14:42:32.643470|INFO |Accounting | |Licensing Information
    2016-08-08 14:42:32.643470|INFO |Accounting | |type : Non-profit
    2016-08-08 14:42:32.643470|INFO |Accounting | |starting date : Tue Jul 19 00:00:00 2016
    2016-08-08 14:42:32.643470|INFO |Accounting | |ending date : Sat Jan 28 00:00:00 2017
    2016-08-08 14:42:32.643470|INFO |Accounting | |max virtualservers: 10
    2016-08-08 14:42:32.643470|INFO |Accounting | |max slots : 512
    2016-08-08 14:42:33.928544|INFO | | |Puzzle precompute time: 1254
    2016-08-08 14:42:33.930544|INFO |FileManager | |listening on 0.0.0.0:30033, :::30033
    2016-08-08 14:42:33.962546|ERROR |VirtualSvrMgr | |loading VirtualServer(1) failed to start, error: invalid channelID
    2016-08-08 14:42:33.963546|INFO |CIDRManager | |updated query_ip_whitelist ips: 127.0.0.1/32, 192.168.1.10/32,
    2016-08-08 14:42:33.967546|INFO |Query | |listening on 0.0.0.0:10011, :::10011
    2016-08-08 14:44:52.173451|INFO |Query | |query from 624 50.163.12.75:50075 issued: login with account "serveradmin"(serveradmin)

  4. #4
    Join Date
    June 2012
    Posts
    33

    Why?

    Quote Originally Posted by Llamalord View Post
    Here is the last log:

    2016-08-08 14:42:30.777364|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.0.13 (2016-07-19 12:06:50)
    2016-08-08 14:42:30.777364|INFO |ServerLibPriv | |SystemInformation: Windows 7 SP1 (7601) x64 (AMD or Intel) Binary: 64bit
    2016-08-08 14:42:30.777364|INFO |ServerLibPriv | |Using hardware aes
    2016-08-08 14:42:30.831367|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, (c)TeamSpeak Systems GmbH
    2016-08-08 14:42:30.831367|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
    2016-08-08 14:42:31.023378|INFO |DatabaseQuery | |checking database integrity (may take a while)
    2016-08-08 14:42:32.643470|INFO |Accounting | |Licensing Information
    2016-08-08 14:42:32.643470|INFO |Accounting | |type : Non-profit
    2016-08-08 14:42:32.643470|INFO |Accounting | |starting date : Tue Jul 19 00:00:00 2016
    2016-08-08 14:42:32.643470|INFO |Accounting | |ending date : Sat Jan 28 00:00:00 2017
    2016-08-08 14:42:32.643470|INFO |Accounting | |max virtualservers: 10
    2016-08-08 14:42:32.643470|INFO |Accounting | |max slots : 512
    2016-08-08 14:42:33.928544|INFO | | |Puzzle precompute time: 1254
    2016-08-08 14:42:33.930544|INFO |FileManager | |listening on 0.0.0.0:30033, :::30033
    2016-08-08 14:42:33.962546|ERROR |VirtualSvrMgr | |loading VirtualServer(1) failed to start, error: invalid channelID
    2016-08-08 14:42:33.963546|INFO |CIDRManager | |updated query_ip_whitelist ips: 127.0.0.1/32, 192.168.1.10/32,
    2016-08-08 14:42:33.967546|INFO |Query | |listening on 0.0.0.0:10011, :::10011
    2016-08-08 14:44:52.173451|INFO |Query | |query from 624 50.163.12.75:50075 issued: login with account "serveradmin"(serveradmin)
    So it looks like 2016-08-08 14:42:33.962546|ERROR |VirtualSvrMgr | |loading VirtualServer(1) failed to start, error: invalid channelID

    Why would this start happening?! Nothing was change other then apply the update!!!

  5. #5
    Join Date
    June 2012
    Posts
    33

    Exclamation

    Quote Originally Posted by Llamalord View Post
    So it looks like 2016-08-08 14:42:33.962546|ERROR |VirtualSvrMgr | |loading VirtualServer(1) failed to start, error: invalid channelID

    Why would this start happening?! Nothing was change other then apply the update!!!

    Tried going back to the old version and got this

    2016-08-08 17:08:41.886645|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.0.12.3 (2016-03-04 08:31:20)
    2016-08-08 17:08:41.887645|INFO |ServerLibPriv | |SystemInformation: Windows 7 SP1 (7601) x64 (AMD or Intel) Binary: 64bit
    2016-08-08 17:08:41.887645|INFO |ServerLibPriv | |Using hardware aes
    2016-08-08 17:08:41.889645|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2016-08-08 17:08:41.889645|INFO |DatabaseQuery | |dbPlugin version: 3.8.6
    2016-08-08 17:08:41.890645|INFO |DatabaseQuery | |checking database integrity (may take a while)
    2016-08-08 17:08:41.907646|CRITICAL|DatabaseQuery | |setSQLfromFile( file:sql/update_26.sql) failed


    Could i please get some help on this?! Never had a problem EVER till this update...

  6. #6
    Join Date
    October 2003
    Location
    Germany
    Posts
    2,528
    Quote Originally Posted by Llamalord View Post
    So it looks like 2016-08-08 14:42:33.962546|ERROR |VirtualSvrMgr | |loading VirtualServer(1) failed to start, error: invalid channelID

    Why would this start happening?! Nothing was change other then apply the update!!!
    It seems that there's a channel missing in your database for some reason. I think you won't be able to resolve this issue without doing manual changes to your database. Please upload your ts3server.sqlitedb file and send me the link via PM. I'll have a look at it asap.

  7. #7
    Join Date
    June 2012
    Posts
    33
    Quote Originally Posted by ScP View Post
    It seems that there's a channel missing in your database for some reason. I think you won't be able to resolve this issue without doing manual changes to your database. Please upload your ts3server.sqlitedb file and send me the link via PM. I'll have a look at it asap.
    Doing this now!

    Thanks!

  8. #8
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,371
    You may not downgrade TeamSpeak servers. It destroys it entirely. This is a bug BTW. Looks like TeamSpeak has this code somewhere:
    WHILE (DatabaseVersion != ExecutableVersion)
    {
    DatabaseVersion++;
    Query("sql/update_" + DatabaseVersion);
    }
    "!=" should be changed to "<", so it only updates if the executable version is newer than the database, not if older.

  9. #9
    Join Date
    June 2012
    Posts
    33
    Quote Originally Posted by numma_cway View Post
    You may not downgrade TeamSpeak servers. It destroys it entirely. This is a bug BTW. Looks like TeamSpeak has this code somewhere:
    "!=" should be changed to "<", so it only updates if the executable version is newer than the database, not if older.
    How would i fix this i sent file to support but no reply yet? My members are starting to get upset...

  10. #10
    Join Date
    April 2011
    Location
    Germany
    Posts
    1,266
    Why don't you use your backup? Prior to performing any update you do make a backup, don't you?
    If you don't have a backup... remember to take one next time before and I suppose you have to wait until you get your repaired db back.

  11. #11
    Join Date
    June 2012
    Posts
    33
    Quote Originally Posted by Barungar View Post
    Why don't you use your backup? Prior to performing any update you do make a backup, don't you?
    If you don't have a backup... remember to take one next time before and I suppose you have to wait until you get your repaired db back.
    Nope...wish i had a back up...one time i didn't make one...Like i said never had any problems EVER updating teamspeak this is my VERY first time having a problems since starting my teamspeak back in 2006...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Just updated an now server won't say on?
    By Martyn in forum Linux / FreeBSD
    Replies: 0
    Last Post: July 16th, 2015, 06:35 PM
  2. Updated server
    By stillborn in forum General Questions
    Replies: 15
    Last Post: June 12th, 2011, 05:10 PM
  3. Replies: 3
    Last Post: January 19th, 2010, 09:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •