Forum

Results 1 to 1 of 1
  1. #1
    Join Date
    April 2016
    Location
    Russia
    Posts
    14

    TeamSpeak3 access violation

    My aim for now is creating team speak 3 manager service (that switches the users by channels an others):
    So I created wrapper of TS3 SDK lib (wrapped with Cython for Python): https://mega.nz/#!pQdFjIwD!1vg8DPsFt...-aPz2niRkTU4fY (main module: http://pastebin.com/PywhH4bf )
    In this wrapper I used test connection in module. To test this module just import this.

    And I got message in python console: Process finished with exit code -1073741819 (0xC0000005) (access violation)

    With this log:

    init client lib
    HTML Code:
    2016-08-16 10:14:20.862577|INFO    |              |   |TeamSpeak 3 Client 3.0.3 (2015-03-30 11:30:36) SDK
    2016-08-16 10:14:20.863574|INFO    |              |   |SystemInformation: Windows 9 8664 {6} {3} {9600}  (9600) x64 (AMD or Intel) Binary: 32bit
    2016-08-16 10:14:20.863574|INFO    |              |   |Using hardware aes
    2016-08-16 10:14:20.876587|DEBUG   |Direct Sound  |   |setting timer resolution to 1ms
    2016-08-16 10:14:20.892602|ERROR   |SoundBckndIntf|   |Could not load "ts3soundbackend_isSupported" from backend dynamic library
    spawn connection handler
    mode
    Default capture mode: b'Windows Audio Session'
    
    ('Default capture device: %s %s\n', b'\xd0\x9c\xd0\xb8\xd0\xba\xd1\x80\xd0\xbe\xd1\x84\xd0\xbe\xd0\xbd (\xd0\xa3\xd1\x81\xd1\x82\xd1\x80\xd0\xbe\xd0\xb9\xd1\x81\xd1\x82\xd0\xb2\xd0\xbe \xd1\x81 \xd0\xbf\xd0\xbe\xd0\xb4\xd0\xb4\xd0\xb5\xd1\x80\xd0\xb6\xd0\xba\xd0\xbe\xd0\xb9 High Definition Audio)', b'{0.0.1.00000000}.{c28d826f-9cd5-414b-a018-bbfc0cbc1298}')
    2016-08-16 10:14:20.905616|DEBUG   |Windows Audio Session|   |WAS::openDevice-enter
    2016-08-16 10:14:20.912622|DEBUG   |Windows Audio Session|   |WAS Buffer size: 896
    2016-08-16 10:14:20.912622|DEBUG   |Windows Audio Session|   |WAS::openDevice-leave
    2016-08-16 10:14:20.912622|INFO    |PreProSpeex   |1  |Speex version: speex-1.2beta3
    2016-08-16 10:14:20.912622|DEBUG   |Windows Audio Session|   |WAS::startDevice-enter
    2016-08-16 10:14:20.913622|DEBUG   |Windows Audio Session|   |WAS::startDevice-leave
    Default playback mode: b'Windows Audio Session'
    
    ('Default playback device: %s %s\n', b'\xd0\x94\xd0\xb8\xd0\xbd\xd0\xb0\xd0\xbc\xd0\xb8\xd0\xba\xd0\xb8 (\xd0\xa3\xd1\x81\xd1\x82\xd1\x80\xd0\xbe\xd0\xb9\xd1\x81\xd1\x82\xd0\xb2\xd0\xbe \xd1\x81 \xd0\xbf\xd0\xbe\xd0\xb4\xd0\xb4\xd0\xb5\xd1\x80\xd0\xb6\xd0\xba\xd0\xbe\xd0\xb9 High Definition Audio)', b'{0.0.0.00000000}.{cb324415-bf79-473b-9a59-69a1ca4bfe56}')
    2016-08-16 10:14:20.913622|DEBUG   |Windows Audio Session|   |WAS::openDevice-enter
    2016-08-16 10:14:20.918627|DEBUG   |Windows Audio Session|   |WAS Buffer size: 896
    2016-08-16 10:14:20.918627|DEBUG   |Windows Audio Session|   |WAS::openDevice-leave
    2016-08-16 10:14:20.918627|DEBUG   |Windows Audio Session|   |WAS::startDevice-enter
    2016-08-16 10:14:20.918627|DEBUG   |Windows Audio Session|   |WAS::startDevice-leave
    creating identity
    
    Client lib initialized and running
    
    Connect status changed: 1 1 0
    
    2016-08-16 10:14:20.926635|DEVELOP |PktHandler    |   |Puzzle solve time: 7
    Connect status changed: 1 2 0
    
    Connect status changed: 1 3 0
    
    Connect status changed: 1 4 0
    What I doing wrong? Help please. And thank you for attention!
    Last edited by broly; August 17th, 2016 at 12:33 PM. Reason: new url

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •