So... assuming that the client doesn't care for the link-local addresses on your interfaces when resolving IPs, I can only imagine that the Toredo tunneling adapter causes the issue on Windows machines. While we might fix this issue with one of our next pre-releases, can you try if the problem is solved when you disable the Toredo interface?

Code:
netsh interface ipv6 set teredo disable
You can use this command when you want to re-enable it later:

Code:
netsh interface ipv6 set teredo default
Also, please test what happens when you disable the IPv6 protocol for each of your interfaces by unchecking it temporarily in the properties of each connection.