Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 3 of 3
  1. #1
    Join Date
    January 2013
    Posts
    21

    Question Server failes to start after update "free(): invalid pointer:"

    Dear community,

    Today I've tried upgrading my Teamspeak3 server version 3.0.11.4 64bit on Debian 8.5 to the newest version of Teamspeak 3.0.13.2 64bit.

    Unfortunally, after replacing the files with the newest version, the server refused to start.

    I couldn't find anything about this issue on google, so I decided to create this topic.

    For now, I've downgraded the server version back to 3.0.11.4 by replacing the server files with the backupped ones.

    The actual error is shown below:

    Name:  error.png
Views: 240
Size:  23.7 KB

    Is there someone that can shed any light on this matter?

    Thanks in advance!

  2. #2
    Join Date
    July 2008
    Location
    Germany
    Posts
    136

    Unhappy

    Quote Originally Posted by cakemasher View Post
    Dear community,

    Today I've tried upgrading my Teamspeak3 server version 3.0.11.4 64bit on Debian 8.5 to the newest version of Teamspeak 3.0.13.2 64bit.

    Unfortunally, after replacing the files with the newest version, the server refused to start.

    I couldn't find anything about this issue on google, so I decided to create this topic.

    For now, I've downgraded the server version back to 3.0.11.4 by replacing the server files with the backupped ones.

    The actual error is shown below:

    Name:  error.png
Views: 240
Size:  23.7 KB

    Is there someone that can shed any light on this matter?

    Thanks in advance!
    same here
    *** Error in `./ts3server': free(): invalid pointer: 0x00007f1a7503a718 ***
    Log sais nothing...
    cat ts3server_2016-08-20__07_54_38.660763_0.log
    2016-08-20 07:54:38.660804|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.0.13.3 (2016-08-18 16:46:43)
    2016-08-20 07:54:38.660882|INFO |ServerLibPriv | |SystemInformation: Linux 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt25-2+deb8u3 (2016-07-02) x86_64 Binary: 64bit
    2016-08-20 07:54:38.662027|INFO |DatabaseQuery | |dbPlugin name: MySQL plugin, (c)TeamSpeak Systems GmbH
    2016-08-20 07:54:38.662052|INFO |DatabaseQuery | |dbPlugin version: 1

  3. #3
    Join Date
    February 2012
    Location
    Germany
    Posts
    577
    You both have still the replaced mysql plugin from previous TS versions in your config. Use the mariadb plugin according to the doc/update_mysql_to_mariadb.txt documentation file.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: March 24th, 2016, 07:44 PM
  2. [Resolved] Server direct crash "invalid group ID"
    By CRC Mismatch in forum Server Support
    Replies: 19
    Last Post: April 23rd, 2015, 05:13 PM
  3. Please Update this Plugin ""Connection History"" Or Include to Client Version
    By varela1george in forum Suggestions and Feedback
    Replies: 2
    Last Post: October 13th, 2012, 08:28 AM
  4. Replies: 1
    Last Post: November 13th, 2011, 04:30 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •