Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 13 of 13
  1. #1
    Join Date
    February 2016

    Teamspeak stopped recognizing mic after it's disabled and reenabled on G930/G933/G633

    hi all.
    Ive just upgraded my Logitech headset from the G930 to the G633.

    I have run into a problem with TS with these new G633 (No problems with G930), either case when I raise the mic or press the mute button, when I unmute the headset the mic doesn't reactivate so I cant speak.
    If I go into the settings/options/record and change the capture or device mode and apply the change, I get the mic back on.

    I don't have this problem if I use the TS mute.

    has any one else have this problem with the G633 and is there a fix for this?
    Last edited by dS.john; March 1st, 2016 at 08:17 AM. Reason: problem solved

  2. #2
    Join Date
    June 2008
    I would say this is also a driver problem.

    What does your client log say, when you mute the mic.
    Last edited by dante696; February 29th, 2016 at 11:15 AM.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    April 2016

    Logitech g633 mute/unmute problem

    I have the same problem as this person:

    I bought the headset 2 days ago and basically when I mute my microphone on the headset and after like 1 minute I unmute it, teamspeak 3 doesnt let me talk, it still counts as muted, to make a temporary fix I have to change my audio recording device from Default to something that is disabled, apply the change and then change it back to default and apply the change again, then everything works again UNTIL I mute my microphone again not on ts3 the mute options but on the headset itself.

    This guy said in his thread that its solved, I was wondering if someone can help me with this problem, I also had the Logitech G930 headset before and everything was working perfectly well.

    If anyone has a solution please let me know ASAP, thanks!

  4. #4
    Join Date
    May 2016

    Teamspeak stopped recognizing G930/G933/G633 mic after it's disabled and reenabled

    TS -

    Logitech G930 headset

    Been working perfectly until Logitech software installed update. Still works perfectly with all other programs on the PC but intermittently the headset seems to disconnect inside TS. Can reproduce by muting mic on HS with either button or lifting the boom....HS will not reactivate unless you do one of two things:

    1> Exit TS and reenter

    2> Go into Settings->Options -> Capture and switch Capture device and hit apply. There are only two options - default and Logitech. It makes no difference which you select as long as it is the opposite of whatever is set when you first open the screen.

    Randomly I get the HS just dropping TS - both audio feeds - headphones and mic...and have to do one of the reconnect options.

    I have uninstalled the Logitech software, tried a different G930, and deleted all drivers from my 64bit W7 machine and reinstalled.


  5. #5
    Join Date
    July 2016

    Headset mute issues.

    I am using a Logitech G930 Headset with the flip boom mute feature. You rotate the boom up over your head and it mutes the headset.
    I'm having an issue with this. Every time the headset is muted, Teamspeak stops picking up sound from it even after I unmute it and produces some horrible static noise. It does this every time and will not pick up sound again until I restart my computer. Other applications on my computer also won't pick up sound from the headset even though it is unmuted and I have verified it is unmuted in the Windows audio settings AND Windows audio settings says it's picking up sound. Additionally, I can only use the headset in directsound which is rather strange.

    Any ideas? I can't even mute my headset unless I use TeamSpeak's native mute feature.

  6. #6
    Join Date
    June 2014

    Teamspeak stopped recognizing G930/G933 mic after it's disabled and reenabled

    Hello everyone!

    I am having an issue with Teamspeak 3 involving my Logitech G933, as well as my friend utilizing a G930. Any help would be awesome!

    When the headset's built in mute is activated then deactivated, intermittently Teamspeak may not pick up the microphone audio until the program is restarted or the selected capture device is cycled away and back to the headset.
    Looking at TS's error log, no related events are recorded.

    I'm not sure what to do on this one - TS3 is the only program that is having this issue. It works properly in Ventrillo, Mumble, Steam, Skype and the ingame audio of the games we play.

    Here is what I have tried so far
    I have suspected Logitech's gaming software - I have reproduced the issue without the software, with the newest software (8.83.85) and a much older version (8.51.5).
    I have been able to reproduce the issue with the MS default drivers, in addition to Logitech's latest drivers.
    I have deleted teamspeak (Including AppData) and reinstalled the latest version. The issue is reproduced in 32 and 64 bit software.

    The above issue, attempted solutions and results were mirrored on two systems, the only significant difference being the headset and AMD/Intel CPUs. This was all tested on Windows 10.

    Any help would be great!
    Last edited by dante696; September 7th, 2016 at 10:06 AM. Reason: merged

  7. #7
    Join Date
    June 2014
    I am still experimenting for a solution but I have had no success so far.

    If anyone can comment on what could be done here, I would love any input.

  8. #8
    Join Date
    September 2016

    Mic stops working

    I recently bought a new wireless headset (Logitech G930) and i have an issue.

    When i am in TS and goes afk for a little while i pull up my mic and thereby mutes it, or press the mute button on the headset that mutes it as well. But the problem is that when i come back, TS sometimes dont capture my voice to TS. the audio works fine but people cant hear me.

    I know that if i restart TS it works fine again.
    It also starts working again if i enter settings and change the mic driver to something else and back to my G930 drivers.

    Another this to note is that on skype i dont have to do anything to make it work again, Skype instantly starts capturing my voice after i unmute.

    How do i resolve this issue ?

  9. #9
    Join Date
    September 2016

    Teamspeak stopped recognizing G930 mic after it's disabled and reenabled

    My settings are: Windows 7 64 bit, TeamSpeak (but I tried earlier versions too)

    (I don't have any client logs because they are not present where they should be according to this link and also there's no "Other" option under "Settings - Options")

    I have Logitech G930 wireless headset and generally it works fine. The headset has a button that turns off the microphone, also the mic can be folded upwards which also disables it. Up until about a month ago it had caused no issues. But then at some point this issue appeared: if I disable the mic with the button or folding and then reenable it, TeamSpeak seems to stop recognizing it and no sound is transmitted, even though Windows recognizes the mic as present and other software (e.g. Skype) can transmit sound just fine.

    I thought it was an issue with the updated version so I rolled back to, but the issue was still present which baffles me.
    Last edited by dante696; September 7th, 2016 at 10:04 AM. Reason: merged

  10. #10
    Join Date
    June 2008
    I still think this is a driver issue and there is something in your log.
    The current log is always present when the client was started in your client under Tools -> Client Log.

    I merged some threads. All had the same problem with similar devices.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  11. #11
    Join Date
    April 2016
    Reporting a similar problem with the G933. I can mute with the soft keys with no problem, but if I park the mic boom, TS3 loses sight of the mic. Windows still sees it, though; the VU meter in the sound panel still bounces if I make noise.

    I have found that closing TS3, unplugging and replugging the USB dongle, and relaunching TS3 is a workaround.

    A stupid workaround.

    But a working workaround.

    Win10 x64
    Headset firmware 98.2.25
    LGS 8.83.85

    Edit, like five minutes later:

    The software versions above were current last night. However, when checking tonight, there was a new LGS (8.87.116). Once that was installed, it alerted me to a new firmware for the headset (98.3.27). The firmware included this fix:

    Fixed issue where microphone remains muted when pulled down.

    So... yay!

  12. #12
    Join Date
    September 2016
    Where can i find this firmware update ? :S all i see on logitech's site is the Logitech gaming software ( and i cant find anything like that in LGS, or am i blind ? :S

  13. #13
    Join Date
    March 2017
    I reinstalled my OS two day ago. I came from Windows 7 and now I have Windows 10 Pro and the same fucking problem

    I have a G933. Newest Logitech LGS 8.91.41 x64 and on the Headset is Firmware version 98.3.27.

    If i mute the mic (fold up) it takes 15sek. and it does not work any more in TS - only in TS!

    Any solutions?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: August 12th, 2016, 12:29 PM
  2. Replies: 9
    Last Post: November 26th, 2012, 04:23 PM
  3. Replies: 1
    Last Post: June 24th, 2012, 07:50 PM
  4. Logitech G930 & Teamspeak 3
    By Baazje in forum General Questions
    Replies: 8
    Last Post: April 4th, 2012, 02:19 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts