Forum

Results 1 to 3 of 3
  1. #1
    Join Date
    September 2016
    Posts
    2

    Teamspeak hotkeys don't work in CSGO and Steam

    I have my 'x' key as talk in game for csgo and also configured it to mute me in teamspeak when I talk in game. I have also set up 'ctrl + enter' to toggle between muted/unmuted.

    This used to work in CSGO a few weeks ago but recently it doesnt work, when I press x to talk in game it doesnt mute my voice in teamspeak and the 'ctrl + enter' shortcut wont do anything.

    Is there a workaround for this or does anyone have any similar problems to this???

  2. #2
    Join Date
    September 2016
    Posts
    2
    Hey man, I see no one has answered this yet, so I'll give it a go:

    The first thing I would check is whether you are running any of the programs as Admin, as any program running at a regular User level wont be able to catch input from Admin programs. So try running all of them as Admin, all as regular User (aka, just run normally, uncheck run as Admin), and try just running TeamSpeak as Admin.

    Still nothing? Alright, double check all your binds, maybe try playing with window focus. I used to be an avid CSGO player and used the '*' key on numpad to mute my mic for example. Always worked. So try switching your binds to something that isn't in use in game.

    My suspicions lay with the "Run as Admin" issues, as thats what I've seen happen the most myself. But give that a go and tell me what happens.

  3. #3
    Join Date
    September 2017
    Posts
    1
    Quote Originally Posted by XubWiz View Post
    Hey man, I see no one has answered this yet, so I'll give it a go:

    The first thing I would check is whether you are running any of the programs as Admin, as any program running at a regular User level wont be able to catch input from Admin programs. So try running all of them as Admin, all as regular User (aka, just run normally, uncheck run as Admin), and try just running TeamSpeak as Admin.

    Still nothing? Alright, double check all your binds, maybe try playing with window focus. I used to be an avid CSGO player and used the '*' key on numpad to mute my mic for example. Always worked. So try switching your binds to something that isn't in use in game.

    My suspicions lay with the "Run as Admin" issues, as thats what I've seen happen the most myself. But give that a go and tell me what happens.
    Got the same problem and elevating the teamspeak3 client to the admin rights is helped. Seems like CSGO recently did something in their last update that elevates their process above the TS3 client if it runs in a normal mode.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: September 5th, 2016, 08:13 PM
  2. Replies: 1
    Last Post: July 4th, 2015, 09:15 AM
  3. Hotkeys sometimes work sometimes not
    By Gamecube in forum Windows
    Replies: 0
    Last Post: June 28th, 2015, 06:32 PM
  4. Hotkeys doesn't work in CounterStrike:Source STEAM
    By naonao in forum Bug Reports [EN/DE]
    Replies: 2
    Last Post: May 18th, 2012, 06:26 PM
  5. TeamSpeak 3 hotkeys do not work
    By TeddyBeertje in forum Windows
    Replies: 0
    Last Post: May 10th, 2011, 11:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •