Previously I had El Capitan installed with an older TS Server version. I had created an Automation, where TS Server would be started automatically after logging in. No problems, everything worked flawlessly.
Now, after installing OSX Sierra, my Mac Mini (server) froze after rebooting. After starting the Mac Mini in Safe mode I was able to install the latest TS3 Server software (P.S. at this point I wasn't sure TS3 Server was the reason my Mac Mini froze after boot). I switched off the Automation and was able to start my Mac Mini up the regular way.

After it booted, I tried to start up TS3 Server again. I got the following error:
"unable to load database plugin library "libts3db_sqlite3.dylib", halting!"

I then placed back my old sqlite3 file (of which I had made a backup when updating the TS3 Server software, according instructions).

Retried launching TS3 Server... no error message... however the whole Mac Mini froze again.... requiring a reboot.

Any help is appreciated? Is it a compatibility issue?