Forum

Results 1 to 4 of 4
  1. #1
    Join Date
    September 2016
    Posts
    3

    No response from server if user avatar doesn't exists (ServerQuery)

    Hi everyone.

    A few days ago was discovered a bug that if a ServerQuery clients tries to request an user avatar that doesn't exists, server simply doesn't respond making systems without verification crashing.

    Here is the discussion on github on TS3Admin PHP class by par0noid:
    https://github.com/par0noid/ts3admin.class/issues/4

  2. #2
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,351
    Confirmed with 3.0.13.4 x86 running on x64 Debian. Though not an infinite loop, server doesn't use notable CPU time (though it does use a little).

  3. #3
    Join Date
    June 2002
    Location
    Netherlands
    Posts
    1,049
    Found the bug. It will be fixed in 3.0.13.5 release. We hope to release a beta on tuesday or wednesday

  4. #4
    Join Date
    June 2002
    Location
    Netherlands
    Posts
    1,049
    Sorry for the delay. The beta can be found here:
    http://dl.4players.de/ts/releases/pr...0.13.5-Beta-1/

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Not possible] Set avatar of user via server query
    By SackZement in forum Server Support
    Replies: 5
    Last Post: September 22nd, 2015, 08:05 AM
  2. No response - ServerQuery
    By Victo in forum Linux / FreeBSD
    Replies: 3
    Last Post: December 20th, 2014, 12:54 AM
  3. The system doesn't response at TeamSpeak 3 shut-down
    By r3n4m3 in forum Client Support
    Replies: 1
    Last Post: May 14th, 2011, 07:17 PM
  4. How to remove other user's avatar as Server Admin
    By Sintharas in forum Client Support
    Replies: 3
    Last Post: January 12th, 2010, 02:48 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •