Forum

Results 1 to 7 of 7
  1. #1
    Join Date
    October 2016
    Posts
    1

    Can't launch teamspeak server on ARM CPU

    hi,i tried to launch teamspeak on raspberry pi. but it isnt worked yet.
    tried 2 os,raspbian and centos7

    this is an error.
    [email protected]:~/teamspeak3-server_linux-x86 $ ./ts3server_startscript.sh start
    Starting the TeamSpeak 3 server
    ./ts3server_startscript.sh: line 68: ./ts3server_linux_x86: cannot execute binary file: Exec format error
    TeamSpeak 3 server could not start

    68 "./${BINARYNAME}" ${COMMANDLINE_PARAMETERS} > /dev/null &

    checked with vim above the statement,but i dont know what should i do..

    i can launch teamspeak on VPS(CentOS6.6) with same situation..

    i am not unacquainted with linux, so i cant do anything about that.

    so i stucked,need some help please.

  2. #2
    Join Date
    June 2008
    Posts
    18,144
    A raspberry pi does not match our minimal System Requirements

    By clicking this link you get the latest system requirements
    Last edited by dante696; February 15th, 2019 at 09:24 AM. Reason: replaced outdated quote with direct link
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    November 2016
    Posts
    1

    ./ts3server: 2: ./ts3server: Syntax error: ")" unexpected

    Hey, so the title says it all:

    ./ts3server: 2: ./ts3server: Syntax error: ")" unexpected

    I am running raspberry pi 3 with the default OS, even a tutorial specific for rasperry got no error, this is the x86 version of the ts3 server.
    send help

  4. #4
    Join Date
    December 2004
    Location
    RF
    Posts
    3,006
    ARM CPU's are not supported.

  5. #5
    Join Date
    October 2016
    Posts
    3
    x86 is not the same instruction set as ARM.

    You probably shouldn't run a server if you don't understand this basic concept.

  6. #6
    Join Date
    November 2016
    Posts
    1

    server dont start

    Hi
    I insalled a ts3server on my raspberry pi and if I want to start the server it says

    [email protected]:~/teamspeak3-server_linux_x86 $ ./ts3server_startscript.sh start
    Starting the TeamSpeak 3 server
    ./ts3server: 1: ./ts3server: ELF4�R4: not found
    ./ts3server: 2: ./ts3server: Syntax error: word unexpected
    TeamSpeak 3 server could not start

    pls help me
    Last edited by dante696; November 12th, 2016 at 07:15 PM. Reason: merged

  7. #7
    Join Date
    March 2017
    Posts
    1
    I have exactly the same problem. But I'm able to kill the ts3server process.
    My server is hosted on a Raspberry Pi 3 with exagear and previous versions worked completely fine.
    Last edited by dante696; March 29th, 2017 at 03:23 PM. Reason: moved out of http://forum.teamspeak.com/threads/129940 (Can't start or stop server)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Teamspeak 3 will not launch
    By jeremymajors in forum Windows
    Replies: 0
    Last Post: April 19th, 2014, 04:17 AM
  2. Teamspeak 3 not appears at launch
    By darkdruid in forum Client Support
    Replies: 5
    Last Post: October 5th, 2010, 01:38 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •