When trying to connect to any server, the client will freeze and is only recoverable by force-quitting the application.

I have tried:
  • Completely reinstalling.
  • Changing playback/capture mode to Direct Sound.
  • Updating/rolling back audio driver. (No updates available.)
  • Using a different audio driver.
  • Running the application as administrator.
  • Restarting the computer and disabling antivirus.


Client Log:
Code:
2016-10-16 19:40:21.998832|INFO    |              |   |TeamSpeak 3 Client 3.0.19.4 (2016-07-14 10:16:58)
2016-10-16 19:40:21.999332|INFO    |              |   |SystemInformation: Windows 10 (14393) x64 (AMD or Intel) Binary: 64bit
2016-10-16 19:40:21.999332|INFO    |              |   |Using hardware aes
2016-10-16 19:40:22.304549|DEBUG   |Direct Sound  |   |setting timer resolution to 1ms
2016-10-16 19:40:22.392111|INFO    |              |   |*** Time [SPAWN_EVENTCONVERTER]: 394
2016-10-16 19:40:22.433641|INFO    |              |   |Loading plugin: clientquery_plugin
2016-10-16 19:40:22.434141|INFO    |              |   |Loading plugin: lua_plugin
2016-10-16 19:40:22.434141|INFO    |              |   |Loading plugin: teamspeak_control_plugin
2016-10-16 19:40:22.434141|INFO    |              |   |Loading plugin: test_plugin
2016-10-16 19:40:22.434141|INFO    |              |   |Loading plugin: ts3g15
2016-10-16 19:40:22.459159|INFO    |Query         |   |listening on 127.0.0.1:25639
2016-10-16 19:40:22.914983|DEVELOP |Windows Audio Session|   |DeviceDeleteList::waitForDeletes - enter
2016-10-16 19:40:22.914983|DEVELOP |Windows Audio Session|   |DeviceDeleteList::waitForDeletes - leave
2016-10-16 19:40:23.085603|INFO    |              |   |*** Time [SERVERVIEW]: 212
2016-10-16 19:40:23.154653|INFO    |              |   |*** Time [SERVERVIEWMANAGER]: 393
2016-10-16 19:40:25.426766|INFO    |InputDevices  |   |Input device name:  
2016-10-16 19:40:25.426766|INFO    |InputDevices  |   |Input device name: Logitech, Inc. Unifying Receiver
2016-10-16 19:40:25.554858|INFO    |Input         |   |Default monitoring enabled
2016-10-16 19:40:25.555358|INFO    |              |   |*** Time [HOTKEYS]: 194
2016-10-16 19:40:25.681948|INFO    |              |   |*** Time [MAINWINDOW]: 3686
2016-10-16 19:40:25.682449|INFO    |              |   |*** Time [INIT]: 3688
2016-10-16 19:40:25.682948|INFO    |ClientUI      |   |*** Time [SQLITE_CONVERTER]: 1002
2016-10-16 19:40:25.736487|INFO    |ClientUI      |   |Qt version: 5.5.1
2016-10-16 19:40:25.736487|INFO    |ClientUI      |   |Using configuration location: C:\Users\bnahi\AppData\Roaming\TS3Client\settings.db
2016-10-16 19:40:26.182804|INFO    |ClientUI      |   |Last update check was: Never
2016-10-16 19:40:26.182804|INFO    |ClientUI      |   |Checking for update
2016-10-16 19:40:26.330909|INFO    |Update        |   |Checking for updates...
2016-10-16 19:40:27.554778|INFO    |Newsticker    |   |Newsticker language change detected
2016-10-16 19:40:27.555279|INFO    |Newsticker    |   |Newsticker next check: 
2016-10-16 19:40:28.550485|INFO    |Newsticker    |   |Newsticker received for language en, expires on Sun Oct 16 13:10:27 2016, next check in 1800 seconds
2016-10-16 19:40:28.711099|INFO    |Update        |   |Check license version: 1
2016-10-16 19:40:28.712603|INFO    |LicenseViewer |   |License language: en
2016-10-16 19:40:28.713101|INFO    |LicenseViewer |   |Requesting remote license for version 1 and language en
2016-10-16 19:40:28.804666|INFO    |LicenseViewer |   |Downloaded license file for version 1 and language en
2016-10-16 19:41:22.049984|INFO    |ClientUI      |1  |Connect to server: ts.zseartcc.org
2016-10-16 19:41:22.412741|INFO    |ClientUI      |1  |Trying to resolve ts.zseartcc.org
2016-10-16 19:41:22.465779|INFO    |TSDNS         |   |DNS resolve successful, "ts.zseartcc.org"=192.169.243.107
2016-10-16 19:41:22.511312|INFO    |TSDNS         |   |SRV DNS resolve unsuccessful for "_ts3._udp.ts.zseartcc.org"
2016-10-16 19:41:23.729676|INFO    |ClientUI      |1  |Lookup finished: 192.169.243.107 9987 ts.zseartcc.org 0 0
2016-10-16 19:41:23.729676|INFO    |ClientUI      |1  |Resolve successful: 192.169.243.107:9987
2016-10-16 19:41:23.730177|INFO    |ClientUI      |1  |Blacklist check ok
2016-10-16 19:41:23.730177|INFO    |ClientUI      |1  |Initiating connection: 192.169.243.107:9987 ts.zseartcc.org
2016-10-16 19:41:24.014379|DEVELOP |Windows Audio Session|   |DeviceDeleteList::waitForDeletes - enter
2016-10-16 19:41:24.014379|DEVELOP |Windows Audio Session|   |DeviceDeleteList::waitForDeletes - leave
TeamSpeak 3.0.19.4. The problem is also consistent with the beta version, 3.1.