Forum

Results 1 to 4 of 4
  1. #1
    Join Date
    October 2016
    Posts
    2

    Logitech G430 issues

    I have a Logitech G430 headset everything worked fine for a few days when all of a sudden when I connect to a teamspeakserver my computer continually starts to disconnect and connect my headphone and mic. I have them connected via USB to my computer. When I do not use TS everything works fine, only when I connect to TS I have these problems. Does anybody have a clue how to solve them?

  2. #2
    Join Date
    January 2013
    Location
    Thüringen
    Posts
    329
    Have you installed the latest Drivers for your headset?

  3. #3
    Join Date
    October 2016
    Posts
    2
    yes I did that.

  4. #4
    Join Date
    January 2013
    Location
    Thüringen
    Posts
    329
    Maybe a lot of Windows updates are missing?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. TS issues with logitech g430
    By Mizore in forum Windows
    Replies: 1
    Last Post: July 11th, 2016, 07:59 AM
  2. How can i set Logitech G430 as device
    By yr1699 in forum General Questions
    Replies: 1
    Last Post: February 18th, 2016, 07:59 AM
  3. logitech g430 not capturing mic
    By capgunmatt in forum Client Support
    Replies: 1
    Last Post: January 8th, 2016, 08:14 AM
  4. Replies: 1
    Last Post: November 19th, 2015, 02:38 PM
  5. Logitech G430 issues
    By thaz1098 in forum Client Support
    Replies: 8
    Last Post: May 26th, 2014, 06:11 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •