Forum

Results 1 to 2 of 2
  1. #1
    Join Date
    December 2016
    Posts
    1

    Server fails to allow outside connections after a random duration.

    Server version: 3.0.13.6 on Linux

    So I'm pretty confused as to what's causing this. Basically everything works fine and people can join and talk on the server perfectly fine. But the problem is, sometimes after a random amount of time (could be an hour or a few days) the server will spit this out when someone attempts to join:

    HTML Code:
    <17:47:41> Trying to resolve hostname <Server DNS>
    <17:47:42> Trying to connect to server on <Server DNS>
    <17:47:47> Failed to connect to server
    I have all the ports forwarded correctly, the server even ran for 10 days without this issue appearing until last week. The DNS is still pointing to the correct IP. I'm also able to connect through the local IP the server is running on (10.1.1.64) but not from outside.

    When this happens all I have to do is restart the server and it works again instantly. So it's not a connection issue as I haven't had to touch anything else except restarting the server.

    I'm at a loss for what the issue is here. Does anyone know what would be causing these random server hiccups?

    EDIT: I feel like I should also mention, the ports I have forwarded are:
    HTML Code:
    Default voice port (UDP in): 9987
    Default filetransfer port (TCP in): 30033
    Default serverquery port (TCP in): 10011
    Those are all the features I use in this server.

    Also I've read people saying that certain routers don't support connecting to your own external IP. Mine allows me to connect through my external IP, which I have been using to debug when this issue occurs.

    EDIT 2: I just had the server start accepting outside connections again on its own. As in, it stopped accepting outside connections, but while I was troubleshooting it, it suddenly started working again... I don't know why it's doing this.
    Last edited by Enigma37; December 13th, 2016 at 02:24 PM.

  2. #2
    Join Date
    June 2008
    Posts
    17,926
    This doesn't look like a server problem for us. It more looks like a problem with your router or firewall.
    Or your IP did change and your router does not recognize it correctly for forwarded ports.

    The reason is simple:
    You still can connect trough the local address.
    The server would also reject the connection in case there is something wrong with the server.

    Is there something strange in your server log?
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ban duration permission
    By god92uk in forum Windows
    Replies: 2
    Last Post: October 24th, 2012, 04:05 PM
  2. Ban duration issue bug?
    By 82ndab.Bravo17 in forum Permission System
    Replies: 2
    Last Post: July 7th, 2011, 01:13 AM
  3. Random Connections Every Minutes...Please Help!
    By paocneusok in forum Permission System
    Replies: 3
    Last Post: April 6th, 2011, 03:49 AM
  4. Spell duration
    By chris579 in forum General Questions
    Replies: 7
    Last Post: April 3rd, 2011, 09:36 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •