Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 8 of 8
  1. #1
    Join Date
    January 2017

    TeamSpeak3 Linux client (3.1/x86) fails to start when IPv6 is disbaled in kernel


    after updating my client to version 3.1 today it won't start anymore. The error message reads:

    TeamSpeak fails to start because it cannot find any port.

    Terminal output:
    $ ./ts3client_linux_x86          
    2017-01-09 19:29:18.862811|INFO    |              |   |TeamSpeak 3 Client 3.1 (2016-12-15 09:43:25)
    2017-01-09 19:29:18.862870|INFO    |              |   |SystemInformation: Linux 4.9.1 #3 SMP PREEMPT Mon Jan 9 16:43:04 CET 2017 i686 Binary: 32bit
    2017-01-09 19:29:18.869036|DEBUG   |PulseAudio    |   |connected to pulse audio server
    2017-01-09 19:29:18.898367|INFO    |Addons        |   |Checking for addon updates...
    2017-01-09 19:29:18.900647|INFO    |Plugins       |   |Loading plugin:
    2017-01-09 19:29:18.927237|INFO    |Query         |   |listening on
    2017-01-09 19:29:19.234976|ERROR   |UDPClient     |   |could not bind :: port 0 error codesystem:97 open: Address family not supported by protocol
    2017-01-09 19:29:19.235087|INFO    |EvtConverter  |   |Error spawning server connecting handler
    I suspect this happens because my kernel is missing IPv6 support entirely. Enabling it in my environment involves some work so I did not verify this theory yet. The addition of IPv6 support is also mentioned in the changelog. It isn't listed as a mandatory requirement though.

  2. #2
    Join Date
    June 2008
    The message TeamSpeak fails to start because it cannot find any port. is means "the client can not open and use any UDP port on your system".
    This is mostly a permission issue or blocked ports/firewall rule.

    Quote Originally Posted by dante696 View Post
    This problem occurs, when your operation system does not offer any port for the client.
    We use Ephemeral ports ranges for the client ( and you will get this error from the client, when we can not open any port for the client.

    Possible reasons are:
    - Firewall/Antivirus tools block the client
    - The network card wasn't found or could not opened
    - A P2P program blocks all ports

    Please check all these points. It's a local problem on your computer.
    The TeamSpeak developers can not fix this.

    knowledge base
    It could be that the kernel or a driver is the issue here, because just deactivating IPv6 did not bring the same result.
    How could it be that your Kernel does not support IPv6 yet. Your system looks like it could not be updated because you are using the latest updates already.
    Which Linux is this?
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    January 2017
    I run Debian stretch/testing with a custom built kernel. Compiling IPv6 support into the kernel resolves the issue.

    I didn't include support into the kernel because my ISP doesn't support IPv6 at all and some applications get confused because of this. The Teamspeak client now is the first app I encountered to require IPv6 to work at all though. Most applications just output a warning and fall back to IPv4.

    If you plan to keep IPv6 support mandatory, improving the error message in case the system returns EAFNOSUPPORT may be a good idea as the error is not strictly related to firewall/blocked ports.

  4. #4
    Join Date
    June 2008
    Thank you for the feedback!

    The client still should work, even when IPv6 is not available.
    Our developers will investigate into this.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  5. #5
    Join Date
    January 2017
    Just to confirm similar findings -- Slackware with kernel 4.9.2 and no IPv6 support resulted in the 'cannot find ports' message with the latest 3.1 Beta. Recompiling a new kernel with IPv6 support resulted in the 3.1 Beta TeamSpeak client working without throwing any errors.

  6. #6
    Join Date
    August 2016
    ipv6? really, thank you.
    Had same issue with ipv6 module blacklisted from loading.

  7. #7
    Join Date
    January 2017


    I can confirm this.
    With grub option
    Teamspeak fails to start. Removing the option resolves the issue.

  8. #8
    Join Date
    February 2017
    still actual, TS client version
    # ./ 
    QCoreApplication::applicationDirPath: Please instantiate the QApplication object first
    Crashdump ENABLED,  directory is: /root/.ts3client/crashdumps
    DUMP defined! Dumpdir is: /root/.ts3client/crashdumps
    2017-02-24 07:28:57.783988|INFO    |              |   |TeamSpeak 3 Client (2017-02-21 09:16:30)
    2017-02-24 07:28:57.784067|INFO    |              |   |SystemInformation: Linux 4.8.6-040806-generic #201610310831 SMP Mon Oct 31 12:33:48 UTC 2016 x86_64 Binary: 64bit
    2017-02-24 07:28:57.784103|INFO    |              |   |Using hardware aes
    2017-02-24 07:28:57.800244|DEBUG   |PulseAudio    |   |connected to pulse audio server
    2017-02-24 07:28:57.831368|INFO    |Addons        |   |Checking for addon updates...
    2017-02-24 07:28:57.833930|INFO    |Plugins       |   |Loading plugin:
    2017-02-24 07:28:57.840663|INFO    |Query         |   |listening on
    2017-02-24 07:28:58.138461|ERROR   |UDPClient     |   |could not bind :: port 0 error codesystem:97 open: Сімейство адрес не підтримується протоколом
    2017-02-24 07:28:58.138618|INFO    |EvtConverter  |   |Error spawning server connecting handler
    # dmesg | grep 'Command line'
    [    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-4.8.6-040806-generic root=UUID=6637b326-b474-433a-bbc8-2afad2104572 ro ipv6.disable=1 quiet splash vt.handoff=7

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: November 17th, 2013, 06:56 PM
  2. Teamspeak3 Fails to Connect
    By GundamWZero in forum Windows
    Replies: 7
    Last Post: December 28th, 2011, 03:25 AM
  3. Replies: 0
    Last Post: February 24th, 2010, 04:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts