I somehow have echo on teamspeak, And it isn't my friends' problem. They dont hear/cause the echo. I teamspeaked with them for a long time, never had echo but suddenly the echo is there.. I already looked in the options, I switched cancellation and reduction on, But it still echo's... Even the voice that says ''Connected'' Or ''Server group assigned'' echo's.... If anybody got tips, please send them to me.

-Chrisbe