Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Page 7 of 8 FirstFirst ... 5678 LastLast
Results 91 to 105 of 112
  1. #91
    Join Date
    February 2019

    PTT & Rhino X56

    HAllo zusammen!

    Habe seit neuesten folgendes Problem:

    Kann meinen Rhino >X56 HOTAS nicht mehr für PTT configurieren.
    Mir wird der Button zwar im grauen Kästchen angezeigt aber kann nicht bestätigen nur wenn ich endweder nen Butten auf dem Keyboard drücke oder die Maus.
    Gamepad Controll Plugin mehrmals de&installiert, TS³ 32 & 64 bit Version getestet kein Erfolg.

    Wäre super wenn jemand ne problemlösende Antwort hat.

    mfg Survival
    Last edited by dante696; February 13th, 2019 at 03:38 PM. Reason: merged

  2. #92
    Join Date
    April 2017
    I first posted in this thread about this issue almost two years ago. For a while I ran an older version of TS so it would work. At some point I updated and it was fine for quite a while. Today I'm having this issue once again. I cannot assign a hotkey to my Warthog throttle, all my other devices can assign keys no problem. Once again I'm downloading an older version so I can play with my friends, here I am wasting time screwing with this instead of playing, this is so frustrating!

    Never mind, can't even do that because the server I'm trying to connect to requires a newer version. I am beyond angry right now.

  3. #93
    Join Date
    April 2019
    Hi, yet another frustrated flightsimmer who is having the same problems and issues re controller Button assignment for PTT using a yoke/joystick button.
    Having read all previous 7 pages, followed the instructions to the letter Post #56, downloading latest 64bit plugin uninstalled reinstalled etc, still no success.

    A previous post hit the nail on the head where they stated it recognises the button on being pressed but does not when it is released waiting for further input to activate it. Subsequent keyboard or mouse button used then binds the joystick + (key/mouse button) then does activates it as a keybinding combination.
    Any Keyboard keys works fine same as the mouse buttons whatever is selected and activates upon release.

    It is just the game controller buttons (in my case a yoke) that doesn't seem to respond on release. It only seems to recognise the controller button being selected but thats where it stops and waits for further action to complete the binding does not recognise the buttons release as it does with keyboard or Mouse.

    Hopefully this can be resolved sooner than later.

    It appears no support coming soon no replies from Teamspeak Team members (Chris, Dante696)where are they as this is not an isolated issue by the sound of the 7 pages of posts. This post was submitted on 2 April and its now over 2 months 16 June without even a reply !

    No wonder ppl are looking for alternatives
    Last edited by rf253; June 16th, 2019 at 01:00 AM.

  4. #94
    Join Date
    June 2019
    Hi All

    Glad to see there are other people out there suffering just as I am; call it cruel, but I'm glad to not be the only one suffering from this.

    Previously, I could use TeamSpeak 3 with my Saitek Cyborg Evo Force. One day however, updating TeamSpeak 3 the plugin functionality for good. Hell, even on a NEW operating system, new hard drive and what not, I am unable to get my Joystick Hotkeys to work, be it downloading via the online official way, the plugin in Post #56 or what not.

    What I have noticed are that users such as @Dreggan79 and such are getting the same error I am when we check our log files:
    2019-06-17 10:42:11.694041|INFO    |Plugins       |   |Failed to load plugin: C:\Users\-my user directory here-\AppData\Roaming\TS3Client\plugins\gamepad_joystick_win32.dll
    2019-06-17 10:42:11.695041|INFO    |Plugins       |   |LoadLibrary error: 127
    Upon Googling LoadLibrary Error: 127 - I see that it's to do with Visual Studio and is something to do with a missing dependency or such. I'd like to kindly ask other users to please, delete all your logs at: C:\Users\-YourUsernamehere-\AppData\Roaming\TS3Client\logs , then to launch TS3 and try to reload all your plugins and paste your logs or post a post confirming, I have Error 127 or something.

    I will soon be deleting TeamSpeak 3 with RevoUninstaller to completely wipe out TeamSpeak 3 and then copy an older install that my sister has to see if I can get it working again as I really need my Joystick bind for Combat flight sessions and even on Arma 3.

    Edit: PS This only breaks/occurs after TeamSpeak versions 3.2.0 and beyond. I have about 30 downloads of TS3 installers now... :^)

    Last edited by Ghost129er; June 17th, 2019 at 12:21 PM. Reason: Edit

  5. #95
    Join Date
    July 2019
    Quote Originally Posted by Ghost129er View Post

    Glad to see there are other people out there suffering just as I am; call it cruel, but I'm glad to not be the only one suffering from this.
    Yep still suffering, please give this thread some love admin.

    I have the same behavior as described in earlier threads. Downloaded latest addon after trying post #56 recommendations.

    I also get the behavior, that if I reload the plugin, that the first time I use it, my throttle button( ch pro ) is recognised. But the set hotkey window remains open, apparently waiting for a key release, I can exit the window by pressing mouse or some other button or by hitting escape. But I can't set the button. Throttle works fine in game.

    The thing I can add, is that I can get the first time behavior again, by clicking "reload" for the gamepad addon on the addons, myaddons page.

    Would really appreciate the developers giving this some love, seems to be something to do with the key release being expected but never happening in the joystick gamepad case.

  6. #96
    Join Date
    August 2019
    Same exact issue. Why has this gone on so long with no resolution?

    The other weird thing, on my previous system it worked fine with TS 3.3.0. No issues at all, ever!

    I even tried installing an old unaffected version on my new system and upgrading to TS 3.3.0. Still doesn't work. Also tried copying over the old appdata/roaming/TS3Client directory. Still no dice.

    Both Windows 10, both using the same Warthog throttle.

  7. #97
    Join Date
    August 2019
    Hi Guys!

    Strange thing. I've tried the plugin yet again after hearing your comments and by some mysterious and magical somehow, the plugin is working for me.

    What? I wish I knew what or how but it just is working again.

    What I did was use some program to completely uninstall all instances of Visual C and then reinstall it; I forgot what the program was called but my exe is called:

    Visual C++ v56.exe (maybe it was this? )

    See if any of you can give that a shot and see if that is what fixes it...

    I don't promise anything but I'm assuming this is what fixed it, that or was a Windows 7 update...

  8. #98
    Join Date
    August 2019

    Push to talk issue


    When I select a PTT button (eg. a button on my joystick), TS3 automatically adds 'MOUSE BUTTON 1 (Default)' to it. And PTT then only works with the mouse button, and not with the selected joystick button.

    Your guidance would be appreciated, thx Vordy

  9. #99
    Join Date
    September 2019

    G27/29 wheel issue

    Having same issue. Cannot assign hotkey for push to talk for iracing use. Absolutely no help from teamspeak or logitech. and profile does not work either. completely ridiculous nobody is willing to help

    Quote Originally Posted by bchav00 View Post
    Sorry for being a noob...

    I'm having difficulty assigning the push to talk setting to my g27 wheel. It works when assigning the button to my keyboard or mouse, but not the wheel. It had been working before the most recent update to the teamspeak client.

    Example: When assigning the button for push to talk. I can press "n" on the keyboard and the button is assigned. But when I try to use "button 7" from the wheel, it waits until I use another button from the keyboard or mouse resulting in a "button 7 + MOUSE1" or "button 7 + n"

    Like I said, I was able to assign "button 7" as my hot key, but after the new update it hasn't worked.

    I'm running Windows XP.

    I'm an adult, but I'm also a noobie to pc gaming... Anymore information needed, please tell me where to find... Thank you for any help.

  10. #100
    Join Date
    September 2019
    I'm having the same issue with 3.2.2 using a TM Warthog Throttle (No TARGET software installed) trying to bind a key for PTT
    Ts3 shows Button 3 pressed (mic switch up hat) but it never shows it release.

    After reading this thread I downloaded an old installer for 3.0.19 and confirmed I could bind the key correctly in that version. I then attempted to upgrade from 3.0.19 to 3.2.2 and while it carried over my button 3 mapping it had the same behaviour when pressed as when I was trying to map it, in that the key was detected as pressed but never released leading to constant a hot mic.

    Not sure what it is about the recent versions that detect the controller button press but not release.

    CPU: Ryzen 3900X
    Mobo: Asus X570-E BIOS 7010
    RAM: 64GB
    GPU Gigabyte 1080ti
    OS: Win 10 x64 Pro 1903 Build 18362.356

  11. #101
    Join Date
    October 2019

    Wirelles controller hotkey problem

    Hi, I've got a problem with adding hotkey for push to talk.
    The problem is when I press a key to add for push to talk, it detects for the first time that I pressed the button but not releasing it and if I escape it than it won't detect that button anymore.
    I've read a lot of threads about this problem but those solutions don't work anymore so I'm just hoping that someone could help me

  12. #102
    Join Date
    October 2019

    Push to talk issues when assigning controller button

    Issue: My push to talk key was assigned to a button on my controller (Thrustmaster Wheel) and it was working fine. After the last update it was not working anymore. When trying to assign the controller button again, on the first try when it needs the input, it recognizes the button press but the 'input window' is not disappearing. It is waiting for a secondary input like a mouse click or keyboard input. It only disappears if I click or type. When I try to delete the assigned keys (like: button13 + mouse1 click) the deleting action works with the ESC key, but when I try again to assign a hotkey for PTT then it will not take any buttons from the controller. When I close TS and restart it, then it will take the controller button again as PTT input but the whole story starts again for waiting a second input.

    Same issue was reported in the past by other users but noone really received any feedback hove to solve this.

    I tried to update to the beta branch but did not solve the issue.

    I tried to uninstall and reinstall Teamspeak, but also did not work.

  13. #103
    Join Date
    October 2019

    Joystick key release not being recognized

    Up until recently, I have been able to toggle my microphone mute with a button on my joystick. For whatever reason, it stopped working, so I went in to re-map the button that mutes the mic on press and unmutes on release. However, TS does not seem to be recognizing when the button is released. I choose the action, click the "No Hotkey Assigned" button and press the joystick button. The button is recognized, but the window doesn't go away.

    A similar problem was reported in

    but that was with PTT, not hotkeys.

    I have the Gamepad and Joystick Hotkey Support installed.

    Joystick is a Saitek X45, but when joystick button is pressed, it shows up as "Gamepad_Joystick", not Saitek X45.

    In a possible related issue, each button can only be recognized ONCE unless the Gamepad Hotkey support add-on is reloaded. For instance, if I try to map button 5 it will recognize the press and wait until I press a keyboard key (giving me a hotkey of "Button 5 (Gamepad_Joystick) + Esc (keyboard)". If I then reattempt and choose a different button (such as Button 3), the same thing happens with button 3, but you can never go back to Button 5 unless you restart the add-on.

    It LOOKS like once the add-on detects the button press, it is not detecting the release until restart.

    Again, this all worked fine until yesterday.


  14. #104
    Join Date
    October 2019

    Joystick button release still not being detected

    Having same problem as above. Joystick button releases not being detected. Looks like joystick not being properly recognized--shows as "Gamepad_Joystick" but I think it was previously recognized as Saitek X45.

    TS version 3.3.2. Drivers up to date, Gamepad and Joystick Hotkey Support v1.2 installed and enabled, joystick drivers installed and enabled.

    Worked fine until yesterday.

  15. #105
    Join Date
    November 2019

    I have the same issue

    I have the same issue.

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. Gamepad and joystick hotkey support plugin not loading
    By skyranger in forum Client Plugins / Lua Scripts
    Replies: 6
    Last Post: November 24th, 2017, 12:26 PM
  2. Replies: 3
    Last Post: November 11th, 2017, 11:31 AM
  3. Gamepad Hotkey Support for MAC
    By DR4Z7IK in forum macOS
    Replies: 4
    Last Post: May 18th, 2017, 12:40 PM
  4. [Resolved] Gamepad and Joystick Hotkey addon creates GB of excessive log entries
    By Irios in forum Client Plugins / Lua Scripts
    Replies: 1
    Last Post: March 27th, 2017, 07:41 AM
  5. Won't allow me to set up joystick hotkey
    By dandancoope in forum Windows
    Replies: 3
    Last Post: November 14th, 2014, 06:29 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts