Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Page 8 of 8 FirstFirst ... 678
Results 106 to 112 of 112
  1. #106
    Join Date
    October 2019
    Quote Originally Posted by Gepida View Post
    Issue: My push to talk key was assigned to a button on my controller (Thrustmaster Wheel) and it was working fine. After the last update it was not working anymore. When trying to assign the controller button again, on the first try when it needs the input, it recognizes the button press but the 'input window' is not disappearing. It is waiting for a secondary input like a mouse click or keyboard input. It only disappears if I click or type. When I try to delete the assigned keys (like: button13 + mouse1 click) the deleting action works with the ESC key, but when I try again to assign a hotkey for PTT then it will not take any buttons from the controller. When I close TS and restart it, then it will take the controller button again as PTT input but the whole story starts again for waiting a second input.

    Same issue was reported in the past by other users but noone really received any feedback hove to solve this.

    I tried to update to the beta branch but did not solve the issue.

    I tried to uninstall and reinstall Teamspeak, but also did not work.
    I have found the issue here.

    I am using now an USB HUB and I connect the controller from there to the PC. If I connect the controller to the PC directly, the release of the key is also recognised and all works like it should.
    Once I connect the controller to the USB Hub, only the initial key press is recognised by Teamspeak and the release is not.

    Any advice apart from "plug it into your PC directly ?"

  2. #107
    Join Date
    November 2019
    Quote Originally Posted by Inflex View Post
    Yes, I have same issue. It does not detect the button release and never finishes.

    Try restarting "Gamepad and Hotkey support module" and it will accept one more button press (does not help to solve the problem but it is a way to confirm it is problem with the module).
    This solved it, thanks!

  3. #108
    Join Date
    January 2010
    Same issue here, problem appear with the 3.3.2 version for Windows 64bits

    Name:  dsYwO8G.png
Views: 2278
Size:  6.7 KB

  4. #109
    Join Date
    July 2013
    Earth: Undisclosed Location

    Xbox Elite Series 2 Controller PTT with Paddles?

    Does anyone here use an Xbox Elite Series 2 controller as a wired controller with the included USB cable & use the additional paddles for PTT in TeamSpeak?
    I’m looking at this controller specifically for the paddles. I currently use an Xbox 360 wired controller & have PTT mapped to the left bumper, but the left bumper is also mapped to many other functions in game.

    Can anyone (if anyone has the controller) conform if those paddles will be recognized as BUTTON_X (where X is a number. Left Bumper is recognized as BUTTON_5 for example), by the gamepad hotkeys plug-in?

    My alternative if the paddles don’t work, is using the mapping software known as reWASD & mapping a paddle to the same keyboard button that also activates PTT.

  5. #110
    Join Date
    October 2019

    TS recognizes X56 stick but not throttle

    I just got a Logitech X56. All switches register in control panel and in games. Teamspeak, however, doesn't even recognize the throttle buttons. With my Saitek X45, when I assigned buttons, the device was listed by name as "Saitek X45." With the X56, it just says "Gamepad/Joystick" for the buttons on the stick and gives no response for the buttons on the throttle.

    Any ideas how to get the buttons on the throttle working so I can put my PTT on the throttle where it belongs?

    Thanks for any help!
    Last edited by dante696; December 9th, 2019 at 11:11 AM. Reason: merged

  6. #111
    Join Date
    December 2019

    PTT not working with new Accuforce wheel buttons


    I just recently got a new Accuforce V2 wheel. I have not been able to get PTT to work since getting it. It used to work fine with my Fanatec buttons on that wheel.

    When i go to set the hot key button, it recognizes it but the grey box just stays there until i click the mouse button or a key on the keyboard, then it reflects both keys as the trigger. then all it takes is the mouse button or the keyboard key to transmit. I can't get any of the buttons on the wheel to close out or deactivate once it is pushed.

    Any help would be greatly appreciated. Thank you. Troy

  7. #112
    Join Date
    January 2020

    Issue with setting controller hot key for PTT

    Hello, I used team speak for about a year for FiveM. I had always added the A button on my controller as a TS3 PTT however I uninstalled it a few months ago because I no longer needed it and when I went to reinstall it a few days ago and add the hotkey I started running into issues.

    The first time I try to add the hotkey it recognizes the input but hangs like its not recognizing the button release until I press a key on my keyboard then it turns into a hotkey combination. After this I then need to reload all my plugins just for it to recognize input from my controller again.

    I tried going back to the version I had working a few months ago but it didn't do anything, I would try an older version of the controller support plugin but I can't seem to find one. I have uninstalled and reinstalled the plugin and my drivers for the xbox one controller multiple times and tried using the pre update plugin from another forum that seemed to be having the same issue but still stuck with the issue.

    Any help would be appreciated.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Gamepad and joystick hotkey support plugin not loading
    By skyranger in forum Client Plugins / Lua Scripts
    Replies: 6
    Last Post: November 24th, 2017, 12:26 PM
  2. Replies: 3
    Last Post: November 11th, 2017, 11:31 AM
  3. Gamepad Hotkey Support for MAC
    By DR4Z7IK in forum macOS
    Replies: 4
    Last Post: May 18th, 2017, 12:40 PM
  4. [Resolved] Gamepad and Joystick Hotkey addon creates GB of excessive log entries
    By Irios in forum Client Plugins / Lua Scripts
    Replies: 1
    Last Post: March 27th, 2017, 07:41 AM
  5. Won't allow me to set up joystick hotkey
    By dandancoope in forum Windows
    Replies: 3
    Last Post: November 14th, 2014, 06:29 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts