Quote Originally Posted by Gepida View Post
Issue: My push to talk key was assigned to a button on my controller (Thrustmaster Wheel) and it was working fine. After the last update it was not working anymore. When trying to assign the controller button again, on the first try when it needs the input, it recognizes the button press but the 'input window' is not disappearing. It is waiting for a secondary input like a mouse click or keyboard input. It only disappears if I click or type. When I try to delete the assigned keys (like: button13 + mouse1 click) the deleting action works with the ESC key, but when I try again to assign a hotkey for PTT then it will not take any buttons from the controller. When I close TS and restart it, then it will take the controller button again as PTT input but the whole story starts again for waiting a second input.

Same issue was reported in the past by other users but noone really received any feedback hove to solve this.

I tried to update to the beta branch but did not solve the issue.

I tried to uninstall and reinstall Teamspeak, but also did not work.
I have found the issue here.

I am using now an USB HUB and I connect the controller from there to the PC. If I connect the controller to the PC directly, the release of the key is also recognised and all works like it should.
Once I connect the controller to the USB Hub, only the initial key press is recognised by Teamspeak and the release is not.

Any advice apart from "plug it into your PC directly ?"