Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 3 of 3
  1. #1
    Join Date
    March 2017
    Posts
    2

    Unable to connect to Teamspeak Server from External IP

    Ive been trying for 6-7 hours now to get a TS3 server up and running to host for a few mates. I have a Qnap TS-1263U-RP that i can run Linux Ubuntu-64bit 16.04 Server in Virtualization.

    I use Linux regularly and i know how to get around the CLI on the server with easy. Anyway ive managed to install the TS3 server (3.0.13.6) and run it as a service. It all works fine and i can connect to the TS3 server on any PC that has a Local LAN IP. (192.168.2.XXX).
    I ran the "ts3server_minial_runscript.sh createinifile=1" to make a config file to run for the startscript, then Crtl+C to stop the server. Ive then edited the voice port from the default 9987 to say 10550 and saved the ini file.

    However when i go to run the server with the following
    "sudo /home/teamspeak/ts3server_startscript.sh start inifile=ts3server.ini" (created a teamspeak user)

    The server will start but ignores any settings ive changed in the ini file. Which means it runs on the default port.
    But the most troublesome part is the fact that on one can connect to my server using my WANIP. The TS3 logs dont show that any attempt was tried to connect. (All ports are forwarded on my router)

    What ive noticed from the logs is that the server is listening on 0.0.0.0::9887, changing the voice_ip in the ini file to the routers internal and external IP has done nothing. (But thats due to the ini file not been used when i run the startscript).

    So have i missed something why isnt the server using my ini file?

  2. #2
    Join Date
    September 2012
    Posts
    6,079
    If you called the file ts3server.ini and are in fact starting the server with inifile=ts3server.ini as you posted then it is being used!
    However the default voice port is exactly that - the *default* port for a new virtual server. Since you already have a virtual server that was created on port 9987 the server doesn't create another one. You need to delete the old server (so another one is created) or edit the one you already have to use a different port.

    You can do both using the server query, or you can delete the ts3server.sqlitedb (while the server is not running) to reset and get a new server from scratch.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  3. #3
    Join Date
    March 2017
    Posts
    2
    Alright so ive got the Teamspeak virtualserver 1 to run on the new port and now people can join. (Maybe my ISP blocks the default ports? I'll have to ask)
    However if the server idles with no one connected for a few hours it stops working. Well the voice port does anyway.
    I can still connect to it through Putty and port 10010 but no clients will connect to it.
    Stopping the TS service though the sudo command did nothing when restarting the service. Rebooting the VM though the terminal didnt fix the problem but hard powering off the VM machine seems to have fixed it for now. (Killing the VM PID from SSH login to the Qnap)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: August 26th, 2016, 06:22 PM
  2. Unable To Connect Via External IP
    By Paralysis in forum Windows
    Replies: 1
    Last Post: September 17th, 2013, 12:20 PM
  3. Replies: 2
    Last Post: May 27th, 2013, 06:09 PM
  4. Replies: 1
    Last Post: December 11th, 2012, 12:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •