Forum

Results 1 to 9 of 9
  1. #1
    Join Date
    March 2017
    Posts
    7

    Issue running lua scripts with the lastest update (3.1.2)

    Hi, i just format my pc, so i was trying to reinstall the lua scripts as always, sadly this time i got an error or something, cuz i couldnt use my scripts... can someone help me out?

    https://puu.sh/uWcvr/59a77080a4.png

  2. #2
    Join Date
    September 2012
    Posts
    6,079
    you need to have the LUA plugin installed and enabled. See Tools -> Options -> Addons -> Browse online -> search LUA
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  3. #3
    Join Date
    March 2017
    Posts
    7
    I do have it installed, i tried uninstall it and after that reinstall the plugin again buit nothing, this is how it appears on the addons screen!

    Name:  ef3687fddf.png
Views: 185
Size:  61.0 KB

  4. #4
    Join Date
    September 2012
    Posts
    6,079
    Try reload all or restarting the client.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  5. #5
    Join Date
    March 2017
    Posts
    7
    i did, sadly nothing happens is still the same problem! if ever can you send me a print screen of your addon screen to see if there is any difference on the settings/?

  6. #6
    Join Date
    November 2013
    Posts
    322
    Quote Originally Posted by lord edd View Post
    i did, sadly nothing happens is still the same problem! if ever can you send me a print screen of your addon screen to see if there is any difference on the settings/?
    Head over to '%AppData%\TS3Client\plugins', delete the folder 'lua_plugin' and the file(s) 'lua_plugin_win32.dll', 'lua_plugin_win64.dll'. Now it should be gone from your addons list and you should be able to reinstall it.

    I have the feeling you will not find the folder, though. I deleted it for testing purposes, and reproduced your "button situation" that way.

    Edit: Or do what Chris wrote. Chris definitely knows what they are doing, in contrast to me.
    Last edited by Brady_The; March 24th, 2017 at 11:08 PM.

  7. #7
    Join Date
    September 2012
    Posts
    6,079
    installing works just fine here, it's enabled automatically.
    Maybe something went wrong in your database. If you're using Synchronization and have all your important bookmarks, identities, hotkeys in Sync you could try closing the client, renaming the settings.db and addons.ini in %AppData%\TS3Client (or move them somewhere else) and then start the client again. Accept the License then log in to your account. Wait a couple minutes and then check your addons, install any from the Browse online section that you're now missing.
    If everything is correct now (that is plugins get activated automatically after being installed) please send the old settings.db and addons.ini that you renamed to me privately. You may want to use a password protected archive for those files if you upload it somewhere.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  8. #8
    Join Date
    March 2017
    Posts
    7
    Hi, nothing i tried both methods and nothings happens! so i guess i will try an older version i found looking on google and ill let you know if it works!

  9. #9
    Join Date
    March 2017
    Posts
    7
    Well i tried with a client v. 3.1 and everything was working, it seem is some bug with the current client once it change the destination of the lua folder from /Program Files/ to /App Data/ it stop working! hopefully some one else can find a way to get the lastest version and the lua scripts works!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: November 8th, 2012, 12:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •