Forum

Results 1 to 4 of 4
  1. #1
    Join Date
    March 2017
    Posts
    2

    Slow connect procedure with domain

    If i try to connect to my server with the IP(v4) everything is fine and the connection is established within 1 second.
    But if i try to connect to the server with a domain name the connection takes a few seconds, here is the client log:
    Code:
    26.03.2017 00:31:09    ClientUI    Info    Connect to server: ts3.example.com    
    26.03.2017 00:31:09    ClientUI    Info    Trying to resolve ts3.example.com    
    26.03.2017 00:31:09    TSDNS    Info    A/AAAA DNS resolve successful, "ts3.example.com" =(h: 2001:db8::1 p:0), (h: 101.102.103.104 p:0)    
    26.03.2017 00:31:09    TSDNS    Info    A/AAAA DNS resolve for possible TSDNS successful, "ts3.example.com" =(h: 2001:db8::1 p:0), (h: 101.102.103.104 p:0)    
    26.03.2017 00:31:09    TSDNS    Info    A/AAAA DNS resolve for possible TSDNS successful, "example.com" =(h: 2001:db8::2 p:0), (h: 138.201.175.159 p:0)    
    26.03.2017 00:31:09    TSDNS    Info    SRV DNS resolve unsuccessful, "_tsdns._tcp.example.com" DNS server returned answer with no data    
    26.03.2017 00:31:09    TSDNS    Info    SRV DNS resolve successful, "_ts3._udp.ts3.example.com" =(h: ts3.example.com p:9987)    
    26.03.2017 00:31:09    TSDNS    Info    A/AAAA DNS resolve successful, "ts3.example.com" =(h: 2001:db8::1 p:0), (h: 101.102.103.104 p:0)    
    26.03.2017 00:31:09    ClientUI    Info    Lookup finished: ip=2001:db8::1 port=9987 query=ts3.example.com error=0    
    26.03.2017 00:31:09    ClientUI    Info    Resolve successful: [2001:db8::1]:9987 101.102.103.104:9987    
    26.03.2017 00:31:09    ClientUI    Info    Blacklist check ok    
    26.03.2017 00:31:09    ClientUI    Info    Initiating connection: [2001:db8::1]:9987    
    26.03.2017 00:31:09    Windows Audio Session    Devel    DeviceDeleteList::wait_for_deletes - enter - DeviceDeleteList    
    26.03.2017 00:31:09    Windows Audio Session    Devel    DeviceDeleteList::wait_for_deletes - leave - DeviceDeleteList    
    26.03.2017 00:31:09    Windows Audio Session    Debug    WAS::openDevice-enter - {0.0.0.00000000}.{a948dd14-d4dd-493d-b891-955a1d249501}    
    26.03.2017 00:31:09    Windows Audio Session    Devel    Format detected: Multichannel capable Float - Lautsprecher (Realtek High Definition Audio)    
    26.03.2017 00:31:09    TSDNS    Info    TSDNS found at 2001:db8::1:41144 and queried successfully. Result: (h: 2001:db8::1 p:9987), (h: 101.102.103.104 p:9987)    
    26.03.2017 00:31:09    Windows Audio Session    Info    Initialized with 2 channels in 16bit, 48kHz. - Lautsprecher (Realtek High Definition Audio)    
    26.03.2017 00:31:09    Windows Audio Session    Devel    WAS Buffer size: 1056 - Lautsprecher (Realtek High Definition Audio)    
    26.03.2017 00:31:09    Windows Audio Session    Debug    WAS::openDevice-leave - {0.0.0.00000000}.{a948dd14-d4dd-493d-b891-955a1d249501}    
    26.03.2017 00:31:09    Windows Audio Session    Debug    WAS::startDevice-enter - {0.0.0.00000000}.{a948dd14-d4dd-493d-b891-955a1d249501}    
    26.03.2017 00:31:09    Windows Audio Session    Debug    WAS::startDevice-leave - {0.0.0.00000000}.{a948dd14-d4dd-493d-b891-955a1d249501}    
    26.03.2017 00:31:09    TSDNS    Info    A/AAAA DNS resolve successful, "blacklist.teamspeak.com" =(h: 46.105.112.65 p:0)    
    26.03.2017 00:31:09    TSDNS    Info    TSDNS found at 2001:db8::2:41144 and queried successfully. Result: (h: 2001:db8::1 p:9987), (h: 101.102.103.104 p:9987)    
    26.03.2017 00:31:09    Windows Audio Session    Devel    DeviceDeleteList::wait_for_deletes - enter - DeviceDeleteList    
    26.03.2017 00:31:09    Windows Audio Session    Devel    DeviceDeleteList::wait_for_deletes - leave - DeviceDeleteList    
    26.03.2017 00:31:09    Windows Audio Session    Debug    WAS::openDevice-enter - {0.0.1.00000000}.{fb8b1254-126e-4258-9bf2-9e63ebcfd190}    
    26.03.2017 00:31:09    Windows Audio Session    Devel    Format detected: Multichannel capable Float - Mikrofon (Realtek High Definition Audio)    
    26.03.2017 00:31:09    Windows Audio Session    Info    Initialized with 2 channels in 16bit, 48kHz. - Mikrofon (Realtek High Definition Audio)    
    26.03.2017 00:31:09    Windows Audio Session    Devel    WAS Buffer size: 1074 - Mikrofon (Realtek High Definition Audio)    
    26.03.2017 00:31:09    Windows Audio Session    Debug    WAS::openDevice-leave - {0.0.1.00000000}.{fb8b1254-126e-4258-9bf2-9e63ebcfd190}    
    26.03.2017 00:31:09    PreProSpeex    Info    Speex version: speex-1.2beta3    
    26.03.2017 00:31:09    Windows Audio Session    Debug    WAS::startDevice-enter - {0.0.1.00000000}.{fb8b1254-126e-4258-9bf2-9e63ebcfd190}    
    26.03.2017 00:31:09    Windows Audio Session    Debug    WAS::startDevice-leave - {0.0.1.00000000}.{fb8b1254-126e-4258-9bf2-9e63ebcfd190}    
    26.03.2017 00:31:09    Windows Audio Session    Debug    WAS::associateAECDevice-enter - {0.0.1.00000000}.{fb8b1254-126e-4258-9bf2-9e63ebcfd190}    
    26.03.2017 00:31:09    Windows Audio Session    Devel    Format detected: Multichannel capable Float - Lautsprecher (Realtek High Definition Audio)    
    26.03.2017 00:31:09    Windows Audio Session    Info    Initialized with 2 channels in 16bit, 48kHz. - Lautsprecher (Realtek High Definition Audio)    
    26.03.2017 00:31:09    Windows Audio Session    Devel    WAS Buffer size: 1056 - Lautsprecher (Realtek High Definition Audio)    
    26.03.2017 00:31:09    Windows Audio Session    Debug    WAS::associateAECDevice-leave - {0.0.1.00000000}.{fb8b1254-126e-4258-9bf2-9e63ebcfd190}    
    26.03.2017 00:31:09    Windows Audio Session    Devel    IAudioClient::GetDevicePeriod10.000000ms - Lautsprecher (Realtek High Definition Audio)    
    26.03.2017 00:31:09    ClientUI    Info    Connect status: Connecting    
    26.03.2017 00:31:14    ClientUI    Info    Blacklist check timeout    
    26.03.2017 00:31:14    ClientUI    Info    Connect status: Disconnected    
    26.03.2017 00:31:14    ClientUI    Info    Blacklist check ok    
    26.03.2017 00:31:14    ClientUI    Info    Initiating connection: 101.102.103.104:9987    
    26.03.2017 00:31:14    TSDNS    Info    A/AAAA DNS resolve successful, "blacklist.teamspeak.com" =(h: 46.105.112.65 p:0)    
    26.03.2017 00:31:14    ClientUI    Info    Connect status: Connecting    
    26.03.2017 00:31:14    PktHandler    Devel    Puzzle solve time: 6    
    26.03.2017 00:31:14    ClientUI    Info    Connect status: Connected    
    26.03.2017 00:31:14    ClientUI    Info    Connect status: Establishing connection    
    26.03.2017 00:31:14    ClientUI    Info    Connect status: Connection established
    The main problem i guess is this line:
    Code:
    26.03.2017 00:31:14    ClientUI    Info    Blacklist check timeout
    The server itself shouldn't be the problem, correct? If i try as i said directly with IP:
    Code:
    26.03.2017 00:37:41    ClientUI    Info    Connect to server: 101.102.103.104    
    26.03.2017 00:37:41    ClientUI    Info    Connect status: Disconnected    
    26.03.2017 00:37:41    ClientUI    Info    Disconnected or forced to leave, want autoreconnect = 0    
    26.03.2017 00:37:41    ClientUI    Info    Connecting to next server...    
    26.03.2017 00:37:41    ClientUI    Info    Connect to server: 101.102.103.104    
    26.03.2017 00:37:41    ClientUI    Info    Blacklist check ok    
    26.03.2017 00:37:41    ClientUI    Info    Initiating connection: 101.102.103.104:9987    
    26.03.2017 00:37:41    TSDNS    Info    A/AAAA DNS resolve successful, "blacklist.teamspeak.com" =(h: 46.105.112.65 p:0)    
    26.03.2017 00:37:41    ClientUI    Info    Connect status: Connecting    
    26.03.2017 00:37:41    PktHandler    Devel    Puzzle solve time: 7    
    26.03.2017 00:37:41    ClientUI    Info    Connect status: Connected    
    26.03.2017 00:37:41    ClientUI    Info    Connect status: Establishing connection    
    26.03.2017 00:37:41    ClientUI    Info    Connect status: Connection established
    Everything is fast.

    Some more informations about the server:
    OS: Debian 8
    Version of Teamspeak-Server: 3.0.13.6
    Database: MySQL
    IPTables: Ports open (I turned it completly off for this test)

    DNS-Settings:
    SRV
    Click image for larger version. 

Name:	ts3-dns1.png 
Views:	137 
Size:	12.6 KB 
ID:	15250
    A
    Click image for larger version. 

Name:	ts3-dns2.png 
Views:	80 
Size:	2.9 KB 
ID:	15251

    Some more additional informations:
    If i try to connect to a server hosted by a regular hoster everything is fine, too.
    I googled for several hours but i can't find a solution.

  2. #2
    Join Date
    September 2012
    Posts
    6,044
    Your client is IPv6 capable and so is the server. As such the client will attempt an IPv6 connection first as IPv6 is the preferred protocol. Your server however is not listening on IPv6, despite your records indicating to the client that it is available on IPv6. The connection will thus timeout and the client only then falls back to IPv4.

    Fix is easy: Either allow the TeamSpeak server to listen to IPv6 as well, or don't claim that it is available on IPv6 by removing the AAAA record from the target of the SRV record (ie. ts3.example.com shouldn't have an AAAA record unless the TeamSpeak Server is also listening on IPv6).
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  3. #3
    Join Date
    March 2017
    Posts
    2
    This is it! Thank you very much!

  4. #4
    Join Date
    November 2018
    Posts
    1
    I am trying to setup a ts3 server on my linux server. It works, all ports are set, but if you try to connect to the server it takes about 5-10 seconds. It shows the "connecting to server"-message two times until it finally connects.

    client protocol:

    Code:
    29.11.2018 09:27:03		Info	TeamSpeak 3 Client 3.2.3 (2018-10-02 07:57:10)	
    29.11.2018 09:27:03		Info	SystemInformation: Windows 10 (17134) x64 (AMD or Intel) Binary: 64bit	
    29.11.2018 09:27:03		Info	Using hardware aes	
    29.11.2018 09:27:03	Direct Sound	Debug	setting timer resolution to 1ms - 	
    29.11.2018 09:27:03	SoundBckndIntf	Error	C:/Program Files/TeamSpeak 3 Client/soundbackends/directsound_win64.dll error: NO_DEFAULT_FOUND	
    29.11.2018 09:27:03	SoundBckndIntf	Error	C:/Program Files/TeamSpeak 3 Client/soundbackends/directsound_win64.dll error: NO_DEFAULT_FOUND	
    29.11.2018 09:27:03	Windows Audio Session	Error	GETTING_DEFAULTAUDIOENDPOINT: Element nicht gefunden. - 	
    29.11.2018 09:27:03	SoundBckndIntf	Error	C:/Program Files/TeamSpeak 3 Client/soundbackends/windowsaudiosession_win64.dll error: GETTING_DEFAULTAUDIOENDPOINT	
    29.11.2018 09:27:03	ClientUI	Info	OpenGL Info: LibGLES, Vendor: Google Inc., Renderer: ANGLE (NVIDIA GeForce GTX 970 Direct3D11 vs_5_0 ps_5_0), Version: OpenGL ES 2.0 (ANGLE 2.1.99f075dade7c)	
    29.11.2018 09:27:03	Addons	Info	Checking for addon updates...	
    29.11.2018 09:27:03	Plugins	Info	Loading plugin: teamspeak_control_plugin_win64.dll	
    29.11.2018 09:27:03	ControlPlugin	Info	Control Plugin started, accepting connections	
    29.11.2018 09:27:03	Plugins	Info	Loading plugin: clientquery_plugin_win64.dll	
    29.11.2018 09:27:03	Query	Info	listening on 127.0.0.1:25639	
    29.11.2018 09:27:03	Plugins	Info	Loading plugin: gamepad_joystick_win64.dll	
    29.11.2018 09:27:04	Gamepad Plugin	Info	Found client raw input wnd proc	
    29.11.2018 09:27:04	Gamepad Plugin	Info	Cleared device list	
    29.11.2018 09:27:04	Plugins	Info	Loading plugin: rp_soundboard_win64.dll	
    29.11.2018 09:27:04	Gamepad Plugin	Info	Found device \\?\HID#VID_046D&PID_C52B&MI_02&COL03#7&AE52048&0&0002#{4D1E55B2-F16F-11CF-88CB-001111000030}	
    29.11.2018 09:27:04	Addon	Info	Addon up to date.	
    29.11.2018 09:27:04		Info	*** Time [PLUGINS]: 161	
    29.11.2018 09:27:04	Addon	Info	Addon up to date.	
    29.11.2018 09:27:04	Addon	Info	Addon up to date.	
    29.11.2018 09:27:04	Windows Audio Session	Devel	DeviceDeleteList::wait_for_deletes - enter - DeviceDeleteList	
    29.11.2018 09:27:04	Windows Audio Session	Devel	DeviceDeleteList::wait_for_deletes - leave - DeviceDeleteList	
    29.11.2018 09:27:04	SB	Debug	CurrentServerConnectionChanged: 1	
    29.11.2018 09:27:04		Info	*** Time [MAINWINDOW]: 480	
    29.11.2018 09:27:04		Info	*** Time [INIT]: 481	
    29.11.2018 09:27:04	ClientUI	Devel	Notifications init: Soundpack path: C:/Program Files/TeamSpeak 3 Client/sound\default	
    29.11.2018 09:27:04	ClientUI	Info	Qt version: 5.6.2	
    29.11.2018 09:27:04	ClientUI	Info	Using configuration location: C:\Users\John Doe\AppData\Roaming\TS3Client\settings.db	
    29.11.2018 09:27:04	Bookmarks	Info	Collecting autoconnect bookmarks	
    29.11.2018 09:27:04	ClientUI	Info	Last update check was: Do Nov 29 09:49:33 2018	
    29.11.2018 09:27:04		Info	Statistics report: User previously denied participation	
    29.11.2018 09:27:05	Newsticker	Info	Newsticker next check: Fr Nov 30 09:49:34 2018	
    29.11.2018 09:27:06	ClientUI	Info	Connect to server: MYDOMAIN.de	
    29.11.2018 09:27:06	ClientUI	Info	Trying to resolve MYDOMAIN.de	
    29.11.2018 09:27:06	TSDNS	Info	A/AAAA DNS resolve successful, "MYDOMAIN.de" =(h: 1234:567:890:abcdf::2 p:0), (h: 123.45.678.9 p:0)	
    29.11.2018 09:27:06	TSDNS	Info	A/AAAA DNS resolve for possible TSDNS successful, "MYDOMAIN.de" =(h: 1234:567:890:abcdf::2 p:0), (h: 123.45.678.9 p:0)	
    29.11.2018 09:27:06	TSDNS	Info	SRV DNS resolve unsuccessful, "_tsdns._tcp.MYDOMAIN.de" Domain name not found	
    29.11.2018 09:27:06	TSDNS	Info	SRV DNS resolve successful, "_ts3._udp.MYDOMAIN.de" =(h: MYDOMAIN.de p:9987)	
    29.11.2018 09:27:06	TSDNS	Info	A/AAAA DNS resolve successful, "MYDOMAIN.de" =(h: 1234:567:890:abcdf::2 p:0), (h: 123.45.678.9 p:0)	
    29.11.2018 09:27:06	ClientUI	Info	Lookup finished: ip=1234:567:890:abcdf::2 port=9987 query=MYDOMAIN.de error=0	
    29.11.2018 09:27:06	ClientUI	Info	Resolve successful: [1234:567:890:abcdf::2]:9987123.45.678.9:9987	
    29.11.2018 09:27:06	ClientUI	Info	Initiating connection: [1234:567:890:abcdf::2]:9987	
    29.11.2018 09:27:06	Windows Audio Session	Devel	DeviceDeleteList::wait_for_deletes - enter - DeviceDeleteList	
    29.11.2018 09:27:06	Windows Audio Session	Devel	DeviceDeleteList::wait_for_deletes - leave - DeviceDeleteList	
    29.11.2018 09:27:06	Windows Audio Session	Debug	WAS::openDevice-enter - {0.0.0.00000000}.{b44d6501-1a38-4a32-986e-86593f002547}	
    29.11.2018 09:27:06	Windows Audio Session	Devel	Mix Format: SRate:48000 Bitrate: 32 Channels: 2 - Lautsprecher (Realtek High Definition Audio)	
    29.11.2018 09:27:06	Windows Audio Session	Devel	Initializing with mix format. - Lautsprecher (Realtek High Definition Audio)	
    29.11.2018 09:27:06	Windows Audio Session	Info	Initialized with 2 channels in 32bit, 48kHz. - Lautsprecher (Realtek High Definition Audio)	
    29.11.2018 09:27:06	Windows Audio Session	Devel	WAS Buffer size: 1056 - Lautsprecher (Realtek High Definition Audio)	
    29.11.2018 09:27:06	Windows Audio Session	Debug	WAS::openDevice-leave - {0.0.0.00000000}.{b44d6501-1a38-4a32-986e-86593f002547}	
    29.11.2018 09:27:06	Windows Audio Session	Debug	WAS::startDevice-enter - {0.0.0.00000000}.{b44d6501-1a38-4a32-986e-86593f002547}	
    29.11.2018 09:27:06	Windows Audio Session	Debug	WAS::startDevice-leave - {0.0.0.00000000}.{b44d6501-1a38-4a32-986e-86593f002547}	
    29.11.2018 09:27:06	Windows Audio Session	Devel	DeviceDeleteList::wait_for_deletes - enter - DeviceDeleteList	
    29.11.2018 09:27:06	Windows Audio Session	Devel	DeviceDeleteList::wait_for_deletes - leave - DeviceDeleteList	
    29.11.2018 09:27:06	ClientUI	Info	Connect status: Connecting	
    29.11.2018 09:27:08	TSDNS	Info	TSDNS queried unsuccessfully 1234:567:890:abcdf::2:41144	
    29.11.2018 09:27:09	TSDNS	Info	TSDNS queried unsuccessfully 123.45.678.9:41144	
    29.11.2018 09:27:09	TSDNS	Info	No TSDNS found	
    29.11.2018 09:27:11	ClientUI	Info	Connect status: Disconnected	
    29.11.2018 09:27:12	ClientUI	Info	Initiating connection: 123.45.678.9:9987	
    29.11.2018 09:27:12	Windows Audio Session	Devel	DeviceDeleteList::wait_for_deletes - enter - DeviceDeleteList	
    29.11.2018 09:27:12	Windows Audio Session	Devel	DeviceDeleteList::wait_for_deletes - leave - DeviceDeleteList	
    29.11.2018 09:27:12	ClientUI	Info	Connect status: Connecting	
    29.11.2018 09:27:12	PktHandler	Devel	Puzzle solve time: 18	
    29.11.2018 09:27:12	ClientUI	Info	Connect status: Connected	
    29.11.2018 09:27:12	ClientUI	Info	Connect status: Establishing connection	
    29.11.2018 09:27:12	ClientUI	Info	Connect status: Connection established	
    29.11.2018 09:27:12	PermManager	Info	Loading permissions from cache	
    29.11.2018 09:27:12	SB	Debug	onUpdateClientEvent: serverId = 1, clientId = 1, invokerID = 0, invokerName = "", invokerUID = ""	
    29.11.2018 09:27:12	SB	Debug	onUpdateClientEvent: serverId = 1, clientId = 1, invokerID = 0, invokerName = "", invokerUID = ""
    Any idea? Did I do something wrong?

    I have the same "problem" and just asking myself HOW could I make my Teamspeak server listen also on ipv6? What do I need to do?
    Last edited by dante696; November 29th, 2018 at 04:03 PM. Reason: moved first post here and merged it with second post.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SRV issues cant connect using domain
    By apexGBG in forum Server Support
    Replies: 0
    Last Post: December 30th, 2015, 01:29 AM
  2. Domain won't connect
    By Gaterz in forum Server Support
    Replies: 0
    Last Post: November 7th, 2015, 07:18 PM
  3. Audio lag and slow to connect/load server
    By Ezash in forum Windows
    Replies: 1
    Last Post: September 12th, 2015, 05:38 PM
  4. TeamSpeak3 Connect/Disconnect Server Slow
    By _LiroN_ in forum Windows
    Replies: 4
    Last Post: June 4th, 2014, 05:25 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •