Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 2 of 2
  1. #1
    Join Date
    April 2017

    TeamSpeak 3 Client suddenly doesn't start

    Hey Guys,

    my TS3 Client doesn't start anymore. I double click the ts3 icon but nothing is happening.
    • I deinstalled and installed TeamSpeak
    • I restarted my computer several times.
    • I tried the 32-bit & 64-bit version
    • and I started TeamSpeak with Administrator permissions

    But nothing helped!
    I observed the Task-Manager while I tried to open TeamSpeak. TeamSpeak popped up for ~2 seconds and disappeared after that.
    It seems like Windows doesn't want TeamSpeak to open ....

    Pls help me

    Greetings Addi

  2. #2
    Join Date
    September 2012
    Download again from official downloads and then install that, or run the update.exe in your installation directory as admin.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 11
    Last Post: August 15th, 2017, 11:34 PM
  2. Client doesn´t start - no Ports available
    By Hircine83 in forum Windows
    Replies: 0
    Last Post: December 30th, 2015, 11:01 PM
  3. TS3 Client doesn't start
    By D3u577 in forum Windows
    Replies: 11
    Last Post: February 20th, 2010, 11:03 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts