Hello everyone,

i am running a server for a larger gaming community.
Recently one of the clients had problems to connect to the specific server.

He connects and gets the error message, that he is not able to connect.
Eventhough the server is running and is hosting ~30-50 other clients.

We already went through all the neccessary steps to diagnose the problem - without much success.

► Checking logs, both server and client side
► Reinstalling the client including the data in the appdata directory
► Connecting from within the same network with a tablet
► Running atraceroute to see if packets get dropped etc.
► Pinging the server
► Connecting by IP and Domain
► Enabling and disabling TSDNS
► Using a fresh Identity

Unfortunately i ran out of ideas for what to check and cant find the cause of the poblem.


This is an excerpt of the clients log
26.04.2017 16:46:06 ClientUI Info Trying to resolve synergy-of-steel.de
26.04.2017 16:46:07 TSDNS Info SRV DNS resolve successful, "_ts3._udp.synergy-of-steel.de" =(h: synergy-of-steel.de p:9988)
26.04.2017 16:46:07 TSDNS Info A/AAAA DNS resolve successful, "synergy-of-steel.de" =(h: 144.76.252.181 p:0)
26.04.2017 16:46:07 TSDNS Info SRV DNS resolve unsuccessful, "_tsdns._tcp.synergy-of-steel.de" DNS server returned answer with no data
26.04.2017 16:46:07 TSDNS Info A/AAAA DNS resolve for possible TSDNS successful, "synergy-of-steel.de" =(h: 144.76.252.181 p:0)
26.04.2017 16:46:07 TSDNS Info A/AAAA DNS resolve successful, "synergy-of-steel.de" =(h: 144.76.252.181 p:0)
26.04.2017 16:46:07 ClientUI Info Lookup finished: ip=144.76.252.181 port=9988 query=synergy-of-steel.de error=0
26.04.2017 16:46:07 ClientUI Info Resolve successful: 144.76.252.181:9988
26.04.2017 16:46:07 ClientUI Info Blacklist check ok
26.04.2017 16:46:07 ClientUI Info Initiating connection: 144.76.252.181:9988
26.04.2017 16:46:07 TSDNS Info TSDNS found at 144.76.252.181:41144 and queried successfully. Result: (h: 144.76.252.181 p:9988)
26.04.2017 16:46:07 TSDNS Info A/AAAA DNS resolve successful, "blacklist.teamspeak.com" =(h: 46.105.112.65 p:0)
26.04.2017 16:46:07 ClientUI Info Connect status: Connecting
26.04.2017 16:46:07 PktHandler Devel Puzzle solve time: 5
26.04.2017 16:46:18 ClientUI Info Connect status: Disconnected
26.04.2017 16:46:18 ClientUI Info Failed to connect to server, want autoreconnect = 0
This is the according excerpt from the server log
2017-04-26 16:46:10.489530|INFO |VirtualServerBase|4 |client connected 'Test'(id:2231) from 89.183.xxx.xxx:53332
2017-04-26 16:46:35.392306|INFO |PktHandler |4 |Cleaning up connection because of 9 resends of COMMAND packet
2017-04-26 16:46:35.392393|INFO |PktHandler |4 |Dropping client 2 because of resend timeout
2017-04-26 16:46:35.392432|INFO |VirtualServerBase|4 |client disconnected 'Test'(id:2231) reason 'reasonmsg=connection lost'


I would very much welcome further ideas of what to investigate.

Thank you very much and best regards,
Sequence