Results 1 to 6 of 6
  1. #1
    Join Date
    October 2015

    Push to talk hotkeys not working


    Since the latest Teamspeak3 updates in 2017, no hotkey I bind to my push to talk will work - even if I only have Teamspeak open.
    I want to use the 'control' button in the lower left corner of the keyboard.

    I use Imac - macOS Sierra, version 10.12.4 and Teamspeak3 - 3.1.4

    Here is what I have tried so far to fix the issue and has not worked:

    - Reseted Nvram and SMC

    - Tried to download older versions of Teamspeak3, but the problem persists there and no bind works.

    - Checked my Accessibility and enabled my Teamspeak 3 Client via this link: h

    I'd appreciate it if you did not move this post to the "FN button issue post" as this has nothing to do with that button - but every single key I try to bind.

    I sincerely hope you can help.

  2. #2
    Join Date
    May 2017
    I am seeing the exact same issue on OSX Sierra. The default hotkey (left cmd + left alt) does not work, and no keys register when trying to set another key.

    This is only a problem as of the latest release and was not a problem in the past release. I've tried setting the appropriate accessibility permissions but no luck.

  3. #3
    Join Date
    March 2015
    This is still not working. I am not able to assign any hot keys in TeamSpeak on my iMac. TeamSpeak does appear in the Accessibility tab under Security and Privacy. Still no joy. A response from TeamSpeak developers on this issue is needed.


  4. #4
    Join Date
    September 2017

    This is still not working. macOS Sierra, version 10.12.6 and Teamspeak3 - 3.1.6. Can't bind any hotkey.

    Developers, help!! Fix it plzz

  5. #5
    Join Date
    March 2015
    Ditto to the above post - it is now September 12th and still no word on a fix?

    Developers, help!! Fix it plzz

  6. #6
    Join Date
    October 2017

    Same annoying problem

    MacOS Sierra 10.12.6 4K iMac
    PTT hotkey assignment works in test, but not when connected to server
    TS3 client is enabled in privacy settings.

    Any idea as to what the problem is?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: August 21st, 2016, 02:43 AM
  2. Problems with push to talk hotkeys
    By Khator33 in forum Client Support
    Replies: 1
    Last Post: July 22nd, 2016, 08:30 AM
  3. Push to talk doesn't run with Mouse Hotkeys
    By Itania in forum Windows
    Replies: 3
    Last Post: December 4th, 2015, 09:13 PM
  4. Replies: 31
    Last Post: July 26th, 2011, 07:02 PM
  5. Still problem with Hotkeys or push-to-talk working.
    By shentoza in forum Client Support
    Replies: 1
    Last Post: July 2nd, 2011, 07:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts