Forum

Results 1 to 8 of 8
  1. #1
    Join Date
    June 2017
    Posts
    8

    Can not set Avatars

    Hey id just moved my server from a OpenVZ Server to a LXC Server i just normally installed it and after that i pasted the following files on my server:

    - files folder
    - ts3server.sqlitedb
    - serverkey.dat
    - licencekey.dat

    Now no one can ste avatars and ther is no error messages when i try to set one.

    Need Help pls

    Thanks for any Help

  2. #2
    Join Date
    June 2008
    Posts
    17,934
    Check your server log for errors in that case and make sure needed port for file transfer is open.
    Maybe your user has no permissions to read and write into your folders.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    June 2017
    Posts
    8
    In the log stands that the server did not have permisiions to open the avatars.

    2017-06-26 18:18:44.252922|INFO | | |Error opening file "files/virtualserver_2/internal/avatar_nnomkoodjnanhdmgdjeledenhpfkfbndnjkpkbnl": Permission denied

    i had already given the ts3 user root permisssions with:
    sudo adduser ts3 root

    what did i do wrong?

  4. #4
    Join Date
    June 2017
    Posts
    8
    Ive just fixed the issue.
    The Teamspeak user just not had the right rights to write / read in the folder so i just sayed per root command the he becomes more rights.

    chmod -v 777 /home/ts3

    thats all

  5. #5
    Join Date
    June 2008
    Posts
    17,934
    You should remove the root privileges again and only use root to manage your system.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  6. #6
    Join Date
    September 2012
    Posts
    6,076
    Quote Originally Posted by MrIceCubeTV View Post
    Ive just fixed the issue.
    The Teamspeak user just not had the right rights to write / read in the folder so i just sayed per root command the he becomes more rights.

    chmod -v 777 /home/ts3

    thats all
    the nuclear option...

    Better way would be to make the user running the TS3 server the owner of it's own installation directory and everything in it.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  7. #7
    Join Date
    June 2017
    Posts
    8
    how can i do this?

  8. #8
    Join Date
    July 2015
    Posts
    31
    https://www.lifewire.com/create-user...ommand-3572157

    Then go to the users home directory and put the TS there, start the script as the user, by loggin in to the user or su to the user.
    I might also be wise to learn something about Linux, and sure also about security.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. cant add avatars on my ts
    By rubberband in forum General Questions
    Replies: 1
    Last Post: May 22nd, 2017, 11:39 AM
  2. avatars ...
    By Aizzy in forum Linux / FreeBSD
    Replies: 1
    Last Post: October 26th, 2014, 12:23 AM
  3. [Not possible] Cannot set avatars from URL...
    By VacantPlanets in forum Windows
    Replies: 2
    Last Post: April 4th, 2014, 05:16 AM
  4. Avatars
    By iflog in forum Client Support
    Replies: 14
    Last Post: August 6th, 2010, 07:45 AM
  5. Avatars
    By iflog in forum General Questions
    Replies: 8
    Last Post: February 14th, 2010, 12:20 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •