Forum

Results 1 to 2 of 2
  1. #1
    Join Date
    July 2017
    Posts
    1

    Previously bought app, won't let me re-download

    I previously purchased TeamSpeak on my old iPhone 4s, but due to me upgrading to a better phone-5s, the app is obviously not on the phone. I went to download it again but it's asking me to buy it again which I can't as I am basically broke at the moment. I used the exact same apple ID, which means it should still be linked within my account. With higher purchasable applications, it allows me to re-download them after the upgrade, yet this one app doesn't? I would appreciate if someone could get in contact with me, so I can get my app back. I would use my computers TeamSpeak but I do not have a working microphone currently so I can only use my phone for contacting my online friends via TeamSpeak which I am currently unable to do due to the circumstances.. Thanks - Paige

  2. #2
    Join Date
    June 2008
    Posts
    18,417
    It could be that you had the old app installed. The old app was replaced & removed in 2012.
    Check your account and make sure you own the Current app

    Quote Originally Posted by Chris View Post
    In order to be able to help you, please open a ticket with our Sales department using the email address that you use for your ITunes account and provide the following data:
    • Payment receipt of the original app purchase
    • Country your Apple account is registered under (the country you purchase from)

    our Sales department will then review your proof of purchase and help you as soon as possible.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: November 25th, 2014, 07:00 PM
  2. Get Previously Used Names
    By RaJiska in forum Windows
    Replies: 1
    Last Post: May 29th, 2014, 10:13 PM
  3. previously started server crashed
    By Big_Jul in forum Linux / FreeBSD
    Replies: 0
    Last Post: April 12th, 2014, 04:51 PM
  4. Unable to find hotkeys.ini like previously
    By r6-1st in forum Windows
    Replies: 4
    Last Post: March 1st, 2013, 11:21 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •