Forum

Results 1 to 6 of 6
  1. #1
    Join Date
    August 2017
    Posts
    1

    Using themes/addons and icons in Arch Linux

    I'm trying to figure out why the x64 Linux client on Arch (full details below) is not playing nicely with any mods I've tried installing. Our TS3 package builds and installs perfectly to /opt/teamspeak3, installs $HOME dirs, and doesn't complain about Qt libs or anything (I'm running Cinnamon), but the in-app interface under Addons just plain does not function. I don't know if this is by design though, since I'm running a GTK desktop which also uses OpenGL exclusively because that's how Muffin rolls. On top of that I have some custom Qt settings like lib-gnomeui with qgnomeplatform defined as my default Qt app theme, and honestly I'm not smart enough to determine exactly which level of this is the issue. It could also just be how our Arch package is designed, never meant to use the in-app API stuff, but the Wiki and Google aren't much help. I went to the AUR and got a couple plugins, the SDK, and found a teamspeak3-addon-installer package that built fine, but doesn't do much. But having plugins in our AUR tells me that it's possible ANY addon or mod just won't be compatible out of the box with Arch and our x64 client. Again though, that's just me guessing.

    Anyone have any advice here? I'm competent with gconf, Qt, python and bash. Nothing special, but if some kind of full recompile needs to happen or if I'm shit out of luck doing this the easy way, I might be able to debug it. I prefer the easy way though, like having TS3 itself handle premade packs, like it presumably does for Windows, Mac and maybe Ubuntu.

    If my only choice is total manual install by overriding default files in the TS3 root dir, so be it, I can handle that if it's a last resort. However, I have a bad feeling that my Qt or Gnome/Cinnamon theme settings or the way OpenGL is run statically in Muffin that it's gonna look like shit or be half-broken.

    System info (inxi -S):

    Kernel: 4.12.4-1-ARCH x86_64 (64 bit) Desktop: Cinnamon 3.4.4 Distro: Arch Linux

  2. #2
    Join Date
    September 2012
    Posts
    6,078
    After you've hit the Install button on an addon in Tools -> Options -> myTeamSpeak -> Browse online what happens exactly?

    Do you see a download bar pop up at the bottom?
    What does it say when the progress is done (Does it say Addon installed? (or similar))?
    Once the bar (if it appears) is done, wait 10-30 seconds and check the Client Log (Tools -> Client Log). Post the last 20 or so lines.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  3. #3
    Join Date
    December 2009
    Location
    Germany
    Posts
    288
    As an Archlinux-User i may know, what is the problem

    This is an Upstream-Issue, because there is a package for archlinux, which does not do well when using addons from the addon-browser.
    There is no "binary" or "script" which refers to package_inst, so the client cannot install plugins.

    As a fix, execute the following within a rootshell:

    ln -s /opt/teamspeak3/package_inst /usr/bin/package_inst

    If this should be fixxed within the Archlinux-Package, please open a new bugrequest at https://bugs.archlinux.org/ for the "teamspeak3"-package.

  4. #4
    Join Date
    August 2017
    Posts
    1
    ty for the info

  5. #5
    Join Date
    August 2017
    Posts
    2

    This Helped Me Fix The Issue

    In addition to this I recommend everyone to check their firewall rules.

    My firewall rules by default blocked connections to servers.

  6. #6
    Join Date
    March 2019
    Posts
    1

    install icon packs or themes

    hey there,
    i want to install themes and icon packs on my arch linux. but when i use
    Code:
    /opt/teamspeak3/package_inst /path_to_package/package
    i get the following error:
    Code:
    QFactoryLoader::QFactoryLoader() checking directory path "/opt/teamspeak3/platforms" ...
    QFactoryLoader::QFactoryLoader() looking at "/opt/teamspeak3/platforms/libqxcb.so"
    Found metadata in lib /opt/teamspeak3/platforms/libqxcb.so, metadata=
    {
        "IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
        "MetaData": {
            "Keys": [
                "xcb"
            ]
        },
        "className": "QXcbIntegrationPlugin",
        "debug": false,
        "version": 329217
    }
    
    
    Got keys from plugin meta data ("xcb")
    Cannot load library /opt/teamspeak3/platforms/libqxcb.so: (/opt/teamspeak3/platforms/libqxcb.so: symbol _ZN26QPlatformIntegrationPluginD2Ev version Qt_5 not defined in file libQt5Gui.so.5 with link time reference)
    QLibraryPrivate::loadPlugin failed on "/opt/teamspeak3/platforms/libqxcb.so" : "Cannot load library /opt/teamspeak3/platforms/libqxcb.so: (/opt/teamspeak3/platforms/libqxcb.so: symbol _ZN26QPlatformIntegrationPluginD2Ev version Qt_5 not defined in file libQt5Gui.so.5 with link time reference)"
    qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
    This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
    
    Available platform plugins are: xcb.
    
    [1]    26215 abort (core dumped)  /opt/teamspeak3/package_inst
    already reinstalled xcb but it is not working.
    Last edited by dante696; March 5th, 2019 at 08:04 AM. Reason: merged

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Evaluation] pack addons to zip on linux and libquazip
    By VJean in forum Bug Reports [EN/DE]
    Replies: 12
    Last Post: September 9th, 2016, 10:18 PM
  2. TS3 Server on s390x arch?
    By Kirbysha in forum Linux / FreeBSD
    Replies: 2
    Last Post: May 21st, 2016, 12:46 PM
  3. Replies: 0
    Last Post: March 13th, 2015, 11:20 PM
  4. Teamspeak 3 as a service in Arch Linux Distribution
    By mpqo_ in forum Linux / FreeBSD
    Replies: 0
    Last Post: June 30th, 2013, 04:15 PM
  5. Suggestion for the Addons Page: Link to the own addons profile
    By Stefan1200 in forum Suggestions and Feedback
    Replies: 6
    Last Post: October 26th, 2011, 08:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •