First, let me get some system information out of the way:

I'm running Windows 10 Home on my ASUS GL552-VW DH-71. I've connected my PreSonus Audiobox USB audio interface to my computer and I have my condenser microphone plugged in to my Audiobox USB.

Now, my Audiobox USB is working fine. I'm able to record audio with it inside of audio workstations like Pro Tools and FL Studio with no problem whatsoever. I'm also able to hear myself through my headphones when there's no recording program running (which is how it should be). Yes, my Audiobox is also selected as my default audio device in Windows.

Name:  hgujXvW.png
Views: 288
Size:  10.1 KB

The problem appears inside of the Team Speak Client. I'm able to open the client and set up my audio properly. I go through the sound test and I can see the audio from my microphone showing up on the db meter inside the Team Speak Client. However, when I'm finished and join a server, I can hear everyone talking but I can't be heard. I go back into my settings and my Audiobox is still the selected input device (just like how I set it up before) but now there's no input signal when I run the sound test.

I've tried everything from restarting my computer to unplugging my Audiobox and even reinstalling the drivers (Universal Control). It's really annoying that it works right up until I'm connected to a server. I'm still able to hear the input from my microphone in my headphones (which means that everything is at least plugged in properly). Nothing I try seems to be working.

Looking for any help I can get. Thanks in advance!